11 Replies Latest reply: Apr 27, 2011 2:50 PM by Alastair Mcarthur
jazzplayr Level 1 Level 1 (0 points)
I'm having an issue with Logic 9 that has me stumped. My system configuration is: Logic Pro 9.1.3, iMac 2.4Ghz, 3gb ram, system 10.6.7, MOTU 828 interface.

Here's the problem; Whenever I press record, (or "pause" before recording) there is a long pause / delay. Click record (or pause), nothing happens for about 10 seconds, then spinning beach ball for about 20 more seconds, then recording begins. No overload messages or disk activity indication. it just seems not to be able to access the disk for about 30 seconds. It doesn't matter if there's 24 tracks or only one, or how many plug-in's are enabled. Here's another weird thing- The VERY FIRST TIME you try to record, after opening a project, it works normally, i.e. starting instantly, but subsequent attempts always have this long pause / delay. Playback always begins instantly if not trying to record, so there's no problem mixing.

I came to Logic 9 from Logic 7, which never exhibited this behavior with the same computer, same disks and similar projects (and still doesn't). I have preferences set the same as in Logic 7. What's the deal with Logic 9?

I've tried two different external firewire drives, and the internal drive, all with the same result. I tried tossing out all the preferences files I could find, repairing permissions, and turning off journaling in Disk Utility. No luck there either.

This is driving me crazy, and it makes Logic 9 essentially useless to me. Does anyone have any ideas?

iMac 20" 2.4Ghz, Mac OS X (10.6.7)
  • 1. Re: Looong pause after clicking record before recording begins
    Pancenter Level 5 Level 5 (7,640 points)
    Are any of your external drives by any chance formatted the older Fat32 PC file system. Some drives ship like that.

    Doubtful since you mentioned turning journaling off.

    pancenter-
  • 2. Re: Looong pause after clicking record before recording begins
    zmix Level 1 Level 1 (115 points)
    As you've seen in the associated thread on pausing before playback, there are a lot of theories floating around out there, but the fact remains that this problem never happens in Logic 7 on my system and always happens with Logic 9.1.3.

    It's Logic 9 that is the issue, NOT the computer or the OS, etc....
  • 3. Re: Looong pause after clicking record before recording begins
    JumpingInFire Level 1 Level 1 (5 points)
    In System Preferences under Energy Saver is "Put the hard disks to sleep when possible" checked? If so uncheck it.
  • 4. Re: Looong pause after clicking record before recording begins
    jazzplayr Level 1 Level 1 (0 points)
    Thanks for the suggestions. Yes, I have checked all of the above, to no avail. I'm inclined to agree with zmix that it's a bug in Logic 9, but not every user has it, so there must be some system configuration that works. Logic 7 is still working great, but I would like to use the software I paid for.

    After owning and administering Macs since 1984, I thought I was pretty savvy about troubleshooting software and hardware, but this one has me beat. Any other ideas would be welcome.
  • 5. Re: Looong pause after clicking record before recording begins
    Pancenter Level 5 Level 5 (7,640 points)
    jazzplayr wrote:
    Thanks for the suggestions. Yes, I have checked all of the above, to no avail. I'm inclined to agree with zmix that it's a bug in Logic 9, but not every user has it, so there must be some system configuration that works.


    Yes, zmix is correct, I forgot about the previous thread...

    Under Preferences/Audio down at the bottom is a pop-up box that allows limiting/selecting the number of processor cores the computer uses. Try using other settings rather than "Automatic".

    pancenter-
  • 6. Re: Looong pause after clicking record before recording begins
    tape user Level 1 Level 1 (0 points)
    I starting having this exact problem last night, and i can no longer work. the pause is soooooo long. i've tried the above suggestion to no avail.

    bummer.

    awaiting help.

    gonna call apple now.
  • 7. Re: Looong pause after clicking record before recording begins
    tape user Level 1 Level 1 (0 points)

    i wiped my drive completely and did a clean install of the OS and logic. TO NO AVAIL!!!!

     

    i solved the problem by removing my additional internal drives. not sure why they are causing the problem. I've wiped them both, and as of now everything works fine with one of them in, but not both. frustrating, but at least logic is running normally.

    if you have internal drives, try removing them and see if that helps.

    good luck.

  • 8. Re: Looong pause after clicking record before recording begins
    wolfgerb Level 1 Level 1 (15 points)

    hi,

     

    i once had this happen while recording to my new macbook´s internal harddrive.

    I turned off journaling of the internal disc via the disc utility app and the problem was gone.

    Maybe this helps.

     

    greetings wolfger

  • 9. Re: Looong pause after clicking record before recording begins
    Pancenter Level 5 Level 5 (7,640 points)

    Do the drives have jumpers.

     

    Could it be possible both are not set to "Cable Select"

     

    pancenter-

  • 10. Re: Looong pause after clicking record before recording begins
    chorleyman Level 4 Level 4 (1,415 points)

    You may be going in the right direction with something like that - I don't know, I'm not that technical a person, but when you get hang ups like that it seems fairly obvious that there's a disk drive access problem.

     

    About 8 years ago, I used to use a digital recording system (for home users, like me - Akai DPS16) and it seemed to be accepted practice (and specifically documented in the manual) that you needed to defragment the inbuilt hard drive for specific problems like this, but, of course, we're supposed to have come a long way since then.

     

    It looks like that there's some kind of conflict within the OS with certain configurations since drive access management is a basic OS function rather than a Logic or Core Audio one?

  • 11. Re: Looong pause after clicking record before recording begins
    Alastair Mcarthur Level 1 Level 1 (120 points)

    Hi,

     

    I'm running Logic Pro 9.1.3. If you're not you may see something slightly different here.

     

    Go to Preferences>Audio>Devices>Core Audio. Look at the settings in the IO Buffer Size Field. By default it is usually 256 samples. On my system iMac 2.66 GHz Core 2 Duo, 4GB, Mac OS 10.6.7, this gives a figure for the Roundtrip Latency of 13.6 ms. The lower the buffer size the shorter the latency but the more powerful your system needs to be to be able to process the input signal. Try changing this and see if it reduces the recording delay you are experiencing.

     

    Alastair.