5 Replies Latest reply: Dec 19, 2011 12:34 PM by wuerzsheriff
ehzastrow Level 1 Level 1 (0 points)
Just posting this because I recently had this issue and managed to solve it. I found a few archived issues regarding this topic, and wanted to reply with my experiences and solution.

I was recently using TextEdit on a .txt file on a mounted volume that had been encrypted with TrueCrypt. For some reason, I ended up having to force-quit text edit. Next time I went to open up TextEdit, it complained about an application error and wouldn't launch.

I found that when the TrueCrypt volume was mounted, TextEdit would indeed launch. Unmount it, and TextEdit crashes on launch.

I tried deleting the TextEdit preferences files in ~/Library/Preferences/ and this did not solve the problem.

What finally solved the issue was: Launch TrueCrypt, mount encrypted volume, then eject mounted volume from within Finder (instead of dismounting volume from within TrueCrypt). THEN dismount volume from within TrueCrypt. After that, TextEdit would launch normally.

Must be some strangeness going on with the TrueCrypt built-in "dismount volume" process that doesn't fully notify the OS that it is ejecting and dismounting the volume.

turing machine, Mac OS X (10.5.6)
  • 1. Re: TextEdit crash on launch - solved
    ryan42 Level 3 Level 3 (825 points)
    Out of curiosity, are there any Console log messages that happen when TextEdit crashes? I only ask because I can't imagine an unmounted volume affecting it like that.
  • 2. Re: TextEdit crash on launch
    ehzastrow Level 1 Level 1 (0 points)
    Yeah, it's doing it again too.

    From Console / All Messages, here's what appears when I launch TextEdit:

    3/23/11 11:48:30 AM com.apple.launchd.peruser.501[145] ([0x0-0x3a03a].com.apple.TextEdit[690]) Job appears to have crashed: Segmentation fault
    3/23/11 11:48:30 AM ReportCrash[692] Saved crash report for TextEdit[690] version 1.6 (264) to /Users/ehzastrow/Library/Logs/DiagnosticReports/TextEdit2011-03-23-114830fairtrade.crash

    From the Crash Report:

    Process: TextEdit [690]
    Path: /Applications/TextEdit.app/Contents/MacOS/TextEdit
    Identifier: com.apple.TextEdit
    Version: 1.6 (264)
    Build Info: TextEdit-2640000~1
    Code Type: X86-64 (Native)
    Parent Process: launchd [145]

    Date/Time: 2011-03-23 11:48:29.808 -0500
    OS Version: Mac OS X 10.6.6 (10J567)
    Report Version: 6

    Exception Type: EXCBADACCESS (SIGSEGV)
    Exception Codes: KERNINVALIDADDRESS at 0x0000000000000011
    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Application Specific Information:
    objc_msgSend() selector name: _cfTypeID

    Thread 0 Crashed: Dispatch queue: com.apple.main-thread
    0 libobjc.A.dylib 0x00007fff8200211c objc_msgSend + 40
    1 ...ple.CoreServices.CarbonCore 0x00007fff839af807 CFNumber::CFNumber(void const* const&) + 39
    2 ...ple.CoreServices.CarbonCore 0x00007fff839ad81c CFURLCreateByResolvingDataInBookmark(__CFAllocator const*, BookmarkData&, unsigned int, unsigned long, __CFArray const*, unsigned char*, __CFError**) + 2671
    3 ...ple.CoreServices.CarbonCore 0x00007fff839ae15b copyAndMountVolumeRequiredByBookmark(__CFAllocator const*, BookmarkData&, unsigned int, unsigned long, unsigned char*, __CFError**) + 234
    4 ...ple.CoreServices.CarbonCore 0x00007fff839acdf3 CFURLCreateByResolvingDataInBookmark(__CFAllocator const*, BookmarkData&, unsigned int, unsigned long, __CFArray const*, unsigned char*, __CFError**) + 70
    5 ...ple.CoreServices.CarbonCore 0x00007fff839af477 _CFURLCreateByResolvingBookmarkData + 1361
    6 com.apple.CoreFoundation 0x00007fff83dcc6d6 +[NSURL URLByResolvingBookmarkData:options:relativeToURL:bookmarkDataIsStale:error:] + 86
    7 com.apple.AppKit 0x00007fff865aede8 +[NSDocumentController(NSInternal) _resolveAutoreopenRecord:intoDocumentURL:contentsURL:tryAgainLater:] + 183
    8 com.apple.AppKit 0x00007fff863744a0 -[NSDocumentController(NSInternal) _autoreopenDocuments] + 402
    9 com.apple.AppKit 0x00007fff8637425d -[NSApplication(NSAppleEventHandling) _handleAEOpen:] + 51
    10 com.apple.AppKit 0x00007fff86373f81 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 77
    11 com.apple.Foundation 0x00007fff84194f62 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 360
    12 com.apple.Foundation 0x00007fff84194d92 _NSAppleEventManagerGenericHandler + 114
    13 com.apple.AE 0x00007fff821af323 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned int, unsigned char*) + 162
    14 com.apple.AE 0x00007fff821af21c dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 32
    15 com.apple.AE 0x00007fff821af123 aeProcessAppleEvent + 210
    16 com.apple.HIToolbox 0x00007fff84a35765 AEProcessAppleEvent + 48
    17 com.apple.AppKit 0x00007fff8627904b _DPSNextEvent + 1205
    18 com.apple.AppKit 0x00007fff862787a9 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155
    19 com.apple.AppKit 0x00007fff8623e48b -[NSApplication run] + 395
    20 com.apple.AppKit 0x00007fff862371a8 NSApplicationMain + 364
    21 com.apple.TextEdit 0x0000000100000fb8 0x100000000 + 4024

    Thread 1: Dispatch queue: com.apple.libdispatch-manager
    0 libSystem.B.dylib 0x00007fff83fae16a kevent + 10
    1 libSystem.B.dylib 0x00007fff83fb003d dispatch_mgrinvoke + 154
    2 libSystem.B.dylib 0x00007fff83fafd14 dispatch_queueinvoke + 185
    3 libSystem.B.dylib 0x00007fff83faf83e dispatch_workerthread2 + 252
    4 libSystem.B.dylib 0x00007fff83faf168 pthreadwqthread + 353
    5 libSystem.B.dylib 0x00007fff83faf005 start_wqthread + 13

    Thread 2:
    0 libSystem.B.dylib 0x00007fff83faef8a _workqkernreturn + 10
    1 libSystem.B.dylib 0x00007fff83faf39c pthreadwqthread + 917
    2 libSystem.B.dylib 0x00007fff83faf005 start_wqthread + 13

    Thread 0 crashed with X86 Thread State (64-bit):
    rax: 0x0000000000000400 rbx: 0x0000000000000005 rcx: 0x00007fff706f9378 rdx: 0x000000000000bfef
    rdi: 0x000000010012b1a0 rsi: 0x00007fff86974cf6 rbp: 0x00007fff5fbfd5a0 rsp: 0x00007fff5fbfd578
    r8: 0x00000000000005c8 r9: 0x000000010012b490 r10: 0x0000000000000001 r11: 0x0000000000000001
    r12: 0x00007fff5fbfd720 r13: 0x00007fff5fbfd710 r14: 0x0000000000000000 r15: 0x0000000000000000
    rip: 0x00007fff8200211c rfl: 0x0000000000010206 cr2: 0x0000000000000011

    Binary Images data omitted.

    Now, I'll attempt to mount the encrypted volume, then eject it from Finder, then dismount it from TrueCrypt, then launch TextEdit: Nope, same result

    Now mounting TrueCrypt volume, and opening TextEdit: Worked

    Now ejecting TrueCrypt vol (from Finder only, not unmounting from TrueCrypt) and then opening TextEdit: Worked - and it remounted the volume in Finder. The following three lines appeared in Console:

    3/23/11 11:57:07 AM hdiejectd[1496] parentKeyForDiskUsingAlias: disk1 FSResolveAliasWithMountFlags returned -120
    3/23/11 11:57:07 AM fseventsd[38] could not open <</Volumes/NO NAME/.fseventsd/fseventsd-uuid>> (No such file or directory)
    3/23/11 11:57:07 AM fseventsd[38] log dir: /Volumes/NO NAME/.fseventsd getting new uuid: CAD29D0A-7180-4A16-BF4D-5D1475E28CF5

    Now I eject volume from Finder, and dismount from within TrueCrypt:

    3/23/11 11:59:40 AM KernelEventAgent[35] tid 00000000 received event(s) VQ_DEAD (32)
    3/23/11 11:59:44 AM hdiejectd[1496] quitCheck: calling exit(0)

    Now attempting to launch TextEdit (crash, same as before):

    3/23/11 12:00:39 PM com.apple.launchd.peruser.501[145] ([0x0-0x59059].com.apple.TextEdit[1853]) Job appears to have crashed: Segmentation fault
    3/23/11 12:00:39 PM ReportCrash[1855] Saved crash report for TextEdit[1853] version 1.6 (264) to /Users/ehzastrow/Library/Logs/DiagnosticReports/TextEdit2011-03-23-120039fairtrade.crash

    Now, what really boggles me, is that launching TextEdit after ejecting (via Finder) the volume, results in the volume being remounted automatically by Finder...

    Nor can I reproduce the "solution" that seemed to fix this the first time. HMMMM.....
  • 3. Re: TextEdit crash on launch
    ryan42 Level 3 Level 3 (825 points)
    Very interesting. Have you updated to 10.6.7?
  • 4. Re: TextEdit crash on launch - solved
    demarca.pl Level 1 Level 1 (0 points)
    I had the same issue.
    I rebuilded texedit, reinstalled maxfuse and truecrypt, and this did not solve the problem.
    Finally I deleted every single file with "textedit" in filename from ~/Library/ subfolders - and now textedit works fine.

    Yes, OSX 10.6.7

    Message was edited by: demarca.pl
  • 5. Re: TextEdit crash on launch - solved
    wuerzsheriff Level 1 Level 1 (5 points)

    OS 10.6.7.

    After a system hangup working on a mounted truecrypt drive, Textedit kept crashing.



    user/library/Autosave Information/com.apple.TextEdit.plist


    works again!