10 Replies Latest reply: Nov 26, 2013 5:44 PM by turingtest2
Hoqr Level 1 Level 1 (0 points)
I recently bought a used, but "factory refurbished" 80gb ipod classic. when it arrived it had one song on it and it played perfectly and then i was able to put another 100 or so songs onto it. tonight, when i tried to connect it to my computer to put more music on itunes and my ipod froze. I tried closing itunes using task manager multiple times but it never worked and when i tried to eject my ipod from the computer it still said that it was being used in a application (itunes). So, i just unplugged my ipod without ejecting it or anything and it said it needed to be restored. I went back on itunes and tried to restore it but the status bar on my ipod got to a certain point and then it restarted and said it needed to be restored again. I have tried restoring it multiple times now and it keeps restarting in the same place on the status bar. Please help!

Dell, Windows 7, Have 2 ipod touchs and ipod classic on 1 computer
  • 1. Re: iPod Classic restoration issues
    turingtest2 Level 8 Level 8 (46,590 points)
    Sounds like your refurb. might need to be swapped out. Used is OK, not usable isn't.

    *Check your iPod with Diagnostics Mode*
    It's possible that your iPod's hard drive has started to fail. Take your iPod and place your right thumb on the centre SELECT button and your left on the top MENU button. Press down both thumbs for about 6 seconds until your iPod reboots. Immediately move your left thumb around to the rewind button |<< on the left and hold this down together with SELECT for a further 6 seconds. Your iPod should now switch into Diagnostic Boot mode. Press MENU for *Manual Test*, then select *IO > HardDrive > HDSMARTData* to reveal your stats. For comparison here are mine for my 2 year old 6th Generation Classic:
    Retracts: 889
    Reallocs: 12
    Pending Sectors: 0
    PowerOn Hours: 2202
    Start/Stops: 894
    Temp: Current 24c
    Temp: Min 10c
    Temp: Max 50c

    Take a note of your results. When finished press *SELECT & MENU* for 6 seconds to reset the iPod again.

    With modern disc drives sectors are no longer marked bad by a disc scan, if the SMART firmware detects a sector it has trouble accessing it will attempt to invisibly reallocate it to a spare area of the disc.

    Note that I've only 12 remapped sectors and none pending. To help explain what the numbers mean here is an extract from the Wikipedia S.M.A.R.T. article:
    *Reallocated Sectors Count*
    Count of reallocated sectors. When the hard drive finds a read/write/verification error, it marks this sector as "reallocated" and transfers data to a special reserved area (spare area). This process is also known as remapping, and "reallocated" sectors are called remaps. This is why, on modern hard disks, "bad blocks" cannot be found while testing the surface – all bad blocks are hidden in reallocated sectors. However, as the number of reallocated sectors increases, the read/write speed tends to decrease. The raw value normally represents a count of the number of bad sectors that have been found and remapped. Thus, the higher the attribute value, the more sectors the drive has had to reallocate.

    *Pending sector count*
    Number of "unstable" sectors (waiting to be remapped, because of read errors). If an unstable sector is subsequently written or read successfully, this value is decreased and the sector is not remapped. Read errors on a sector will not remap the sector (since it might be readable later); instead, the drive firmware remembers that the sector needs to be remapped, and remaps it the next time it's written.

    Large numbers of Reallocs or Pending Sectors would suggest your drive is failing and that you may need to repair or replace your iPod. Check your stats after another attempt to update your iPod. If the numbers increase that again points to hard drive failure. While it won't be good news at least you'll know it isn't some random software problem and you can decide what to do next.

    tt2
  • 2. Re: iPod Classic restoration issues
    Hoqr Level 1 Level 1 (0 points)
    Thank you for that i looked it up and got the following numbers:
    retracts:6
    reallocs:1552
    pending sectors:8
    PowerOn Hours:883
    starts/stops:15980
    current temp:23c
    min temp:2c
    max temp:54c

    most of my numbers are drastically different than yours and it sounds like a hard drive failure to me. Does that sound about right?
  • 3. Re: iPod Classic restoration issues
    turingtest2 Level 8 Level 8 (46,590 points)
    Doesn't look too good, 54c is above max op. temp of 50c which might be a factor in the health of the drive. The number of start/stops seems high although I'm not really sure how that figure should be interpreted. The 1552 remapped sectors may only be the tip of the iceberg. The 8 pending sectors are probably not being released by the restore process which might explain your current locak of progress in restoring it. You could try a low level full (not quick/fast) format of the drive. As long as all the problem areas of the disc surface are identified, mapped out, and the damage isn't progressive then it isn't a problem. However if you've recently bought this as a refurb from Apple I would suggest that you try to get it exchanged for one in better health.

    tt2
  • 4. Re: iPod Classic restoration issues
    Hoqr Level 1 Level 1 (0 points)
    ok i was going to send it back today to get a new one thanks for the advice, i checked the hard drive again after i tried to restore it one more time and it still had those high numbers thanks for the advice.
  • 5. Re: iPod Classic restoration issues
    Hoqr Level 1 Level 1 (0 points)
    hard drive failed
  • 6. Re: iPod Classic restoration issues
    B_tay Level 1 Level 1 (0 points)
    tt2,

    I came across this post while dealing with similar issues; I've tried restoring my 160G classic every which way, from changing USB ports to uninstalling iTunes. When I connect, iTunes only shows one option for my iPod -- 'summary.' And it doesn't even show it as my name (as it does when it's factory direct); the alias is just 'Ipod.'

    I ran the hard drive scan as you recommended and came up w/ the following:

    retracts: 127
    reallocs:246
    pending sectors: 4
    power on hours: 206
    start/stops: 126
    temp: current 26c
    temp: min 43c
    temp: max 254c

    Given your previous answer, the retracts and the max temp really concern me. It's about 3 years old -- does it look like my HD is on its last leg? Help is appreciated.

    Thx!
  • 7. Re: iPod Classic restoration issues
    Schael.Igwe Level 1 Level 1 (0 points)

    Hi

     

    I've been dealing with the same issue for about a week now with my iPod Classic 160gb

    Retracts: 47

    Reallocs: 16376

    Pending Sectors: 0

    PowerOn Hours:177

    Start Stops: 17268

    Temp Current: 30c

    Temp Min: 10c

    Temp Max: 52

     

    This iPod is relatively new, is it possible that I need to replace it, or is there a way that I can fix this problem. I know this is a really really old thread, absolutely desperate

  • 8. Re: iPod Classic restoration issues
    turingtest2 Level 8 Level 8 (46,590 points)

    If by "relatively new" you mean "within warranty", which is a year in most places, then I would try to make an appointment with an Apple Store to see about swapping it out. The figures ought not to be that high.

     

    See also my post Corrupt iPod classic for further information.

     

    tt2

  • 9. Re: iPod Classic restoration issues
    nicfgs Level 1 Level 1 (0 points)

    Hi,

     

    I just tried to run the diagnosis because my Ipod classic won't restore, and when I selected the HDsmartdata* on the menu, it said "error". I tried to repair the Ipod also in disk utility but It wont let me click on any buttons in the "first aid" section of my Ipod disk.

     

    Can you help me with that please I don't know what to do anymore.

     

    * I just tried it now and it says "Ipod could not be restored because it is busy"

  • 10. Re: iPod Classic restoration issues
    turingtest2 Level 8 Level 8 (46,590 points)

    nicfgs wrote:

     

    Hi,

     

    I just tried to run the diagnosis because my Ipod classic won't restore, and when I selected the HDsmartdata* on the menu, it said "error".

     

    That sounds bad.

     

    Try the DFU restore process from the earlier link.

     

    tt2