Skip navigation

Set up DNS & Web to respond to domain.com AND www.domain.com

776 Views 1 Reply Latest reply: Mar 26, 2011 6:03 AM by Leif Carlsson RSS
Demetrios Level 2 Level 2 (200 points)
Currently Being Moderated
Mar 25, 2011 2:49 PM
Having troubles with a server that's set up to serve web sites for multiple domains. The trouble is that machines on local LAN (which rely on this server for DNS) are not resolving http requests to http://domain.com/ correctly. But everything works fine for http://www.domain.com/.

Outside the LAN both URLs resolve fine (I assume because external DNS is set up correctly).

The 'site' in Server Admin is www.domain.com and an Alias has been created for "domain.com".

In DNS we have a Machine (A) record for server.domain.com.
then CNAME record for www.domain.com that points to server.domain.com.
and a CNAME record for domain.com. that also points to server.domain.com.

Anyone see what may be wrong?
MB Pro, Mac Pro, minis, iPhone, TV, Mac OS X (10.6.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.