Skip navigation

Xcode 4.0.1 in App Store; how do I update from Xcode 4.0?

16170 Views 26 Replies Latest reply: Oct 9, 2012 11:35 PM by funvit RSS
1 2 Previous Next
Llessur999 Level 4 Level 4 (1,145 points)
Currently Being Moderated
Mar 25, 2011 6:27 PM
Earlier this week I purchased my first app from the Mac App Store, Xcode 4.0. Today the app store shows it was updated to Xcode 4.0.1 on 3/25/2011 to fix a series of bugs, some of which appear to be important. The Updates button in the app store app shows "All apps are up to date." How do I update 4.0.1? I thought the app store was supposed to make this easier.
MacBook 13" Core 2 Duo 2 GHz, Mac OS X (10.6.7), iPhone 4; iOS 4.2.1
  • K T Level 7 Level 7 (23,215 points)
    It's available in the Dev Center...

    Xcode 4.0.1 and iOS SDK 4.3
    Build:: 4A1006
    Posted: Mar 24, 2011
    File Size: 4.61 GB
    Intel Mac X•VII, 3-D iTunes Desktop
  • William Fiveash Level 1 Level 1 (45 points)
    I too am confused. I purchased Xcode v4 via the App Store and at this point the App Store tells me everything is current which I know isn't the case as I have not updated Xcode to 4.0.1 and in addition when I access the Purchased view I see the Install button is enabled next to Xcode but when I click on that out of curiosity it tells me Xcode is already installed on this computer. Apple needs to get it together and fix this buggy PoS.
    MacBookPro6,2 2.66 GHz i7, Mac OS X (10.6.3), 4 GB RAM, SMC 1.58f15
  • K T Level 7 Level 7 (23,215 points)
    I can't address Mac App store behavior. If you want the latest version of Xcode, you know where it is.

    Since the forums are user supported, if you have a question/comment/complaint meant for Apple, feel free to use the nearest Bug Report form or contact Apple Developer Relations:
    _(800) 633 2152_
    _(408) 974 4897_
    Intel Mac X•VII, 3-D iTunes Desktop
  • n w p Calculating status...
    Same here. The Update tab in the App Store thinks all of my apps are up to date. I do see an Update button for Xcode on the Purchased tab, but that tells me:

    "You have updates available for other accounts - To update this application, sign in to the account you used to purchase it."

    Even though I have no other accounts and no other accounts have ever signed in on this system. I signed out and back in, verified my billing, and get the same response.
    Mac Mini, Mac OS X (10.6.7)
  • n w p Level 1 Level 1 (10 points)
    Aha - thanks to folks at the macrumors forum:

    If you delete the Install out of the Application folder, that Update button on the Purchased tab turns into an Install button and appears to be working. It has to fetch the full 4.5 gb installer again though.
    Mac Mini, Mac OS X (10.6.7)
  • William Fiveash Level 1 Level 1 (45 points)
    Worked for me also, thanks.
    MacBookPro6,2 2.66 GHz i7, Mac OS X (10.6.3), 4 GB RAM, SMC 1.58f15
  • barryzx12r Calculating status...
    I still get the exception error at about 265mb downloaded and retry does nothing apart from attempt to continue before failing again
    MacBookPro, Mac OS X (10.6.7)
  • marshy82 Calculating status...
    Did you sort this? i am having the same problem
    Mac OS X (10.6.7)
  • ssgp Level 1 Level 1 (70 points)

    I had 4.0.1 installed from the app store, and went through the frustrating process of upgrading to 4.0.2 today. Appstore refused to give me an upgrade option. Here's what I had to do:


    1. Execute as root: /Developer/Library/uninstall-devtools --mode=all

    2. As root, again use pkgtool to "forget" these packages:,,

    3.  Weed out any remnants of Xcode from ~/Library

    4. Remove /Applications/Install completely


    I then opened appstore and was able to install 4.0.2. Again, there are some inconsistencies in the app store that could have been caught by some very basic QA. When I navigate to Xcode, it asks me to pay money and repurchase it. If I navigate to the "purchases" tab, it knows I've already purchased Xcode and allows me to "install" instead of repurchasing it. 


    It's ridiculous to have to download 4.5gb for a 4.01 to 4.02 update when there are several tried and trusted binary diff algorithms like BDC and remote differential compression. I'm getting flashbacks of my experiences with microsoft.

  • AllSeeingMac Calculating status...

    Not to advertise any sorta software, but perhaps AppZapper could help? It removes all stuff relating to a specific app - in this case Xcode. Website here. I have used for Xcode before and it did help in weeding it out of ~/Library and /Library.

  • Fromclarksburg Calculating status...

    I m getting same kind of error everytime I try to install xcode. Did any one find solution to it?

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.