Skip navigation

Bootcamp 3.2 Windows 7 Brightness

114324 Views 135 Replies Latest reply: Mar 24, 2014 10:01 AM by varshalomidze RSS
  • ckahn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 17, 2011 7:48 AM (in response to thatguy09)
    2011 MacBook Pro 17", Windows 7
  • ckahn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2011 8:59 AM (in response to ckahn)
    If I close the lid and reopen, the brightness goes to maximum, which requires a reboot to diminish. Ugh again.

    Are we the only ones? Do any 2011 MBP owner's have brightness control in Boot Camp? There are currently 2,504 views for this thread, more than any other on page one.
    2011 MacBook Pro 17", Windows 7
  • brainstormerus Calculating status...
    Currently Being Moderated
    Mar 20, 2011 5:23 AM (in response to ckahn)
    ckahn wrote:
    Are we the only ones? Do any 2011 MBP owner's have brightness control in Boot Camp? There are currently 2,504 views for this thread, more than any other on page one.


    I've got a 2011 MBP, running Win7 64-bit with the latest Boot Camp. Same issues here. Neither the brightness buttons nor the slider in the Windows control panel have the desired effect.
    MBP (Early 2011)
  • Polytonic Calculating status...
    Currently Being Moderated
    Mar 22, 2011 8:35 PM (in response to thatguy09)
    I've figured out part of the problem. Okay, so to get brightness controls working again, pop in the Bootcamp Disc (or Download the AMD Catalyst Control Center binary executable), run the ATIGraphicsSetup driver, and uninstall the AMD 6750M (or 6490M) graphics driver. This should knock you back to the stock Windows driver, where brightness control functions again.


    So, yes, I too have this problem. Nobody on Macrumors or Notebook Review seems to have any idea how to fix it. I did figure out how to get it working again, but the solution involves removing the Apple/AMD driver. Not exactly a useful approach, if you like to play games.


    So, at least we've isolated the problem, right? Right. So, I was tinkering around, and decided to try the AMD Catalyst 11.2 drivers, off the site. Yeah, um. Those don't even detect the 6750M, despite being (I believe) version *.812, and the drivers off the disc being *.808 or something like that. Maybe I have it backwards. So it seems as if the problem lies in the AMD Mobility Drivers, which obviously need updating. At this point, I'm pretty convinced that whoever wrote the Apple/AMD drivers off the BootCamp disc, failed to take into account the brightness controls, as right now, F1 and F2 are small lumpy paperweights, so to speak.


    A temporary workaround is to set the brightness in OSX, then reboot to Windows. I use rEFIt with a time-delayed boot, so it's not so bad, especially since I'm booting off an SSD.

    Message was edited by: Polytonic
    15" Macbook Pro (2011), Mac OS X (10.6.7), 2.3 GHz Core i7 2820-QM
  • ckahn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2011 8:27 AM (in response to Polytonic)
    Polytonic wrote:
    I've figured out part of the problem. Okay, so to get brightness controls working again, pop in the Bootcamp Disc (or Download the AMD Catalyst Control Center binary executable), run the ATIGraphicsSetup driver, and uninstall the AMD 6750M (or 6490M) graphics driver. This should knock you back to the stock Windows driver, where brightness control functions again.


    That didn't work for me. Device Manager now shows a "Standard VGA Graphics Adapter", my max screen resolution is limited to 1600x1200 (down from 1920x1200) and the F1 and F2 keys don't show the brightness icon or change the brightness.

    Agree that newer AMD Mobility Drivers need trying.

    I'm using rEFIt too, but not with SSD.
    2011 MacBook Pro 17", Windows 7
  • Polytonic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2011 2:38 PM (in response to ckahn)
    You need to use the Uninstall function from the drivers, and remove everything. Then reboot, until you're back to the stock Windows native driver. If your brightness still isn't working, try reinstalling the Bootcamp Keyboard driver?
    15" Macbook Pro (2011), Mac OS X (10.6.7), 2.3 GHz Core i7 2820-QM
  • ckahn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 24, 2011 8:27 AM (in response to Polytonic)
    Polytonic wrote:
    You need to use the Uninstall function from the drivers, and remove everything. Then reboot, until you're back to the stock Windows native driver. If your brightness still isn't working, try reinstalling the Bootcamp Keyboard driver?


    Remove everything or remove the graphics drivers using \Drivers\ATI\ATIGraphicsSetup? In any case I'd still be stuck with 1600x1200 resolution on the 17" screen with the stock Windows native driver. Reinstalling the \Drivers\Apple\x64\AppleKeyboardInstaller64 didn't work either. Only the volume (F10/F11/F12) and keyboard brightness (F5/F6) and eject work -- no F1/F2.

    When's a new AMD driver coming out? Version 11.2, released 2/15/2011, as you mentioned, installs Catalyst control panel only:

    http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-64.aspx

    The release notes don't even mention the 6750M:

    http://support.amd.com/us/kbarticles/Pages/AMDCatalyst112ReleaseNotes.aspx
    2011 MacBook Pro 17", Windows 7
  • Djnetics Calculating status...
    Currently Being Moderated
    Mar 24, 2011 9:29 PM (in response to ckahn)
    Me too I've just bought my 2011 17" Macbook Pro. Installed Windows 7 64 bits. The F1 & F2 doesn't increase or dim the display.

    What is going on Apple?? I was told by one of my friends whom is working in an Apple store in Singapore that Apple is stopping support for BootCamp. Means no further improvements or updates??

    I've only found a temporary solution to this issue.

    Boot into Mac OS X.
    Dim or increase the display from there.
    Boot back into Windows 7.
    The display will change thereafter on Windows 7. But F1 & F2 will still don't work.

    That's how it works for me.... For now...

    Please Apple... Do something about it. Or at least reply back to us and admit there's an issue rather than just letting others keep typing down their worries and issues...
    Macbook Pro 17" 2011, Windows 7
  • Polytonic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 26, 2011 5:45 PM (in response to ckahn)
    I'm pretty sure just removing the graphics driver using ~\Drivers\ATI\ATIGraphicsSetup will work. The stock Windows native driver bumps my 15" MBP to 800x600, but brightness should work.


    What I posted was simply to make it so F1/F2 would work again (as it's the Graphics Driver that screws up F1/F2). Completely removing the graphics driver should restore F1/F2, at the expense of the native driver. It was by no means a "solution" so to speak. I posted it mostly as a temporary workaround if you absolutely need brightness controls, at the expense of graphics performance.

    Until AMD releases the next version of Catalyst, or Apple releases an updated graphics driver, we're all stuck. This is why I would have infinitely preferred the nVidia GPUs.
    15" Macbook Pro (2011), Mac OS X (10.6.7), 2.3 GHz Core i7 2820-QM
  • thatguy09 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2011 5:41 PM (in response to Polytonic)
    Has anyone tried modding the Catalyst 11.3 drivers to work with our card? Would the brightness settings be part of those or are they exclusive to apple?
    15" MacBook Pro (Winter 2011), Windows 7
  • TJCacher Calculating status...
    Currently Being Moderated
    Mar 30, 2011 11:26 AM (in response to pwhe23)
    Justing posting up to say my 2011 MBP 17" running Windows 7 64-bit is also exhibiting the same problem. Sometime during the last week or so, the brightness controls stopped working. I had gone to AMD's website and downloaded and installed the Catalyst control panel, and thought that might be the problem, so I uninstalled it and then did a "repair" install of the Bootcamp 3.2 drivers from the Apple System DVD that came with my machine. No dice - neither brightness controls (F1/F2) nor the builtin Windows slider work. There is no brightness tab on the Bootcamp control panel.

    Other posters to this thread seem to have tried both uninstalling the AMD driver and completely uninstalling and re-installing Windows. Apparently the only reliable way of returning brightness control functionality is to jettison the AMD driver entirely, which, of course, renders the use of Windows on these machines entirely moot for those of us who use it for gaming or otherwise need modern accelerated graphics performance.

    Bummer. Between this new problem and the blackout/graphics glitching problems between my new MBP and my Apple 24" Cinema Display, I am defintely feeling the pain of being an early adopter of Apple's newer tech (AMD graphics / Thunderbolt/etc.).

    Has anyone tried reporting this problem to Apple? I wonder if we won't just get the typical "It's not an Apple problem if it works under OSX" type response.
    Early 2011 MacBook Pro 17", Mac OS X (10.6.7), Windows 7 Utimate 64-bit via Bootcamp 3.2
  • TJCacher Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 30, 2011 12:43 PM (in response to TJCacher)
    Ok - I'm replying to my post to report that I've gotten the brightness controls to work again under Windows 7 64-bit - at least for now - I kind of expect the broken behavior to return again, but if it does I'll try what I did again and report back.

    Here's what I did:

    I thought maybe booting into Windows' "Safe" mode would be similar to removing the AMD driver just to see if the standard Windows display driver would work with the brightness controls.

    I booted into Safe mode (the one with networking, if that made any difference) to test this theory. The brightness controls did not work under safe mode, due to the lack of the Bootcamp keyboard drivers I presume, and so I just rebooted the machine normally.

    After rebooting onto my normal Windows desktop, I thought I might have a look at the system logs to see if anything unusual was happening driver-wise. After perusing the logs for a few minutes (and deciding the warnings and errors reported there were nothing new nor related to the brightness issue), I exited from the log viewer and, just for the heck of it, pressed the F1 key. Lo and behold, the brightness of the screen dimmed!

    So far, the controls continue to work (although I still don't have a brightness tab in the Bootcamp control panel - I'm not sure I ever did with this machine, though).

    I'm just posting this in case anyone wants to try replicating my experience and reporting back. If booting into safe mode resets something that somehow "survives" the safe mode boot and persists into the normal Windows boot, it may be what effected the change I saw. If this is what is actually happening, I think it's quite likely that I will lose the brightness functionality again at some point.
    Early 2011 MacBook Pro 17", 2.3ghz, 500gb SSD, Mac OS X (10.6.7), Windows 7 Utimate 64-bit via Bootcamp 3.2
  • Sasha55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2011 8:41 AM (in response to TJCacher)
    There is a half way solution
    You need to reset NVRAM pressing optcmd+rp before boot, but this is working only until you shutdown your macbook.
    Windows 7
  • Polytonic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2011 7:24 AM (in response to Sasha55)
    Flashing PRAM is unwieldy, as it can reset a number of things in OSX as well.


    On the bright side, there's a new Bootcamp update for the 2011 MBP owners, so that maybe will fix things. If nobody else gets to it before me, I'll post back with my results later today. Supposedly it also fixes my shutdown bug in Windows.
    15" Macbook Pro (2011), Mac OS X (10.6.7), 2.3 GHz Core i7 2820-QM
  • ckahn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2011 7:51 AM (in response to Polytonic)
    Polytonic wrote:

    On the bright side, there's a new Bootcamp update for the 2011 MBP owners, so that maybe will fix things. If nobody else gets to it before me, I'll post back with my results later today. Supposedly it also fixes my shutdown bug in Windows.


    Page at http://support.apple.com/kb/DL1371 doesn't specify whether it's for x86 or x64, and when I run it I get "Boot Camp Services Setup failed" Properties say the file version is 3.1.5.0.

    http://photos-b.ak.fbcdn.net/hphotos-ak-snc6/21704510150206497800891_590525890_8616043_8215078n.jpg
    2011 MacBook Pro 17", Windows 7
1 2 3 4 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.