Skip navigation

Card reader automatically eject media during file transfer

3796 Views 15 Replies Latest reply: Feb 10, 2014 3:23 PM by pvsky RSS
1 2 Previous Next
andychin Calculating status...
Currently Being Moderated
Mar 26, 2011 5:58 PM
I have been having this frustrating issue with several compact flash cards and card readers. First I thought the card reader was malfunction and I get another to try, same issue. So that I thought is the CF card, but several other CFs having same issue as well. Only one particular brand is fine, Sandisk.

I have done search on Google and apparently a few out there is having same issue as mine, but there's no solutions. What could possibly be the solution for this?
MacBook Pro, Mac OS X (10.6.7)
  • ClayG Level 4 Level 4 (1,415 points)
    Is the card formatted properly for Mac OS X?
    MacBook Pro late 2008, 2.4 Ghz, 4 GB RAM, Mac OS X (10.6), iPhone 4, iPad Wifi, Time Capsule
  • eww Level 9 Level 9 (52,975 points)
    Are the cards all the same size? If not, what size is/are the SanDisk card(s) that work, and are the other cards that don't work larger?

    Does your "during file transfer" mean that the transfers begin OK and are partly completed before they stop and the card is reported to be "ejected"? Or does the transfer never actually start?
    15" '08 UMBP 2.4GHz/4G/500G XT; TiBook 1GHz/1G/120G; iPhone 3G, iTouch 32G, Mac OS X (10.6.7), scanners, projector, tablet, laser and photo printers, Pentax K-7, Olympus E-10
  • angelobanjo Calculating status...
    I get the same behavior - doesn't matter which size card (SD or CF). Tried different card readers, get the same behavior - card auto ejects - then get the warning that it wasn't ejected properly. This doesn't happen all the time - seems totally random. Very frustrating. It's so bad that I don't use iPhoto or Aperture for the import (because then I get mixed up half-imported files), have to just keep trying to copy them via the finder, then open a photo program. This must be an OS issue, it happens on the older style MBP and my new Uni Body.

    Does an improperly ejected disk show up in the Console? I don't see it.

    Thanks,
    Angelo
    2 MBP's, Mac OS X (10.6.7)
  • JLF SC Level 1 Level 1 (0 points)
    I've posted following on several other "card reader" threads:

    I'm pretty sure this is a Snow Leopard OS X 10.6.7 problem. I tested my card reader on my wife's iMac, which is still using OS X 10.5.8. Thankfully have not upgraded her's to Snow Leopard yet. The card reader with a SanDisk CompactFlash is immediately recognized on the earlier 10.5.8 op system. I ejected and re-inserted the card numerous times.
    iMac, Mac OS X (10.6.7)
  • JLF SC Level 1 Level 1 (0 points)
    I just received the following helpful URL link from SanDisk tech support.

    http://kb.sandisk.com/app/answers/detail/a_id/60

    SanDisk responded within 5 hours of my inquiry. After removing all USB devices from my iMac and reinserting the card reader alone, the reader started working again. I ejected it numerous times from USB ports on the iMac as well as from a USB hub. After plugging my other USB devices back in, I have not detected if there was a device which was causing the conflict. As a precaution I have removed USB devices that are only used periodically such as a Colorvision Spyder2Express device used every 30 days or so to color correct my monitor.

    Hope this helps others with Mac card reader issues.
    iMac, Mac OS X (10.6.7)
  • zadok70 Calculating status...

    I suspect this problem has surfaced in the last three years because I never used to have this problem when I first got my camera. I've tried everything suggested here and nothing works on either my macbook or my wives.

     

    However, I seem to have found a solution - finally.

     

    Boot up in windows, copy compact flash to usb stick. Not very ideal, but it's less infuriating than having constant ejection whilst trying to import to iphoto. My wives macbook has xp on it installed via bootcamp, and the compact flash reader doesn't eject on whilst on that os. That does suggest to my limited knowledge it's an operating system issue.

  • benseaward Level 1 Level 1 (0 points)

    I have to agree with jlf sc. this is a total snow leparod issue. I'm actually filming in africa right using a canon 5d as a b camera and a macbook pro running snow as my media manager and it has been a huge pain in my ***. i'm even using a program called ShotPut Pro (which is killer btw) to transfer and i still get the same issue. thank god my local fixer had an old mac pro running tiger. since i switched to the tiger computer everything has been transferring like a breeze.

     

    PLEASE PLEASE PLEASE APPLE!!! READ THESE POSTES!!!!!! IM FILMING ALL DAY AND BECAUSE OF THIS ISSUE IM UP ALL NIGHT DEALING WITH MEDIA MANAGMENT. GETTING LIKE 1 HOUR OF SLEEP JUST TO GET UP AND DO IT ALL OVER AGAIN.

     

    ben

  • issanni Level 1 Level 1 (0 points)

    Exactly same problem here.. 

  • Subodhbs12 Calculating status...

    And the problem previals in Mavericks too...Apple, you been disappointing

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.