Skip navigation

my macbook pro does not detect external display anymore

432399 Views 350 Replies Latest reply: Mar 31, 2014 2:28 AM by iDinev RSS Branched to a new discussion.
  • LucasDC Level 1 Level 1 (0 points)
    Same problem here with a Macbook Pro and a Samsung p2770h conected by miniDP-HDMI. It worked fine till today. Any news on how to solve this issue? I really don't want to have a week old 27" display as a piece of furniture...
    MACBOOKPRO, Mac OS X (10.5.8)
  • orphex Level 1 Level 1 (0 points)
    Same issue here. Got MBP 2010. The strange thing is that I had been using the same cable (DV to HDMI) for months - showing films for my daughter and stuff. Then one day it just stopped working. Mac simply stopped detecting my Panasonic TV. After researching for answers in google I tried reseting the chip with cmd+key combination, changing resolution, different hdmi sockets, but nothing worked. Thought it may be the cable issue, but I gave the same cable to my colleague, who owns the same MBP (purchased just few months earlier) and the cable works for him. DV to VGA works fine for both same Panasonic TV and projector. Looking forward to having this resolved asap by apple.
    MacBook Pro, Mac OS X (10.6.7)
  • John Knowles Level 2 Level 2 (335 points)
    I just noticed this issue; tried hooking the MBP to a new Panasonic PlasmaTV at the office via the MDP>HDMI adapter, could not get a consistent signal on the TV. The laptop recognized it -- saw it in the Monitor prefs and the pointer would slide off screen -- but I only saw an image on the monitor once or twice after unplugging, waking from sleep, etc. I have not tried the 10.6.7 update but I've heard of other issues with it so avoiding it for now.
    MacPro 2.66, MBook Pro 2.8, 16GB iPhone 3GS, Mac OS X (10.6.6)
  • onderay Level 1 Level 1 (0 points)
    Im running 10.6.7 and i have exactly the same problem! I know its not the cable nor the screen as it will work sometimes. Just very erractic!!
    Macbook Pro 2009, Mac OS X (10.6.7)
  • Marcus Hardy Level 1 Level 1 (5 points)
    My mac is psycho on this and it is infuriating. It works with my monitor at home, but come time to connect to a projector for work or school, it fails to connect intuitively most of the time. I have to restart the machine to get it to connect--and sometimes (like a few moments ago), that doesn't even work. I have a cheapie adapter from Amazon, so yes I know Apple, I didn't fork over 25 bucks for your market up adapter that is still cheapie and from China as well, but it works most of the time, so why the heck not all of the time?
    MB Pro 13 Mid 2010, Base Model w/ 8gb RAM, Mac OS X (10.6.7)
  • tomizza Level 1 Level 1 (20 points)
    i just had forgotten that i have gfxCardStatus running and set to Intel Only mode (only integrated GPU, eg for power savings) ... but the Intel graphics chipset is incapable of outputting video through the Mini DisplayPort.
    Switching to Nvidia Only or Dynamic Switching enables the use of the external display again, see http://codykrieger.com/gfxCardStatus/faq#ext_display
    macbook pro 15" (early 2011), Mac OS X (10.6.7)
  • Michael Ihnat Level 1 Level 1 (30 points)
    Bad news guys but maybe an answer and perhaps something Apple will cover!

    http://support.apple.com/kb/ts2377

    Mine says its a NVIDIA GeForce 9400M but JIC I am taking it to the Mac repair place to see if it could be a covered issue.
    Macbook Pro 15inch, Mac OS X (10.6.7)
  • John Knowles Level 2 Level 2 (335 points)
    My 2008 MBPro has the dual graphics cards (GeForce 9400+9600), wonder if this is a related issue? I've been running with the 9600 on for a while and just started noticing a MAJOR power drain on the battery with that enabled, plus the weird external monitor issue. I just switched over to the 9400 and so far it's not draining the battery as much and I've been running a Panasonic plasma with a DP>HDMI adapter just fine.
    MacPro 2.66, MBook Pro 2.8, 16GB iPhone 3GS, iPad 1, Mac OS X (10.6.6)
  • iantrich Level 1 Level 1 (0 points)
    Hello All,

    I'm having the same problem as everyone with my 13" 2009 MacBook Pro. I work in a public school in South Korea as a teacher and go to many different rooms with many different displays throughout the week. Needless to say, most of the displays do not work.

    I have good news though, I can get all the displays to work when I use BootCamp and Windows 7. Obviously this is very less than ideal and just goes to show that this is a software issue and not hardware.

    Hope that helps some of you, if you're willing to dual boot, which I have been forced to do as I need these displays to work. Best of luck and I look forward to Apple getting it together and fixing this basic necessity for our overpriced laptops.
    Macbook Pro 13", Mac OS X (10.6.6)
  • Lodar Level 1 Level 1 (0 points)

    Hey all,

    Thought I should share my MBP troubles aswell.

    As of today, my MBP 2011 will recognize my Samsung LCD LED 32" HDTV but my TV tells me "no signal".

    My hdmi cable is not broken (ps3 works fine with it), my tv is not broken (obvious since i checked my PS3), my mbp port is not or should not be broken (bought the thing 2 months ago). The only thing I can no really check is the adapter. I bought it at the apple store, and before today it worked.

     

    So eighter the new update (10.6.7) made something go wrong, or the adapter broke all of a sudden (does anyone know stories of this ever happening?).

     

    Hope someone will find the solution, because right now im having a luxury problem of not being able to watch some things on my big screen .

     

    Thanks!

  • wakestudent Level 1 Level 1 (0 points)

    I'm having the same problem..It only works sometimes and not all the time! Apple needs to make an update to fix it

  • jason84 Level 1 Level 1 (0 points)

    Same problem!!!!  Tried all the solutions I read and still no good.  Replaced my $7 minidisplay to HDMI with a $40 one from the apple store and viola!... then after a month it started with the same problems and now it maybe works 50% of the time!!!  Apple HElP!  This is so frustrating!

  • Charlie Vanitas Level 1 Level 1 (0 points)

    I have an MBP late 2009 and LG 27" HDTV monitor as an external monitor.

    This set has been working perfectly so far, until I updated to the newest Mac OSX

    software. After rebooting, MBP would not recognize the external monitor.

    The monitor has been connected using Apple's mini DVI to DVI adaptor and

    DVI cable to the external monitor.  Maybe I shouldn't have updated.

    Is there any way for me to go back ?

  • PaoloAvezzano Level 1 Level 1 (0 points)

    Same issue for me. I used to connect my mid-2010 MBP to an external projector with no issues.

    Yesterday I attached once again and nothing happened. Tried many times my connecting, disconnecting, rebooting and changing HDMI port, but nothing resolved.

    Next time I'll try with another cable and with Win 7 from Parallels.

  • uulhaa Level 1 Level 1 (0 points)

    And, again, another victim.

     

    My setup is:

    1.     MacBook Pro 17", late 2010 model.

    2.     Apple Mini Displayport to DVI-D adapter.

    3.     DVI D cable.

    4.     Iiyama Prolite B2409HDS monitor.

    This has been working OK since Februari.

    I even occasionally attached my Asus notebook to the HDMI port of the monitor.

     

    Since a few weeks, the monitor would not display an image when starting up my MacBook.

    Sometimes, the MacBook thought there was a second display attached, sometimes it didn't.

    Usually a restart fixed the problem.

     

    Not so today.

     

    I had to Force Quit the Finder (hung in a move of a file) and no monitor would show up.

    I think I have tried all suggestions in this thread as well as a few others, such as connecting the same monitor via an Apple Mini Displayport to HDMI adapter and a HDMI cable. No change.

     

    The monitor still works with my Asus notebook (on Windows 7), though.

1 2 3 4 5 ... 24 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.