Previous 1 2 Next 21 Replies Latest reply: Feb 23, 2013 7:48 AM by polocanada
starangel Level 1 (0 points)

I am backing up my macbook (on snowleopard) for the first time using Time Machine and the WD My Book for Mac external hard drive. The dialogue box shows that Time Machine has finished backing up 370KB of 370KB, but it is stuck on "Finishing backup". I've left it running overnight, but it is still stuck on this message. If I open Time Machine (to the star wars-looking section), it appears that the back up was successful (but of course I've only checked random files - not every single file). I can still use some applications on the macbook, but some things, like Safari, Mail and Preview are frozen.

I've searched this forum and looked at but have not been able to find a solution to this issue.

Please can anyone assist?

Many thanks in advance!

iOS 4, macbook
  • Linc Davis Level 10 (192,599 points)
    370 KB is obviously not a complete first backup. Please take the following steps:

    (1) Check that the cable connecting the external drive to the Mac is firmly seated at both ends.

    (2) Launch Disk Utility, select the TM volume, and run "Repair Disk." Repeat if any problems are found, until it comes out clean. Then select your source volume(s) and run "Verify Disk."

    (3) Launch the Console application, enter "backupd" (without the quotes) in the filtering text box, run a backup, and post the log entries that appear.

    (4) Boot in safe mode (shift key down at startup) and try the backup again. Note any differences in the log entries.
  • starangel Level 1 (0 points)
    Thanks so much for your prompt response!

    I ran Repair Disk on the TM volume - there were no problems.

    I then ran Verify Disk on the source volume and got the following message: "Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk." I've proceeded to insert the installation disc, but was not sure where to go from here. I've tried to follow the instructions on this thread: however, the options that come up are not as per the instructions on the thread. Specifically, after inserting the disc and pressing 'Continue', the only option it gives me is to re-install the OS in its entirety. It does not give me the option, as anticipated in that thread, to select a language nor does any menu bar appear allowing me to select Disk Utility etc etc.

    Do I need to shut down the macbook and insert the installation disc only after it has rebooted? (Apologies in advance if this is an obvious question. I am hesitant to reboot unless this is what I am supposed to do as it often leads to all sorts of other issues).

    Many thanks!
  • Pondini Level 8 (38,740 points)
    See the yellow box in #A5 in [Time Machine - Troubleshooting|] (or use the link in *User Tips* at the top of this forum).
  • Linc Davis Level 10 (192,599 points)
    Insert the DVD but don't run the Installer. Restart the computer, and hold down the C key at the chime until the Apple logo appears. Again, don't run the Installer, but click the Utilities button and select Disk Utility from the menu that appears. In Disk Utility, select your startup volume and run "Repair Disk" repeatedly until no problems are found. Then reboot as usual.
  • starangel Level 1 (0 points)
    Thank you both for the instructions for repairing the source volume; was very helpful.

    I have now repaired the source volume. Below are the log entries from Console:

    Step (3) (i.e. after backup in normal mode):
    DATE / TIME 06/04/2011 21:47:00
    SENDER (PID) quicklookd[6113]
    MESSAGE [QL] 'Creating thumbnail' timed out for '<QLThumbnailRequest /Volumes/My Book/Backups.backupdb/MLD’s Computer/2011-04-06-174447/Macintosh HD/Users/mylo/Downloads/Contract18aCodringtonst.doc>' (Start date: 2011-04-06 21:39:44 +1000)

    Step (4) (i.e. after backup in safe mode):
    Same message as per (3) above, plus the following message -

    DATE / TIME 07/04/2011 15:30:34
    SENDER (PID) [0x0-0xc00c].backupd-helper[175]
    MESSAGE Not starting Time Machine backup after wake - less than 60 minutes since last backup completed.

    Please does this mean anything to you?
  • Linc Davis Level 10 (192,599 points)
    Those are not the log entries I wanted to see. There should be a series of lines beginning with something like
    ...[1234]: Starting standard backup
    But did repairing the source volume or booting in safe mode make any difference?
  • starangel Level 1 (0 points)
    The backup mentioned above was done after having repaired the source volume.

    I have run the backup again and this time got 4 log entries. The first 3 are similar to what I have mentioned above, however, one of the entries is similar to what you mention above. It reads:

    07/04/2011 22:11:32[654] Not starting scheduled Time Machine backup - less than 10 minutes since last backup completed.

    Booting in safe mode made no difference i.e. produced the same 4 log entries.
  • Linc Davis Level 10 (192,599 points)
    All I can tell from what you've given me is that you started the backups too soon. You haven't told me whether scheduled backups are still hanging at the end, or how much data is being backed up.

    Please wait for a scheduled backup to take place, note how much data was selected for backup, and whether the backup completed successfully. If there is still a problem, please post all log messages from backupd starting at the time of that backup, the first one looking like what I posted above.
  • Lawrence60 Level 1 (0 points)
    Change your WD My Book for a drive with no partitions. Time Machine doesn't like partitions. I had endless problems with it until I changed the external drive.
  • Pondini Level 8 (38,740 points)
    Lawrence60 wrote:
    Change your WD My Book for a drive with no partitions. Time Machine doesn't like partitions. I had endless problems with it until I changed the external drive.

    Sure it does, as long as the drive is formatted properly (the GUID *Partition Map Scheme* and +Mac OS Extended (Journaled)+ or +Mac OS Extended (Case-sensitive, Journaled)+ Format.
  • Lawrence60 Level 1 (0 points)
    I struggled for months with my new mac and a WD My Book ext drive. Time machine regularly hanging during back up. Contacted Apple Tech Support & had many suggestions from them. Drive format was correct. None of the Tech Support suggestions worked. After discussion with a "Genius" in my local Apple store he advised a different un-partitioned ext drive. Swapped the WD drive for a iomega - no problems at all since. I can only draw one conclusion from this.
  • Pondini Level 8 (38,740 points)
    There was either something wrong with the drive, the connections, or the *Partition Map Scheme.* Lots of folks (including me) have been using them for years with no difficulties. I've never seen a post here where it wouldn't work, other than for the reasons listed.

    Apple even recommends it. See "Note: Every available disk that can be used to store backups is listed. If you’ve partitioned a disk, the available partitions are listed." in [Mac 101: Time Machine|].

    I suspect this may indicate the problem you had, from the same article: "If the disk is partitioned using the Master Boot Record (MBR) partition type, some partitions may not be available for use with Time Machine. The GUID Partition Table (GPT) or Apple Partition Map (APM) partition types are recommended."
  • Linc Davis Level 10 (192,599 points)
    I've used a partitioned drive for TM for a couple of years, zero problems.
  • starangel Level 1 (0 points)
    Thank you to everyone for your input. Unfortunately, I'm not tech savvy, so I don't really understand all the talk about partitioning. All I know is that the EHD is specifically designated as being made for the Mac and as being Snow Leopard and Time Machine compatible (I understand that compatibility does vary depending on the hardware config).

    In response to Linc Davis on 7/4 at 11.26pm: Since repairing the source volume, I have not had this problem of being stuck on "finish backup". Looking at the folders in the EHD, it appears as though scheduled back ups are taking place. Perhaps the problem has been resolved? Please, how do I check to see whether the back up is in fact completing successfully?
Previous 1 2 Next