Skip navigation

Thunderbolt Does Not Detect Display

106577 Views 89 Replies Latest reply: Dec 3, 2013 1:56 PM by Chuck Bradley RSS
  • evandepol Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 15, 2011 12:11 PM (in response to wsimon)
    Please make sure you call Apple Support, at the minimum so that they are aware of the issue. Thanks.
    Macbook Pro 2011, Mac OS X (10.6.6)
  • KellBobMD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2011 8:00 PM (in response to evandepol)
    Same thing here guys- Have my new shiny 17" MacBook Pro and got the DVI adapter for my 21" monitor and nothing. I've been away from Macs for the past 10 years so I don't know the other "display tricks" I've heard a few of you talk about so that would be nice but I'm thinking that what I'm running up against is the same thing all you are in that the Thunderbolt to DVI thing just doesn't work. I'd be interested to hear if anyone has seen one that actually WORKS.

    Although if its working they're probably not searching for this thread
    17" MacBook Pro '11, Mac OS X (10.6.7)
  • entropic23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2011 8:33 PM (in response to KellBobMD)
    the other "display tricks" I've heard a few of you talk about


    Check this link. It walks you through the different ways to use externals with a MBP:
    http://osxdaily.com/2011/01/14/turn-off-the-macbook-or-macbook-pro-screen-with-t he-computer-still-on/

    My MBP kinda works with DVI on my monitors, but I cannot allow it to sleep otherwise various issues arise. Check my post here for more info and some things to try:
    http://discussions.apple.com/thread.jspa?threadID=2774718&tstart=0

    The gist of it is that it's sporadic for different monitors and different adapters. Your best shot seems to be MDP->HDMI adapters or MDP to MDP (if your monitor has MDP that is). Nothing is a guarantee.

    I've got full functionality (not as smooth as previous MBP or Mac Pros but it works nonetheless) using a moshi knockoff HDMI adapter on an Asus monitor and an HP monitor. Connecting to HD TVs works as well for me. Some ppl don't have success with HDMI though so nothing's a sure bet.

    Also, the Apple tech I'm working with doesn't have a lot of info he can contribute to the situation. It's basically a wait and see thing right now, but at least the engineers are fully aware of and actively working on a fix.

    Hope this helps & you get something figured out.
    13" macbook pro (2011), Mac OS X (10.6.6)
  • KellBobMD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 31, 2011 8:56 PM (in response to entropic23)
    Hey thanks,
    Yeah mine isn't even recognizing that I have anything connected. The monitor acts as if the cord is entirely unplugged no matter what I restart or power cycle. I also went to the system profiler and it also says that nothing is connected to my thunderbolt port no matter when I plug in or out the adapter. I don't know if it only detects working connections but if you told me my Thunderbolt port was dead I'd have to believe you at this point.

    Its likely a firmware issue that will hopefully get updated soon but I was hoping to get a few more miles out of this 'ol 21" monitor before I had to send it out to the pasture thanks for your help
    17" MacBook Pro '11, Mac OS X (10.6.7)
  • Gene Melchionne Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 1, 2011 10:16 AM (in response to KellBobMD)
    I got my 15" ThunderBolt MBP last week and have had a similar problem with my 20" and 23" Apple Cinema Displays. Where there is a picture, it is all fuzzy and resembles a solarized photograph. Went to the Genius Bar and the MBP works fine with in the new 27" MDP screens, but exhibited the same problem with the store's 23" Cinema Display. I downgraded to 10.6.6 last night and that did not fix it. So today I went back tot eh Apple Store and bought a new MDP to DVI Adapter and a Dual Link Adapter. The new Apple MDP to DVI adapter showed the same problems. The Dual Link Adapter fixed it, but now I am losing one of my two USB ports to power it.

    While I am no engineer, this looks like a power supply issue nd it might be that the Thunderbolt Port isn't putting out enough juice to make the jump to true DVI. Just a thought.

    Gene
    2 many 2 count!, Mac OS X (10.6.7)
  • rturnr Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 2, 2011 4:50 AM (in response to timtimtimtim)
    I'm using a new MacBook Pro 15" early 2011 with thunderbolt connection.

    I'm having an issue with Benq 24 inch display via display port to dsub/vga connector on Windows 7. Works fine under Mac OS. Nothing is displaying on all resolutions except 800 x 600 which displays a fuzzy picture. All other resolutions don't work (native resolution is 1920 x 1200).

    I'm about to get a display port to DVI connector to test. I will repost when it arrives.

    Very disappointed. Hope there is a firmware fix soon.
    MacBook Pro 15" (early 2011), Windows 7
  • odiggy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 4, 2011 8:46 AM (in response to timtimtimtim)
    I bought the mini display VGA connector and my new Macbook won't detect my Insignia 32" 1080p TV. I plug it in to my son's 20" Samsung monitor and it works fine. If after connecting to the Samsung I go plug it in to the 32" it works but at the lower resolution of the Samsung of course. So it will output the display, it just won't detect this TV. Anyone think it would work if I bought the HDMI connector instead?
    Macbook Pro 13" 2011, Mac OS X (10.6.7)
  • mvanstaveren Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 4, 2011 12:56 PM (in response to odiggy)
    Same Issue here. I will call support towmorrow, to make them more aware.
    I really hate this, I cant use my 24 inch benq monitor, to work on.
    I got a brand new 13 inch, 2011 model

    I tried a dealextreme adapter, which does not work with dvi (mini displayport to dvi).
    mini display port to HDMI works fine.

    Thinking it was the dealextreme adapter, I went to the apple store and bought a griffin (mini displayport to hdmi to dvi adapter) 40 bucks! and this also did NOT work.

    Im going back to the apple store thursday to have my money back, ill wait some time, if there is no fix I will have to bring my macbook pro back to the store, and get a pc... or buy a new monitor which I dont have the money for now
    Macbook Pro 13, early 2011
  • tomizza Level 1 Level 1 (20 points)
    Currently Being Moderated
    Apr 6, 2011 9:14 AM (in response to timtimtimtim)
    i just had forgotten that i have gfxCardStatus running and set to Intel Only mode (only integrated GPU, eg for power savings) ... but the Intel graphics chipset is incapable of outputting video through the Mini DisplayPort.
    Switching to Nvidia Only or Dynamic Switching enables the use of the external display again, see http://codykrieger.com/gfxCardStatus/faq#ext_display
    MacBook Pro 15" (early 2011), Mac OS X (10.6.7)
  • Anand Mandapati Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 6, 2011 11:48 AM (in response to tomizza)
    This was exactly the problem I was having and brought me to the thread. Looks like the MBP is having issues sometimes going from integrated to discrete graphics and the external display doesn't get detected. Using gfxCardStatus, I'm now able to ensure the right graphics adapter is used and things work fine.

    -anand
    MacBook Pro 15" (Early 2011), Mac OS X (10.6.7)
  • mvanstaveren Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 6, 2011 3:11 PM (in response to Anand Mandapati)
    Update: I just bought the original apple mDP to DVI and it worked.
    So the problem here is, that the thunderbolt displayport sends out a signal that can not be converted?
    Just like the Griffin adapter that works with mDP to HDMI but not mDP to HDMI to DVI.
    Deal extreme adapter only worked with HDMI, dont know why, maybe it see's it as HDMI and then wont allow conversion...

    anyways that is my two cents
    Macbook Pro 13, early 2011
  • odiggy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 7, 2011 12:54 PM (in response to odiggy)
    Update!

    I bought the HDMI moshi connector and now my macbook detects my tv display. Unfortunately I was careless and my laptop fell off the stand onto the floor and the thunderbolt connector busted off. What luck, back to the Apple store to spend another $35 bucks. Be careful with the the thunderbolt connector it's very fragile.
    Macbook Pro 13" 2011, Mac OS X (10.6.7)
  • bryanleee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2011 7:36 AM (in response to tomizza)
    I haven't tried but I think this is the answer.

    gfxCardStatus in the "i" setting (integrated) does not allow you to use external displays! Switch to your discrete card!
  • evandepol Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2011 8:00 AM (in response to bryanleee)
    Well, it external displays don't work when using the integrated (non GPU) graphics, then that probably explains why 13" MBP (2011) is not detecting external displays: it only has integrated graphics..
    MBP 13" 2011, Mac OS X (10.6.6)
  • KellBobMD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2011 12:12 PM (in response to bryanleee)
    Yeah that actually DOESN'T work, unfortunately . I'm trying to have a go at it with a Apple MDP->DVI adapter, just installed the gfxcard status, swtiched it to Discreet, and tried all the turning on/off, plugging/un-plugging and everything I could think of to try to get it to register and NOTHING. My monitor acts just like its unplugged. I plug it back into my old PC and everything works wonderfully.

    I guess its like my dad always said "don't by the first of a model change" (in reference to cars) but hopefully at least with this we can maybe get a firmware update soon to fix things.
    17" MacBook Pro '11, Mac OS X (10.6.7)
1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.