Skip navigation

Install Xcode from the App Store = Deleted System

20878 Views 65 Replies Latest reply: Sep 10, 2011 11:08 AM by Paulyboy69 RSS
  • Frustrated Dylan Calculating status...
    Thanks for the heads-up DJ!

    I've contacted Apple's phone support, they said that they couldn't do anything because XCode falls under the Developer umbrella, and is not under the standard support. I've reported it to Developer support as well: http://developer.apple.com/contact/

    I've also tried the AppStore support site, but haven't heard anything back. I figure the more people report the issue, the more likely they are going to treat it as the major issue that it is.

    Message was edited by: Frustrated Dylan
    MacBook Pro i7, Mac OS X (10.6)
  • JGH60 Calculating status...
    So same thing happened to me. Also on an iMac, which took some recovering with help from the genius Bar as I could nor get to my hard disk after the fairly complete deletion of files during the install

    So I grabbed the old macbook (2.4 Intel Core 2 Duo 2GB) and recapitulated the problem wiping out the operating system, this time could recover the computer using a USB on which I had installed a bootable version of OS X (neat trick learned from http://macs.about.com/od/diyguidesprojects/ss/usbflash.htm) that enabled me to fire up disk utilities which saw the macbook HD

    So have 2 clean OS X 10.6 installs on the computers and wondering about my next move
    iMac 27", Mac OS X (10.6.6)
  • JGH60 Level 1 Level 1 (0 points)
    I downloaded and reinstalled on the Macbook (10.6.7) version 4.01 of Xcode. It installed fine and runs. This was a clean system install, from disk updated through software update but no other software installed not even iLife. Only what comes with the OS X direct install.

    Positive about my experience on the Macbook, went ahead and repeated the process on the iMac (10.6.6) and trashed the system again and cannot recover, off the Genius Bar again, The obvious differences are 10.6.7 vs 10.6.6 and also the iMac was full of other software, documents ....

    Next move is to try and install on a clean system on the iMac before recovering all the other software, will do this at the Genius Bar.
    iMac 27", Mac OS X (10.6.6)
  • JGH60 Level 1 Level 1 (0 points)
    Back from Genius bar, reinstalled OS X 10.6.7 keeping all my information but all Apps were deleted unless part of the OS X package. In this configuration Xcode 4 installed fine. Have load all my apps back onto the iMac and everything is fine.

    So it could be 10.6.7 vs 10.6.6

    Ben at the Genius Bar lived up to the name
    iMac 27", Mac OS X (10.6.6)
  • Frustrated Dylan Level 1 Level 1 (0 points)
    I was able to resolve this issue, but I can't say for certain which of the 2 things I did differently solved the issue.

    1. Replaced the hardware: Because of the disk errors I was getting in the disk utility after the drive was deleted, I took the MacBook Pro back to the Apple Store and had it replaced.

    2. I downloaded and installed XCode 4 from the developer site (costs $100 if you're not already a developer).

    I suspect that the issue was solved by installing the developer site XCode download because it's a .pkg file, rather than an .app file. I think because the app is installed in the Applications directory, that it had different privileges and path than the .pkg install.
    MacBook Pro i7, Mac OS X (10.6)
  • Maximilian S. Maurer Level 1 Level 1 (0 points)
    Add me to the list! This is insane
    Mac Pro, Mac OS X (10.6.7)
  • mac llama Calculating status...
    Happened to me today - four 1T drives, including my back ups, mostly full and now not a single file is recognized. Apple support sent me to the local Genius Bar and they suggested Data Rescue 3. So far no luck with that.
    power Mac, Mac OS X (10.6.7)
  • ncsmith4 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 30, 2011 8:53 PM (in response to mac llama)
    Yep. It effed my terabyte hard drive too. Thank GOD it didn't delete my Time Machine too. Apple, is there any fix? So sad to lose all that data. :-/
    Unibody MacBook Pro 15" / iPhone 3G S, Mac OS X (10.5.7)
  • hibernia1 Calculating status...
    I had the exact same problem. It has taken me almost 3 days to get everything back on track. I've been using MACs since the start, and this is the first time in 20 years that I have had a total system wipe. Lets just say I'm not very happy. System still seems to be very clunky. Have Apple made a statement on this yet?
    MacBook Pro i7 PowerBook G4 iPhone4, Mac OS X (10.6.7)
  • DMC9999 Calculating status...
    I've had exactly the same problem, twice!

    The first time it happened, I thought it was a hard drive failure, so did Apple Care and the drive was swapped out for a new one. I got it back, restored from my back up and everything was fine. Went to reinstall Xcode4, same thing happened, icons and apps disappeared, I thought this was the 2nd drive to fail. Apple Care took this very seriously, sent it for a priority repair, this time they were able to reinstall the OS, said the user data was gone, but everything checked out fine. Engineer thought it was a software issue, I mentioned Xcode4, he hadn't heard anything about it.

    Machine came back, restored from Time Machine via Migration Assistant again. When it finished, had a number "1" added to the name of my Home Folder and loads of permissions issues, iDisk, system folders, iPhoto, all needed sorting.

    Possibly a side issue, but couldn't boot from a commercially purchased Install DVD. DVD drive could read it, I could run access everything while booted up normally, system could see it was a bootable disk, but when I tried to boot from it (every possible way), the DVD would spin a bit and then stop and I would be stuck on the Apple Logo boot screen.

    Spent nearly an hour on the phone with Apple Care, guy was patient and helpful, but couldn't repair permissions or boot from the DVD, even tried cloning the DVD to a flash drive. System saw it was bootable, even in Start Up Disk System Prefs, but couldn't get it to boot. Apple guy thought it might be a problem with my DVD copy, corrupted data or something, which would prevent the original DVD and cloned flash drive from working. He's sending me a replacement copy, which will take a week to arrive. He may be right because I can read other DVDs and can even read the install DVD to a point, just can't boot off it. Will try new disk, if it doesn't work, could be trip 3 to the repair shop.

    Still needed to repair permissions while boot volume wasn't mounted, so spent 4 hours cloning my drive to an external HD with SuperDuper. It worked, was able to boot from it and repair the remaining permissions that needed fixing. Rebooted from the internal drive and all is good.

    Once I get the DVD issue diagnosed, I will phone Apple Care again, my case is still open. Will point out this thread and make the impress upon them as strongly as possible that I believe all of my issues are down to Xcode 4, they have paid for 2 expensive repairs (including courier collection and delivery) that would not have been required if the Xcode 4 installation didn't kill my iMac.

    I've spent nearly 3 weeks dealing with this, while not having my iMac. I am still very upset about it. Commiserations to anyone who has had to deal with this very annoying, depressing problem.
    1.8Mhz G5 iMac w/2 gb ram and internal HD, Mac OS X (10.6.7)
  • Dom Mooney Calculating status...
    I've had this happen twice, once with Xcode 4.0 and once with 4.0.1

    Both times, it got about 50% through the install (download went fine) when it gave an error message about deleting files in the application support folder in Library (Steam was involved in the second case). I told it not to delete the files, and then it hung. Left for 12+ hours and it was frozen, force quit wouldn't work.

    Had to restart, and it killed the system folder (question mark on start up, drive listed as empty once I booted). Booted from Snow Leopard disk and tried to reinstall via Time Machine. 2 attempts, both failed (one an hour before the install started, the other 6 hours). Had to reboot from clone (3 weeks old) made with Superduper! and then use Time Machine to restore the User directories. Fortunately worked okay.

    Next attempt with 4.0.1 I'd learned my lesson and I made a fresh bootable clone with Superduper straight before the install. It locked up the same and I reinstalled from the clone.

    Wondering how I get this (MAS sourced) app installed.

    Cheers,

    Dom
    iMac 24" 2.8GHz / Macbook Al 2.4GHz / iPad 64Gb Wifi / Powerbook G4 12" 1.5GHz, Mac OS X (10.6.7), iOS 4.3.1 / PB OS X (10.4.11)
  • sirtimp Calculating status...
    Same problem happened here. System up to date, new Xcode install via App Store. Froze half way through, had to reboot, which resulted in flashing question mark.

    Restored system via Time Machine (which actually worked quite nicely) - However, App Store no longer launches; just bounces in the dock for a few seconds, but that's it - I've tried the various possible fixes (fsck, cache and prefs, permissions, etc) but nothing has worked.

    Very frustrating! From reading this thread, it looks like I'm almost lucky that the App Store isn't launching, because I would have tried Xcode again, to another system delete!
    Mac OS X (10.6.7)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.