Skip navigation

PPTP Won't work after 4.3 Upgrade

73206 Views 123 Replies Latest reply: Aug 4, 2012 10:02 AM by sguilliard RSS
  • slinge Calculating status...
    Currently Being Moderated
    Apr 7, 2011 2:22 PM (in response to JC_MacD)
    I've twigged a really simple way to make it work, tested on iOS 4.3.1 with iPad 2.

    Firstly I downloaded the iPhone configuration utility, then I went to the "Configuration Profiles" section, clicked on the VPN bit and entered my PPTP details. I also filled in the General bit as apparently it is mandatory.

    With iPad plugged in (and showing in the devices section of the iphone configuration utility) I clicked on it (the iPad), then it shows that I have the option to install the profile I created.

    Click install, this brings up a message on ipad, confirm and install. Asks for the password to the VPN, enter it, click next etc, then profile should be installed.

    Now when I go to VPN and select the PPTP VPN from the profile I just installed and try to connect... it doesnt connect straight away, says connecting.... but hangs.

    Turn Airplane mode on, then off, and try again with the VPN... voila, it connects.

    Now, I try turning the VPN on and off, connects every time.

    Not quite sure why it works, but it is.

    The only reason I can think why it might not work for everyone else is maybe its a profile from my 3GS (which is working) getting applied to the iPad. Still, its got to be worth a shot.

    Apologies for a messy post, but this seems like a really idiot proof solution (it must be if I can do it!).
  • Kliffy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 7, 2011 10:59 PM (in response to slinge)
    I'm dead in the water too! why apple is ignoring this
    Mac OS X (10.6.7)
  • macbook_tim Calculating status...
    Currently Being Moderated
    Apr 8, 2011 7:58 PM (in response to slinge)
    Slinge

    I can confirm that your iPhone configuration utility steps you laid out Do infact work. It fixed my iPad 1 iOS 4.3.1 I can now connect to my VPN provider HMA just fine. This fix works!
    Ipad1, iOS 4
  • Ualdayan Calculating status...
    Currently Being Moderated
    Apr 9, 2011 12:06 PM (in response to Syrex)
    Syrex wrote:

    The iOS 4.3 and 4.3.1 devices simply stop sending traffic back after the PPTP server offers it's Configuration Request. Adding either 'nopcomp', 'noaccomp'
    or both to /etc/ppp/options.pptpd results in the connections working every time.

    In Other Words:
    iOS 4.3 and 4.3.1 immediately stop trying to establish a VPN connection
    when they are offered both pcomp (protocol field compression negotiation)
    and accomp (address/control compression). This is the default behaviour
    in PPP and presumably why allot of Linux based routers are subsequently unable
    to establish connections with iOS 4.3+.


    Is there any way to do the equivalent of adding 'nopcomp' or 'noaccomp' to a Linux options.pptpd on a Windows 7 PPTP VPN server?
    Windows 7
  • Cosworth Calculating status...
    Currently Being Moderated
    Apr 9, 2011 2:10 PM (in response to JC_MacD)
    Thanks to the work and post by Syrex I have been able to get a workable PPTP connection.

    What I have done on my DD-WRT router is add the following to the startup window.
    Found here - Administration > Commands > Startup

    echo 'noaccomp' >> /tmp/pptpd/options.pptpd

    I have verified that it works both over 3G and from another WiFi network connection

    I did it this way so all I will need to do is remove command from the startup window if a real fix is released.

    Thanks again Syrex
    Dual 2.5 G5, 2.5GB RAM, 250GB SATA, 300GB SATA
  • Edward Wu Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 9, 2011 10:19 PM (in response to Cosworth)
    Confirming that this works on iPad 2 and iPhone 3GS w/IOS 4.3.1. Thanks Syrex & Cosworth!
    MacBook Pro, Mac OS X (10.6.2)
  • kcchanzz Calculating status...
    Currently Being Moderated
    Apr 10, 2011 1:11 AM (in response to slinge)
    I am running 10.5.8 and so cannot run iphone configuration utility 3.3 to use your solution for vpn on 4.3.1. any ideas ?
    ibook G4, Mac OS X (10.5.8)
  • slinge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2011 2:23 AM (in response to kcchanzz)
    Try Syrex & Costworth's method if your using DDWRT
  • slinge Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2011 2:45 AM (in response to kcchanzz)
    Also you don't need to run the iPhone configuration app on the computer the Idevice is synced with, you can run it on another machine and email yourself the config profile
  • kcchanzz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 11, 2011 8:07 AM (in response to slinge)
    slinge, tried your advice. email config etc. worked only once when I was on airplane mode. after that it did not work anymore. thanks.
    ibook G4, Mac OS X (10.5.8)
  • Canadian_dev Calculating status...
    Currently Being Moderated
    Apr 11, 2011 8:50 PM (in response to slinge)
    I installed dd-wrt to try to get PPTP working with my Ipad. I had the same problems people are having here (only connected one out of 15 tries).

    I had to install Tomato instead because the wireless was so flakey with dd-wrt. But I installed the Tomato with PPTP patches....the PPTP server was a bit of work to get going, but I finally got it, and the firewall rules working.

    In this process, I tried a lot of settings for the PPTP server. At first, I had the same problem as dd-wrt. I finally found a solution that worked, just altering the ppp options.

    Because I don't have dd-wrt, and they suck for documentation, or even getting to a tarball of the binary/source, I can't tell you where these options should go. (Not a big fan of dd-wrt by this point...trying to troll through their source/binaries to figure out what options it is using.)

    From someone elses post above, it looks like this might belong in /tmp/pptpd/options.pptpd

    Anyways, the options I am using are:

    lcp-echo-failure 3
    lcp-echo-interval 60
    default-asyncmap
    mtu 1482
    mru 1482
    nobsdcomp
    nodeflate
    mppe required,no40,no56,stateless
    require-mschap-v2
    refuse-chap
    refuse-mschap
    refuse-eap
    refuse-pap
    proxyarp
    ms-dns <enter a DNS server here>

    (this requires 128 bit encryption for pptp and ms-chap-v2 for authentication)

    I am 90% sure that the reason it works is because I made the mru & mtu smaller than the default. There is a 10% chance that it is the default-async All I know is that I altered all the other options, and finally when I set those 3 options, it started working. It works 100% of the time I try to connect now.

    I would try adding this to /tmp/pptpd/options.pptpd by writing this into the script window at 'Administration > Commands > Startup':

    echo 'mtu 1482' >> /tmp/pptpd/options.pptpd
    echo 'mru 1482' >> /tmp/pptpd/options.pptpd

    If that didn't work, I would add

    echo 'default-asyncmap' >> /tmp/pptpd/options.pptpd

    I hope this helps someone having problems with dd-wrt or linux in general running poptop for a pptpd server.
  • ware Calculating status...
    Currently Being Moderated
    Apr 12, 2011 6:47 AM (in response to slinge)
    I have the following problem.
    I can connect to the VPN (using L2TP) and I can ping machines in the internal network (in my company).
    The problem is that if I try to resolve a name, the DNS don´t work.

    DNS resolution problem in VPN, ¿How can I repair it?
    In 4.1 mi VPN worked correctly and I have not changed anyting
    ¿Any idea?
  • Canadian_dev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 12, 2011 7:48 AM (in response to Canadian_dev)
    I would try adding this to /tmp/pptpd/options.pptpd by writing this into the script window at 'Administration > Commands > Startup':

    echo 'mtu 1482' >> /tmp/pptpd/options.pptpd
    echo 'mru 1482' >> /tmp/pptpd/options.pptpd

    If that didn't work, I would add

    echo 'default-asyncmap' >> /tmp/pptpd/options.pptpd


    I just tested both statements above....I guessed wrong. Ignore the mru/mtu (though it couldn't hurt). It is the default-asyncmap that made the difference. With it, I connect right away. Without it in my options, I can't connect.
  • markfalta Level 1 Level 1 (45 points)
    Currently Being Moderated
    Apr 12, 2011 4:23 PM (in response to slinge)
    I've tried the workaround offered up by slinge and it does work although not always - often requires several attempts.
    MacBook Pro, iPad, iPhone, Other OS, Multiple
  • Cosworth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 12, 2011 5:28 PM (in response to Canadian_dev)
    I can confirm that this works on my setup as well on a DD-WRT flashed router.

    I just used the following in startup window

    echo 'default-asyncmap' >> /tmp/pptpd/options.pptpd

    It did not connect on first attempt, I connected to my work VPN and then tried again and it seems OK now.
    To many to fit, Mac OS X (10.6.6), Mix of many systems
1 ... 4 5 6 7 8 9 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.