Skip navigation
This discussion is archived

Home directories not being made

744 Views 6 Replies Latest reply: Dec 30, 2005 12:41 PM by Joe White RSS
Rob@Bis Level 1 Level 1 (125 points)
Currently Being Moderated
Oct 13, 2005 7:17 AM
Now I have been searching and wondering about this problem for a while now. About 3 months ago (new) Xserv G5 with Tiger Server installed, stopped making home folders. Just stopped, didn't work through WGM or terminal, any command that you tried, the server wouldn't make the home folders. The new user would logon and get Home folder not found error. So what I did was back up my server (everything else is stored on the Xserv RAID) and formatted and started from scratch. You know once I did that it just started to work. No more problems with the home folders. Guess what, happened again, now my server doesn't seem to want to create home folders!! Again this happened. I am not sure why, but this is the second time, APPLE PLEASE HELP OR ANY ONE ELSE. I don't want to format my server again!

Thanks in advance
  • Anthony Hunt Calculating status...
    Currently Being Moderated
    Oct 13, 2005 7:17 AM (in response to Rob@Bis)
    The same thing happened to me. But I found that this was a DNS issue. If I rebooted the DNS server, it all worked again.

    I'm running my DNS on a Windows 2000 server, and it was running out of virtual memory. I upped it, and have had no problems since.

    Hope this helps...

    Anthony.
  • Todd Heberlein1 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 15, 2005 11:53 AM (in response to Anthony Hunt)
    I found that this was a DNS issue.


    (Just adding another data point)

    I had the same problem and solution. I colocated an XServe at my ISP, and the IP address they gave me was previously owned by someone else. The old name (obliviousdeath.net ?!) kept appearing for different reasons (e.g., on SSH login or Workgroup Manager).

    After getting the ISP to remove the old DNS mapping (apparently it took a few hours to flush all the caches) and rebooting my XServe and PowerMac managing client (just to make sure all the caches were flushed), I was able to create the home directories.

    Interestingly, creating the accounts had worked fine before -- only creating the directories has problems. There must be a slightly different mechanism used.

    XServe, one 2.0 GHz G5   Mac OS X (10.4.3)   colocated at ISP
  • MacSEK Calculating status...
    Currently Being Moderated
    Dec 29, 2005 6:25 AM (in response to Rob@Bis)
    Hi,

    i have the same problem. There is no way to force the server creating the home directories.

    I also tried the DNS-thing, so restartet our DNS-Server (runs on a Debian Linux 3.0) with no effect on the Home Directory problem.

    Thats pretty sh* because i did no chenages to our DNS infrastructure or the Xserve itself.

    I have to create new users, and the Moment they are not able to work without a home directory.

    I'm sorry but i have to say, that as longer as i work with Mac OSX Server i get more and more upset!

    I have to bring the new userer up working the next two days, and i don't belive that Apple will fix this Problem.

    Thank You Apple!
    8 Xserve G5, 2 Xserve RAID, Mac OS X (10.4.2)
  • MacSEK Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 29, 2005 7:41 AM (in response to MacSEK)
    OK folks,

    after some time for research here some findings - maybe helpful for anyboe with the same problem:

    I'm running a Xserver as Open Directory Master. This Master won't create the home directories of new users.

    BUT

    i also habe a Xserve running as an Open Directory Replik of this master. The Replik stores also some home directories, so it has a networkfolder for user homedirectories too. When using the networkfolder of this Replik, the home directory of the new user is stored correctly.

    So i guess i have to redefine the networkfolder for the home directories on the master. Yet i could not verify my presumption but i'll let you know.

    MacSEK
    8 Xserve G5, 2 Xserve RAID, Mac OS X (10.4.2)
  • MacSEK Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 30, 2005 12:24 AM (in response to MacSEK)
    Hi there,

    well my presumtion turned true - it is the networkfolder for storing the home directories. simply uncheck this option and save. so it is a simple shaepoint. after that simply reactivate the option for using the sharepoint for user home directories an everything works fine again.

    setting the server up from the scratch worked to because in the end you also set up the network folder, but i guess with this its not necessary

    Have fun!
    MacSEK
    8 Xserve G5, 2 Xserve RAID, Mac OS X (10.4.2)
  • Joe White Calculating status...
    Currently Being Moderated
    Dec 30, 2005 12:41 PM (in response to MacSEK)
    Excellent! Had just run into this problem on a G4 Xserve running 10.4.3 two days ago. Unshared and reshared the directory, and am once again able to create new users.

    FWIW, the share location changed from

    /Volumes/[volume name]/[directory name]
    /Network/Server/[server name]/Volumes/[volume name]/[directory name]



    Xserve (1st Gen)   Mac OS X (10.4.3)  

       

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.