1 2 3 4 Previous Next 45 Replies Latest reply: May 27, 2011 11:30 PM by grantos13 Go to original post
  • 30. Re: No sound on Multi-channel audio TV shows after 4.2 update
    Levelguy Level 1 Level 1 (0 points)
    Hi. Wish I could throw some light on the problem! I have two apple TV's, downloaded the latest software, and now neither of them will get sound. Only solution I have found is to remove power, plug back in and it works again. Also cannot get HD movies at all. I wish when they released this stuff they would make sure it works. I had no issues with either unit before the update.
  • 31. Re: No sound on Multi-channel audio TV shows after 4.2 update
    Brett L Community Specialists Community Specialists (2,270 points)
    Apple is aware of this issue and investigating a fix.

    Brett L
    Apple Discussions Host
  • 32. Re: No sound on Multi-channel audio TV shows after 4.2 update
    JDENredden Level 1 Level 1 (0 points)
    Im not re-encoding all 1tb of my movies and shows.
  • 33. Re: No sound on Multi-channel audio TV shows after 4.2 update
    AppleSauced5 Level 1 Level 1 (0 points)
    Same exact problem. This is really poor of Apple. How could this possibly get missed?!
  • 34. Re: No sound on Multi-channel audio TV shows after 4.2 update
    LOpE Level 1 Level 1 (0 points)
    I've read all your suggestions and have tried Subler and MkVtools and really the best product I've used is Handbrake. What I did was use the Original Apple Tv settings. I have two original apple Tv's and one new apple tv. As well as Iphone 4 and 3gs. For what ever reason multichannel audio wont work as everyone knows. But since I need to stream to multiple devices, the best solution is to use the original Apple Tv handbrake settings. The settings work perfectly with all my devices and all movies. I honestly can't hear the difference in sound even though I know there is, I care more about the video quality and pixelation. Whatever apple did during the last update totally made a weekends amount of work for me and my Macbook.. Good luck, I hope this helps
  • 35. Re: No sound on Multi-channel audio TV shows after 4.2 update
    OzziesMAC Level 2 Level 2 (150 points)
    Moral Of The Story...

    If everything is working Normal on your Apple TV, don't be in a hurry to do the update.
  • 36. Re: No sound on Multi-channel audio TV shows after 4.2 update
    Dhlee3 Level 1 Level 1 (0 points)
    I am having the same problem as well of playing movies with multi-channel audio having no sound when I play them. My videos used to play with out an issue until I did the OS upgrade - big mistake.

    While I appreciate the suggestions to re-encode my videos to get it to work again, honestly, that is an awful work-around and not a legitimate option for most users.

    Apple Tech Support, what is the timing to get this defect resolved?
  • 37. Re: No sound on Multi-channel audio TV shows after 4.2 update
    AppleSauced5 Level 1 Level 1 (0 points)
    I am stunned that Apple has not produced a patch yet. Apple, I can't watch anything with 5.1 encoding INCLUDING movies purchased through iTunes.

    A-mazing.
  • 38. Re: No sound on Multi-channel audio TV shows after 4.2 update
    Dhlee3 Level 1 Level 1 (0 points)
    Brett, can you please provide a status update on this fix? Thanks for your help.
  • 39. Re: No sound on Multi-channel audio TV shows after 4.2 update
    rastriffler Level 1 Level 1 (0 points)
    Hey Andreas,

    From your screenshots, it looks like only the video and stereo tracks are enabled in subler. Could this be what fixed your problem? If the surround sound track (AC-3) were disabled, you'd effectively have only one track.
  • 40. Re: No sound on Multi-channel audio TV shows after 4.2 update
    Mac6767 Level 1 Level 1 (0 points)
    Is it just me or has the issue of the upgrade messing up the sound on the TV2 been going on for too long with no sign of a fix??
    I can't believe it is taking so long to sort a problem apple have clearly created here.
  • 41. Re: No sound on Multi-channel audio TV shows after 4.2 update
    tmartine Level 3 Level 3 (955 points)
    maybe because it's a problem that isn't actually experienced by very many people... i don't see this problem at all.. and others on this very thread don't experience it either.. some on this thread have change setting and got it working too..

    i know sometimes it seems like lots of people are experiencing a problem because you come here and you see what seems to be a lot of posts.. but there are millions of these things out there.. a handful of post on a forum where people specifically come because they have a problem may give a skewed perspective of how prevalent a problem really is... like going to a hospital and concluding that the population at large has a huge health problem based on the number of people you see sick at the hospital..

    from what i can see it really looks like they have tightened up their code and it's excluding files that aren't structured in a very specific way.. in truth.. a standards compliant way.. in the history of AppleTV this has happened before... when they 1st changed the structure of their .m4v container to accommodate AC3 (DD 5.1).. appleTV could play the files before the file structure was standardized and then when it was standardized people that had created movies that once worked stopped working once they updated their appleTVs.. Apple later relaxed what appleTV was looking for and those files again played properly.. it kinda looks like that has happened again.. some one probably looked at the code and according to standards these files are not standards compliant and didn't consider them when changing the code.. and they stopped working.. but still for the vast amount of users it's business as usual.. and it's not really a bug because the code is really working as it should according to standards.. it's really a feature to allow non-standards compliant files to play.. just a theory base on appleTV..
  • 42. Re: No sound on Multi-channel audio TV shows after 4.2 update
    AppleSauced5 Level 1 Level 1 (0 points)
    This theory doesn't hold water. Apple's OWN movies purchased from iTunes don't play.

    I can't get anything 5.1 encoded to play whether I use HDMI OR plug Apple TV direction into a sound system via the optical-out.

    It's. Just. Plain. Screwed.
  • 43. Re: No sound on Multi-channel audio TV shows after 4.2 update
    tmartine Level 3 Level 3 (955 points)
    I think we have two cases.. as i've said earlier in the thread...

    1) people with non-standards compliant files.. read the thread.. people have reformatted their files and they have started working..
    2) people that just need to restart their appleTV.. or they need to change some setting.. toggle DD 5.1 on/off etc.. appleTV 2 code is still not as stable as it should be.. read this thread.. people have restarted and/or toggle DD on/off and is started working

    ..maybe 3) a tiny portion of people who have equipment that for whatever reason is incompatible with the upgrade..

    but the post i was responding to asked.. why the slow response from Apple? and the likely answer to that is that very likely, very few people have this problem.. i don't.. i've had it flake out a few times.. i toggled DD5.1 on/off or restarted and it came right back.. i sympathize.. it ***** if it's you that it doesn't work for, but you have to accept the fact that if this was not working for huge numbers of people, a fix would have been out pretty fast.. the most likely reason it isn't is because it's affect only a very small number of users..

    Message was edited by: tmartine
  • 44. Re: No sound on Multi-channel audio TV shows after 4.2 update
    terraemotus Level 1 Level 1 (0 points)

    The latest update to version 4.2.2 of the AppleTV firmware resolved this issue for my movies with 5.1 channel sound (those ripped in Handbrake 0.9.3 or earlier). Thanks Brett L & Apple.

     

    Philip, Williamstown