Skip navigation
This discussion is archived

attachments received are jibberish

534 Views 17 Replies Latest reply: May 25, 2006 3:50 PM by Stephen Emmett RSS
1 2 Previous Next
jayhawk Level 1 Level 1 (40 points)
Currently Being Moderated
Oct 27, 2005 7:04 AM
I am using mail.app to access my Groupwise account (IMAP) and my students are required to send me many attachments. Lately (since upgrading to 10.4), I am getting MS Word files and .JPGs and about 1/4 of these attachments show up as jibberish and not as attachments. If i start up Entourage and get my mail, I can clearly see the attachments and download them just fine even though they don't appear in mail.app.

I upgraded my wife to 10.4 just yesterday and now she is experiencing the same thing with MS Word files from her students.

Here's an example of just a small portion of what appears in my email text instead of the attachment i should have received:

--==_ZMF1618_==
Content-Type: application/octet-stream; name="ed205_001.jpg"
Content-disposition: attachment; filename="ed205_001.jpg"
Content-Transfer-Encoding: base64

/9j/4Q4FRXhpZgAASUkqAAgAAAAFABoBBQABAAAASgAAABsBBQABAAAAUgAAACgBAwABAAAAAgAA
ABMCAwABAAAAAgAAAGmHBAABAAAAWgAAAKgAAABIAAAAAQAAAEgAAAABAAAABgAAkAcABAAAADAy
MDABkQcABAAAAAECAwAAoAcABAAAAAECAwABoAMAAQAAAAEAAAACoAQAAQAAAFgCAAADoAQAAQAA
AMIBAAAAAAAABgADAQMAAQAAAAYAAAAaAQUAAQAAAPYAAAAbAQUAAQAAAP4AAAAoAQMAAQAAAAIA
AAABAgQAAQAAAAcBAAACAgQAAQAAAPYMAAAAAAAASAAAAAEAAABIAAAAAQAAAAD/2P/gABBKRklG
AAEBAQAAAAAAAP/bAEMAAwICAwICAwMDAwQDAwQFCAUFBAQFCgcHBggMCgwMCwoLCw0OEhANDhEO
CwsQFhARExQVFRUMDxcYFhQYEhQVFP/bAEMBAwQEBQQFCQUFCRQNCw0UFBQUFBQUFBQUFBQUFBQU
FBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFBQUFP/AABEIAEAAWAMBIgACEQEDEQH/xAAf
AAABBQEBAQEBAQAAAAAAAAAAAQIDBAUGBwgJCgv/xAC1EAACAQMDAgQDBQUEBAAAAX0BAgMABBEF
EiExQQYTUWEHInEUMoGRoQgjQrHBFVLR8CQzYnKCCQoWFxgZGiUmJygpKjQ1Njc4OTpDREVGR0hJ
SlNUVVZXWFlaY2RlZmdoaWpzdHV2d3h5eoOEhYaHiImKkpOUlZaXmJmaoqOkpaanqKmqsrO0tba3
uLm6wsPExcbHyMnK0tPU1dbX2Nna4eLj5OXm5jp6vHy8/T19vf4fr/xAAfAQADAQEBAQEBAQEB
AAAAAAAAAQIDBAUGBwgJCgv/xAC1EQACAQIEBAMEBwUEBAABAncAAQIDEQQFITEGEkFRB2FxEyIy
gQgUQpGhscEJIzNS8BVictEKFiQ04SXxFxgZGiYnKCkqNTY3ODk6Q0RFRkdISUpTVFVWV1hZWmNk
ZWZnaGlqc3R1dnd4eXqCg4SFhoeIiYqSk5SVlpeYmZqio6Slpqeoqaqys7S1tre4ubrCw8TFxsfI
ycrS09TV1tfY2dri4Tl5ufo6ery8/T19vf4fr/2gAMAwEAAhEDEQA/AP1Tor5q/bM8W654Xh8K
jRdZ1DSDOl75psLp4TJt8nbnaRnGTj0ya+U
  • Syncopator Level 1 Level 1 (115 points)
    Currently Being Moderated
    Oct 19, 2005 12:05 AM (in response to jayhawk)
    I'm having the same problem!

    I came here to post about the problem, but thought I'd search the forum first. I'm accessing IMAP accounts, as well -- but they're AOL accounts. I was prepared to blame AOL for this, but since you're not using AOL, that seems to point back to Mail itself as the culprit.

    What's interesting is this: If you know how AOL works, you know there's an AOL application that one would typically use to read mail and access all of AOL's features. But when I switched to Mail, a little over a year ago, I stopped using the AOL app. I haven't needed it. However, every time I get an undecoded, "gibberish" message in Mail, if I then log on with the AOL app, I'm able to acces that message just fine!

    More details:

    Sometimes the messages are displayed as "gibberish," but at other times, they're completely blank -- no text, no anything. Then, 100% of the time, I'm able to access those messages with the AOL app.

    The problem messages always have attachments: either PDFs, zipped files, or a single image file (JPEG, etc.). When the attachment is a zipped file -- say 5 photos zipped together -- Mail will often display one or two of the images, but not all 5. But not consistently! At other times, Mail will correctly display all 5 images -- and this inconsistent behavior happens even with mail from the same sender!!

    Just today, someone sent me five separate messages, sent from the same e-mail address, each containing five, zipped images. In two of the messages, Mail displayed all 5 images properly. In another two messages, Mail only displayed 2 images, and in the 5th message, Mail displayed none!

    What on earth is going on??? I'm having to launch the AOL app several times a day, just to access standard attachments! But, as Jayhawk said -- it's not 100% of the time. For me, it's somewhere between 25 and 35% of the time.

    I'm a loyal Apple fan -- but I'm fuming over this.
  • OVozeh Level 3 Level 3 (840 points)
    Currently Being Moderated
    Oct 19, 2005 4:05 AM (in response to jayhawk)
    In my experience, this has to do with IMAP accounts in MAIL. I have had an AOL IMAP account and frequently experienced the same problem (with attachments of all kinds). Once I started using my .Mac account only, the problem has disappeared. So, it could be simply AOL or, it could be any IMAP account. I don't have time to experiment which it is. I do believe that Apple knows about this issue.
  • Austin Kinsella1 Level 6 Level 6 (11,505 points)
    Currently Being Moderated
    Oct 19, 2005 5:32 AM (in response to jayhawk)
    Have you tried saving it to disk and then using Stuffit Expander?
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Currently Being Moderated
    Oct 19, 2005 6:43 AM (in response to Austin Kinsella1)
    It is also possible that the sender is using a poorly written mail program (like almost anything Microsoft...outlock, OuthouseExpress).
    Plus you're using Group-unWise? It's possible that your GW server is doing something funky with the mail/attachments as they're recieved on the server.

    Or they're inserting, instead of attaching.

    But why Mail is even displaying the contents of a ZIP file is odd.
    I wonder why you're not using the program associated with the file type?
    Word for word docs, stuffit/finder for ZIP's/preview for JPG's..

    Try saving the attachment like Austin suggests. Then open the saved file.
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Currently Being Moderated
    Oct 19, 2005 8:45 AM (in response to jayhawk)
    OK, I see what you mean.
    I would almost suggest trashing the Mail prefs (since your mail SHOULD know how to handle these kinds of mail msgs.)

    I sure seems that Mail just plain forgets how to handle attachments, and sometimes hangs on as an atachment, and sometimes tries to display 'inline' (in the msg).

    But if you're convinced that it's nothing to do with the Sender, or their Server, or your Groupwise Server...then look at rebuilding your prefs. (I'm not on my Mac just now, so I can't point you to which plists to delete.)
  • Austin Kinsella1 Level 6 Level 6 (11,505 points)
    Currently Being Moderated
    Oct 19, 2005 12:21 PM (in response to jayhawk)
    This is not intended as a fix, but as a work-around so that you can retrieve the pics. Use File/Save as... to save the message. I don't know whether it will make a difference, so if Raw Message doesn't work try Plain Text. Drop the resulting file onto Stuffit Expander. It may expand in the same location as your saved file, or it may make a new folder there and expand in that. Either way you will have two (maybe more) files, one containing the text (and maybe the headers) of the email and one containing the jpeg.

    I use this technique for extracting student reports sent as attachments, but automated in an Applescript - if you like I can post it.
  • southcityguy Calculating status...
    Currently Being Moderated
    Oct 20, 2005 8:21 AM (in response to Austin Kinsella1)
    Wow! Beleive it or not, that workaround actually worked! Thanks for the idea. I am having the problem with message created on mac and sent via my own internal mailserver from someone else on my network so I definitely think the problem resides in Mail. (also, never saw this before upgrading to Tiger!) Hope Apple comes up with a fix soon...
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Currently Being Moderated
    Oct 20, 2005 2:02 PM (in response to southcityguy)
    Does anyone who is having this problem NOT use some form of IMAP?
    Are there any of these problems when getting mail from POP server?

    just wondering.
  • Neil Saravanamuttoo Level 1 Level 1 (75 points)
    Currently Being Moderated
    Oct 26, 2005 8:47 PM (in response to jayhawk)
    My wife and I each have an account within the same Mail app on a single computer (as a single user).

    When I send using my wife's pop account, attachments are sent fine.

    But when I send using my .mac account, attachments are scrambled.
  • Rick Van Vliet Level 5 Level 5 (6,385 points)
    Currently Being Moderated
    Oct 26, 2005 9:11 PM (in response to Neil Saravanamuttoo)
    Interesting. (Thanks Neil)
    Not to raise more questions than are warranted, but are we:
    1) dragging the file into the msg, or using the attach/paperclip button an browsing?
    2) Are you using "Windows-Friendly Attachment" setting?
    3) are messages being composed using Rich Text or Plain Text (Preferences)?

    But dot-mac is IMAP-based, isn't it...
    Is there some reason to believe that these two IMAP servers aren't somehow misconfigured?
    Or that the client isn't misconfigured.

    We need Ernie to pop in with an idea --- he's really good with mail. I'm just trying to eliminate a few variables (and Mail has a few(!) built in. Not to mention the variety of screwed up mail servers. sorry, groupwise
  • Neil Saravanamuttoo Level 1 Level 1 (75 points)
    Currently Being Moderated
    Oct 27, 2005 7:04 AM (in response to Rick Van Vliet)
    Rick

    To answer your questions:

    1- I am using the paperclip
    2- yes, Windows-friendly attachments
    3- probably Rich Text (sorry, away from my home computer right now)

    Cheers, Neil
  • DPSG-Scout Level 4 Level 4 (1,135 points)
    I'm experiencing a similar problem.

    We've got a TiBook and an iMac connected to the same IMAP account.

    Sometimes the iMac doesn't download MS Word attachments correctly, displaying them as garbage text within the original email. The Powerbook though doesn't have trouble at all. I can even forward an email, which doesn't display properly on the iMac, to myself using the PB and the iMac will download the forwarded attachment without any issues. Furthermore, the iMac refuses to check for emails from time to time, telling me there aren't any new messages. I restart Mail and all of a sudden, new (actually, rather old) messages are flying in. This didn't get fixed by upgrading to 10.4.3.

    Will try deleting prefs...


    Mail was acting up on a different AlBook as well. We had an IMAP account functioning fine for months, then over night Mail reverted to it's default state, displaying that "welcome, please enter your account information.." screen at launch. (Luckily we're using IMAP, so I just punched in the server settings and let Mail sync again.) FileVault user, btw.
    15 PB G4 Ti 867Mhz; 768 RAM; iPod;, Mac OS X (10.4.3)
  • Daniel Kaplan Level 1 Level 1 (55 points)
    Currently Being Moderated
    Dec 22, 2005 12:27 PM (in response to Austin Kinsella1)
    Your workaround doesn't work well enough. I have emails like that that say they have 4 attachments, but Mail thinks they are just long text files. When I save the message to a file and expand it with Stuffit Expander, one of the attachments is decoded but the others are not.

    I am getting my mail through an imap server.

    We need a reliable workaround or a fix! Like the rest, I think this only started happening when I upgraded to Tiger - the earliest such mail that I seem to have was received on Aug. 24.

    (I can get the attachments through a web email interface, but it is a pain compared to the convenience of OS X Mail.)

    PowerBook G4 15 (Titanium) Mac OS X (10.4.3)

    PowerBook G4 15 (Titanium)    
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.