Skip navigation
This discussion is archived

23" Cinema Display with no Backlight/Pixel issues ?

1113 Views 6 Replies Latest reply: Jan 2, 2006 7:05 PM by RSC10 RSS
RSC10 Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 1, 2006 2:05 PM
A question for all. Is one stuck pixel (in my case, red) enought to warrant returning a 23" Cinema display? I guess another way to ask this is is there anyone out there that has a 23" display with no backlight bleeding issues and no stuck or dead pixels whatsoever? I ask, because it took two returns to get to this point. The first two displays I received through Compusa had serious back light bleeding issues and dead/stuck pixels (one display had four stuck pixels, another had 6 stuck pixels and 1 dead pixel). So now I've got a beautiful display that has no backlight bleed issues....but just one tiny stuck pixel in the middle of the screen that is only visible against a totally black screen. Guess I just am curious if a "perfect display" exists. Anyone ??
Powerbook G4, Mac OS X (10.4.3)
  • QK Level 1 Level 1 (90 points)
    Currently Being Moderated
    Jan 1, 2006 6:29 PM (in response to RSC10)
    I got my 23' in June 2005, and it perfect, i ordered it from the Apple store, i was concerned about all the negative feedback.

    I guess i got lucky, 0 dead/stuck pixels and 0 issues.
    iMac RevB 20' 1GB / Mini 1.42 1GB (BT/Airport), Mac OS X (10.4.3)
  • babartol Calculating status...
    Currently Being Moderated
    Jan 1, 2006 11:13 PM (in response to RSC10)
    I do also have a "perfect 23."

    It didn't start out that way, but the issue had nothing to do with pixels. Until someone at the local Apple store would finally listen to me and think a little bit outside the box, the display managed to fry four separate logic boards--three of mine and one belonging to them at the store.

    Through it all though, in the output category, it has performed brilliantly.

    PowerBook G4   Mac OS X (10.4.3)  
  • Mark Lynch1 Calculating status...
    Currently Being Moderated
    Jan 2, 2006 12:33 AM (in response to RSC10)
    Hi, I have no issue with dead pixels on my 23" display. Thankfully I have a perfect display of pixels. However, mine has started to develop a persistent fault whereby if I powerdown/restart or put the computer to sleep the display will not power up/wake up. I have to pull the DC plug from the power adapter and reinsert it. Only then the display comes back on and everything's fine. Anyone else have this problem?



    PowerMac G5 Dual 2.7GHz 1GB RAM Mac OS X (10.4.3) ATI 9650 chipset ATY,RV351
    PowerMac G5 Dual 2.7GHz 1GB RAM, Mac OS X (10.4.3), ATI Radeon 9650 Chipset ATY,RV351
  • Daniel Speich Calculating status...
    ive got 5 really nasty stuck pixels on my brand new 23" cinema display. a red one in the middle surrounded by 4 green ones. They're really annoying, and that's why i also want to return it to get another one, but I dont know if it's enough
    G5 2x2GHz 1gb RAM, Mac OS X (10.4.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.