Skip navigation

Why won't iPhoto 9.1.1 export edited pictures?

1599 Views 11 Replies Latest reply: Apr 21, 2011 10:40 AM by Apple_TV_fan RSS
Apple_TV_fan Calculating status...
Currently Being Moderated
Apr 17, 2011 10:01 AM

I've tried to search the forum for an answer as to why iPhoto is not allowing me to export photos that have been edited in iPhoto, and have not found a solution, so please forgive me that I am asking a question that so many have asked.


What I am trying to do: Import a picture from a camera, perform minor editing in iPhoto, and export it to a site for printing.


How I am attempting: Insert CF or SD card into reader, import into iPhoto, click the "Edit" button, adjust exposure curves, and add a little edge blur.


After performing edits, I cannot:     Drag the photo from iPhoto to the desktop nor a folder

                                                  Click File> Export> Select options to write photos to a folder, USB stick, etc


Under File> Export I have tried:      Selecting Original, Current, JPEG, TIFF, and PNG for "Kind"

                                                    Selecting all combinations of "Quality and Size"

                                                    Tried using File Names as Sequential, Title, Album Name with number, and filename


Error I get:          Unable to create /Users/username/foldername/  ; dragging still results in "No Smoking" symbol


I have tried:      restarting machine

                       repairing Disk permissions

                       Repairing Iphoto library database,

                       Examine and repair iPhoto Library File Permissions

                       Deleting, replacing, repairing iPhoto plist



Any insight would be appreciated. This is performed on an intel iMac core 2 duo, Snow Leopard 10.6.7, iPhoto 9.1.1-   FYI- all functions work as expected on my Macbook pro.




iMac, Mac OS X (10.6.7)
  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Apr 17, 2011 10:47 AM (in response to Apple_TV_fan)

    Select one of the affected photos in the iPhoto Window and go File -> Reveal in Finder -> Modified File. A Finder Window should open with the file selected. Does it?






  • Old Toad Level 10 Level 10 (113,285 points)
    Currently Being Moderated
    Apr 17, 2011 11:13 AM (in response to Apple_TV_fan)

    Try resetting the preferences on the iPhoto library using BatChmod with the settings shown in the screenshot below:




    Also delete the iPhoto cache file that's located in your Users/Home/Library/Cache/ folder.


    Then launch iPhoto and try again.



  • Old Toad Level 10 Level 10 (113,285 points)
    Currently Being Moderated
    Apr 18, 2011 7:15 PM (in response to Apple_TV_fan)

    That previews folder is just the thumbnails.  Look in the Masters folder for a similarly named folder and see if there are any full sized images in it and how many.    It's beginning to sound like those originals have been deleted or moved but not by iPhoto.

  • Terence Devlin Level 10 Level 10 (121,745 points)
    Currently Being Moderated
    Apr 19, 2011 1:49 AM (in response to Apple_TV_fan)

    No, as a matter of fact, it does not. A Finder window does open, but there is no file selected.


    That means that iPhoto has lost the connection to the file. As you also report, the files just aren't there (which would explain why iPhoto can't find them) I would suggest that you need to restore from your back up.






  • dankohn Level 1 Level 1 (30 points)
    Currently Being Moderated
    Apr 19, 2011 7:05 AM (in response to Apple_TV_fan)

    If you reimport, can you replicate the problem?

  • Fred Harwood Calculating status...
    Currently Being Moderated
    Apr 19, 2011 8:35 AM (in response to Apple_TV_fan)

    Apple's Express Line advisor told me that this is a known problem and will be addressed. Simply stated, the externally edited photo is saved but not where export looks for it. The workaround, which works for me, is to click on the edited photo and then revert to original, which does not revert, but does link to the modified photo (or, puts the modified photo in the proper place).


    This may not be the only problem, but it fixed my problem.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.