Skip navigation

MacBook Pro: Trackpad settings reset after restart.

89693 Views 70 Replies Latest reply: Feb 2, 2013 7:34 PM by Ian Cheong RSS
1 2 3 ... 5 Previous Next
iLukeKendall Calculating status...
Currently Being Moderated
Feb 17, 2011 3:59 AM
Hey guys,

Was just wondering if anyone could shine some light on the problem I'm experiencing at the moment.

For some unknown reason, my MBP (current model, with latest firmware) keeps 'forgetting' the trackpad settings I choose every time I restart/turn it off and on.

The issue lies with the settings for enabling 'One Finger' settings, specifically 'Tap to Click', 'Dragging', and 'Secondary Click - Bottom Right Corner'. I'll tick the settings, but after a reboot the boxes are unchecked again.

This is pretty annoying as I'm having to change the settings every time I turn my computer on.

Does anyone have a solution to my issue?

Many thanks,
Luke
MacBook Pro (Current), Mac OS X (10.6.6)
  • Linc Davis Level 10 Level 10 (108,150 points)
    Those settings are stored in the file Library/Preferences/.GlobalPreferences.plist in your home folder. The file may be corrupt. I suggest you move or rename it, log out, and log back in. Then set up your trackpad again and see whether the settings stick across sessions. You'll need to set quite a few other preferences as well.

    Note that the file is invisible in the Finder by default, so you'll either have to show invisible items or use the shell to get to it.
    Mac OS X (10.6.6)
  • Linc Davis Level 10 Level 10 (108,150 points)
    The next question is whether the problem lies in your user files or in the operating system. Log in to the guest account (enabling it if necessary in the Accounts preference pane) and see whether you can reproduce the problem there. If you can't, then something is wrong with your account. If you can, then something is wrong with the system, the hardware, or third-party software that you installed.
    Mac OS X (10.6.6)
  • Linc Davis Level 10 Level 10 (108,150 points)
    An intermittent problem might be hardware-related. If you're close to the end of your warranty, consider taking the machine to an authorized shop to be checked out.
    Mac OS X (10.6.6)
  • Peter Honeyman Calculating status...

    I have been having the same forgetful trackpad settings problem reported by OP for several months now ... it's annoying, but somewhat easier to fix on the occasion than to try to understand what's going on.  But it happened again this morning, so I googled macbook forgets trackpad settings and that took me here.  No answers, but I agree with the overall hypothesis that it's time for a fresh OS install.

     

    Fact is, my (i7 8GB) MBP has been panicking on a regular basis for a while, always

     

    panic(cpu 2 caller 0x226b57): "thread_invoke: preemption_level -1, possible cause: unlocking an unlocked mutex or spinlock"@/SourceCache/xnu/xnu-1504.9.37/osfmk/kern/sched_prim.c:1471

     

    with the locationd process implicated.  This bug has persisted across several Snow Leopard major updates, more or less on a monthly basis.  (I have taken to writing "I hate you" in my the love note section of the (anonymous!) report to Apple.)  I am guessing that my network stack, infiltrated by both Cisco VPN and VMware, has been become a battleground for control by a bunch of witless giants.

     

    But I have strayed from the trackpad problem ... I just wanted to s.o. that I have symptoms just like iLukeKendall.  I guess I'll reset PRAM.  (Old school shout out!)

  • jwestover Calculating status...

    I have just started experiencing a similar issue. I have done a PRAM reset and an SMC reset which has been no help.

  • bigheadjer Calculating status...

    I've been experiencing this as well since about the same timeframe as the OP.  Just upgraded to 10.6.8 and the same problem still occurs.  I have done a find/grep on all plists in ~/Library/Preferences and /Library/Preferences and the only plist that contains trackpad and mouse settings are in .GlobaPreferences.plist and those contain the right values.   BTW I ran into some other users having this problem which is related to them having installed and tried out MagicPrefs at some point.  I did, but I followed all instructions for removing MagicPrefs but to no avail.

     

    Did any of you also try MagicPrefs at some point?

  • bigheadjer Level 1 Level 1 (10 points)

    Yeah the thing is I wasn't the only one with problems post-uninstalling MagicPrefs.  I might send a separate email to the developer of MagicPrefs as well to ask.  It seems like .GlobalPreferences.plist seems to keep getting overwritten, and MagicPrefs seems to be the common link for this issue.

  • BarbarellaTV Calculating status...

    I've never used MagicPrefs, but i've been experiencing this problem since I upgraded to 10.6.8..can be an upgrade problem?

  • Brad Bishop Level 1 Level 1 (10 points)

    Something I just did that worked for me:

     

    Go to: Utilities -> Disk Utility

    Select your Mac's drive.

    Select the "First Aid" panel

    Click on "Repair Disk Permissions"

    (it'll churn for a while)

     

    Then reboot.

     

    Then make your settings changes.

     

    Then reboot and verify.

     

    Seemed to work for me.

     

    Good luck!

  • Brad Bishop Level 1 Level 1 (10 points)

    Never mind... A reboot later and it was back to the way it was.

     

    This is very frustrating.

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.