11 Replies Latest reply: May 29, 2011 12:20 AM by michael_k
yasmin.k Level 1 Level 1 (0 points)

we have in the company about 25 Macs which are integrated in the ADS via the Centrify plugin.
So far so good.
Beside this we have an MacMini Server which should be used for SUS, Packages, NetInstall (later).

My issue is for now with the SUS.
It's configured correctly, the packages are being downloaded and synced with Apple, the Group Policy in Centrify is set up correctly so the clients are able to see the server via port 8088 and indeed they are looking for the software on the server.
But here's the issue: each client is saying "Your software is up to date", but in the background I can see that there is something (the window with the software list appears in the background).

I suppose this is related to the SUS and not to the Centrify software.

Can someone help, please?


iMac 2.4; PowerMac G4 Quicksilver 2001, Mac OS X (10.6.6)
  • 1. Re: Issues with SUS
    VincensoXFIN Level 1 Level 1 (40 points)
    Im not sure how did you configure clients to use your mac mini to download updates, but thats not the way I did it.

    When I first built up my Software Update service, I had to configure each mac to use my own update server via terminal on the client, using this command


    sudo defaults write /Library/Preferences/com.apple.SoftwareUpdate CatalogURL http://your.server.ip.address.or.domain.name:8088/index-leopard-snowleopard.merg ed-1.sucatalog

    You should try that with one client machine, if you are running Snow Leopard. I think the command with leopard was very similar, but can't recall what part was different.

    Hope this helps.
  • 2. Re: Issues with SUS
    yasmin.k Level 1 Level 1 (0 points)
    I've already tried this, in the server log I can see that the client is looking for the "index-leopard-snowleopard.merged-1.sucatalog" but I have the same effect, a window with the details appears in the background (the one you get when software is available)...
  • 3. Re: Issues with SUS
    MrHoffman Level 6 Level 6 (12,455 points)
    That reported ghosted software update display is, um, quite abnormal.

    Remove the Centrify plug-in from one client, and see SUS starts working.
  • 4. Re: Issues with SUS
    yasmin.k Level 1 Level 1 (0 points)
    I've tried it on one client with the Apple ADS plug-in and on another one without any ADS bindings.
    The same effect, "Your software is up to date" in front of the details window.
  • 5. Re: Issues with SUS
    Terry Fundak Level 2 Level 2 (150 points)
    I had a client where I had something like this....

    It turned out that my SUS URL had a single / after the http:/sus.mydomain.com/...

    not the correct http://sus.mydomain.com/...

    Check your client configuration string carefully.

    On my the software updates download but the Software Update process just stopped when it was time to do the install..... i.e it appeared to hang.... ghost with no complaint at all..... I ended up thinking my client OS was corrupt but a reinstall and restore of User data resulted in the same issue...... All because of a "/" being missing....

    Maybe this will help someone.....
  • 6. Re: Issues with SUS
    yasmin.k Level 1 Level 1 (0 points)
    I've double-checked the URL, it's correct, with //
    Still the same...
  • 7. Re: Issues with SUS
    HackerJL Level 1 Level 1 (0 points)
    Confirmed this happening with me as well! PAIN!
  • 8. Re: Issues with SUS
    michael_k Level 1 Level 1 (0 points)

    Add me to the list! Having same Issue...and no solution... :-(

  • 9. Re: Issues with SUS
    HackerJL Level 1 Level 1 (0 points)

    Michael, no movement on this?

  • 10. Re: Issues with SUS
    Leif Carlsson Level 5 Level 5 (4,950 points)

    Try looking at the URLs that the SUS provide for the update files.


    If you go to the server: http://<yourserver>:8088/catalogs.sucatalog


    Look at / use one of the "links" on the page to try to find the SUS from a SUS client


    The names should match or at least the URLs for each update file must point to the SUS server.


    The SUS might have been setup / configured using a different server name or maybe DNS is lacking the correct information.

  • 11. Re: Issues with SUS
    michael_k Level 1 Level 1 (0 points)

    Actually I got it working but only with all Updates and autocopy enabled. It tooks 6 hours till everything was green(everything was! downloaded before). Now the updates runs much faster and save bandwith, but I’m still not able to provide only selected Updates, which, I guess, would make sense not only in my environment.