5 Replies Latest reply: May 14, 2011 9:43 AM by trevor1ders
Leomar Level 1 Level 1 (0 points)

Please advise how come my Mac Mini keeps on hanging on me while rendering a movie using IMovie. Can anybody please advise me on this issue... Thanks.


Mac Mini, Mac OS X (10.6.4)
  • 1. Re: IMovie Problem
    Bengt Wärleby Level 6 Level 6 (19,160 points)

    Hi

     

    Not knowing the origin to Your problem - General approach when in trouble is as follows.

     

    • Free space on internal (start-up) hard disk if it is less than 10Gb should rather have 25Gb

     

    • Delete iMovie pref file

     

    iMovie pref file resides.

    Mac Hard Disk (start-up HD)/Users/"Your account"/Library/Preferences

     

    and is named. (one or more of these)

    com.apple.iMovie.plist

    com.apple.iMovie3.plist

    com.apple.iMovie7.plist

    com.apple.iMovie8.plist

    com.apple.iMovie9.plist

    com.apple.iMovieApp.plist

     

    and find

    com.apple.iApps.plist

     

    While iMovie is NOT RUNNING - move this/these file/s out on to desk-top.

    Now restart iMovie.

     

    • Hard disk is untidy. Repair Permissions, Repair Hard disk (Apple’s Disk Utilities application)

    • Garageband-fix. Start it, Play a note and Close it. Re-try (Corrects an audio problem that hinders iMovie)

    • Screen must be set to Million-colors

    • Turn off Mac and disconnect Mains/Power for 20-30 minutes - will at least re-set FW-port

    • Third party plug-ins that doesn't work OK (not relevant for iMovie’08 or 09 or 11)

    • Problems in iPhoto Library can affect iMovie to crash on start-up. Re-build this first then try to re-start iMovie.

    This You do by

    _ close iPhoto

    _ on start up of iPhoto - Keep {cmd and alt-keys down}

    _ now select all five options presented

    _ WAIT a long long time

     

    • iMovie updated ?

    • QuickTime updated ?

    • Mac OS version ?

     

    • Program miss-match. iMovie 4 - will not work under Leopard

    • Program miss-match. iMovie 5.0.2, up to Mac OS X.4.11 AND QuickTime 7.4.1 - is OK

    • Program miss-match. iMovie 6.0.3 or 6.0.4, Mac OS X.4.11 AND QuickTime 7.4.1 - is OK (will work under Leopard and Snow-Leopard)

    • Program miss-match. iMovie’08 v. 7.1.4, Mac OS X.4.11 AND QuickTime 7.5.5 - is OK (will work under Leopard and Snow-Leopard)

    • Program miss-match. iMovie’09 v. 8.0.6, Mac OS X.5.8 AND QuickTime 7.6.4 - is OK (will work under Leopard and Snow-Leopard)

     

    From LKN 1935. (in this case = iMovie HD (5), I tried it all, but nothing worked.

    Your answer (above) has been helpfull insofar as all the different trials led to the conclusion that

    there was something wrong with my iMovie software. I therefore threw everything away and reinstalled

    iMovie from the HD. After that the exportation of DV videos (there has not been any problem with HDV videos)

    to my Sony camcorders worked properly as it did before.

     

    Lennart Thelander

    I run "Cache Out X", clear out all caches and restarts the Mac.

     

    Yours Bengt W

  • 2. Re: IMovie Problem
    Leomar Level 1 Level 1 (0 points)

    I am still getting the same problem.  Do you think increasing my RAM will help?  Also, do you think there is something to do with the length of the movie I am processing?  Currently, the movie is about 2 1/2 hours in length.  Kindly advise.

     

    Thanks a lot.

  • 3. Re: IMovie Problem
    FangSuede Level 4 Level 4 (2,195 points)

    Try setting your energy saver System Pref's so the computer will not 'sleep' while rendering the movie.

  • 4. Re: IMovie Problem
    Leomar Level 1 Level 1 (0 points)

    @FangSuede... thank you for your suggestion.  I already did that but is not helping me at all.  I am on the process of shortening the file, hopefully it will solve the issue. 

  • 5. Re: IMovie Problem
    trevor1ders Level 1 Level 1 (0 points)

    I am having problems too, I have an Apple iBook G4 with a 60gb hard drive (only like 5gb free, but more than enough to save the movie) and 1.5gb ram. (1.33 GHZ processor)and Mac OS 10.5 Leopard. and I'm trying to save an 18 minute video in HD, the blue bar will move not even a quarter of the way across, then it stops and the estimated time remaining just keeps going up and up and up and up and the blue bar doesnt move at all, and the time NEVER stops going up and it never saves the movie! i am now trying to save it to my 8gb flash drive and its STILL doing it! there was one time where it did save and it saved the movie in like 2 mins which is odd, but then when i played it, it played for 30 seconds then the video froze so you were looking atthe same frame for the rest of it, but you could still here the audio. (that was before it stopped saving at all) is there any fix to this? I NEED this movie to save ASAP!!!!!!!!!!!!!!