Skip navigation

Unlockable External Drives

493 Views 7 Replies Latest reply: May 23, 2011 11:10 AM by Michael Branagan1 RSS
Michael Branagan1 Calculating status...
Currently Being Moderated
May 2, 2011 3:02 PM

I have 2 1.4 TB external drives attached to an intel macmini running snow leopard server.  For some reason today, the server started to display a bunch of error message when I was trying to copy a folder.  So I restarted, only to get a grey screen with the rotating grey beach ball.  Booted off the dvd and ran disk utilities, which seemed to fix things, or so I thought.

 

I lost all user accounts except primary admin.  filemaker server trashed as is addressbook server.  Open directory gone too.  [I have a DVD that I store software on, but now the DVD is unreadable on the mac mini (and imacs as well).  It was always readable.]

 

Worse yet, external drive Backup_A (connected via firewire to mac mini) is locked and says I don't have permissions to see contents.  It is the clinic's central time machine drive for the mac mini server and the 3 other imacs.  The 2nd external drive Backup_B (connected via usb to  mac mini)  backs up Backup_A drive.  I also have an older 500 GB TimeCapsule that I just started to use to backup Backup_B.  While I can seem to retrieve all critical data files, all 3 drives have the little "locked" icon.  Get Info on each drive has no unlock checkbox.  Trying to change sharing and permissions via Get Info is ineffective.  Using terminal commands (cd /Volumes then chflags -R nouchg Backup_A) is ineffective as I get error statements telling me I do not have permission.

 

Before I erase all drives and start over I'd, well, NOT want to erase anything.  Zillions of TM backup are within my reach.

 

This is a REAL pain.  Suggestions?

Several Models, Mac OS X (10.5.6)
  • VincensoXFIN Calculating status...
    Currently Being Moderated
    May 3, 2011 3:25 AM (in response to Michael Branagan1)

    Have you tried to edit ACL or posix with Server Admin ? I rarely use that Get Info thingy because its zillion times slower if you have lots of folders. What I recommend is that you open Server Admin (if its working properly). And I believe that Server Admin is able to browse the drive even if it seems to be locked.

     

    Go to File sharing (when server name is selected) and select Volumes and Browse from the tabs. Now browse your way to the drive you want to set permissions to. You should instantly see the applied ACL and POSIX on the bottom of the screen. Whats going on there? It could help if you could post and tell what do you see there? Gray accounts? No accounts at all?

     

    When you have browsed enough and investigated what is going on in that drive, you may want to recreate the ACL and Posix if there is something badly wrong in there. My guess is that you might see gray users or just _unknown users in the ACL or/and in posix. If thats the case, try to re-input the proper accounts and users in the list. You might regain access to drives if you re-create the permissions properly.

     

    If you can't re-create the permissions as they were. Try at least adding the server admin user to the ACL, full control, all files and folders all descendants, and then remember to save and propagate permissions. Use the small gear button on the bottom and select Propagate permissions.

     

    Hope you get this fixed. First, investigate, if you find something weird from the server admin, post it here, it might help to get better understanding of what has happened.

  • Sven-Goran Ljungholm1 Level 2 Level 2 (240 points)
    Currently Being Moderated
    May 3, 2011 5:22 AM (in response to Michael Branagan1)

    You say that you have a firewire drive that backs up the server? I would use that to restore your server to the last know good state. You mention that you are also running filemaker server. After a major crash with the same kind of setup I discovered that my filemaker databases were not backing up. I had time machine and FMS running a backup. Turns out that filemaker does not like Time Machine touching the files. I set up TM to ignore the Database folder that FMS uses and only back up using the FMS schedule.

     

    The reason the drives are locked is you lost your user list. The drives are looking at the permission set up for users that are no longer on the machine.


    Again I would boot from CD and do a time machine restore.

  • Sven-Goran Ljungholm1 Level 2 Level 2 (240 points)
    Currently Being Moderated
    May 3, 2011 7:54 AM (in response to Michael Branagan1)

    Just to check, when you boot of DVD and try to do a restore from Time Machine it doesn't work? It should show you a list of available backups on the drive.

  • VincensoXFIN Level 1 Level 1 (40 points)
    Currently Being Moderated
    May 4, 2011 5:41 AM (in response to Michael Branagan1)

    So, have you actually tried to boot off from the external drives? (Press alt down while booting, and boot straight off the external drive when they appear? Or do they show locked as well, or don't appear at all? Oh yeah, I don't know if thats possible with Time machine copies tho. Don't use it myself.

     

    Well, I would do re-install if I were in your shoes, because if you have hard copy of the most critical data, the loss may not be so devastating. And if you somehow managed to screw over OD and other services, maybe it's better to get a fresh start, maybe even improve your setup, think it over again. I had a total system failure last december and I was so ****** because there was not much I could do to save the setup, my RAID set broke up cos of my stupid mistake. I had good backups tho. But what I did was that I really went back to the drawing board, and watched some tutorials, read few articles and really started over. In the end when I re-installed the entire thing, it did came out much better than before. The valuable experience what I got from the first install gave me lot of good info to what to improve and what not to do at all.

     

    If you are going to reinstall, think it trough first with some time, and try to point things what you were not happy with and what was working OK. Then you can really improve things on the new install.

     

    By the way, I recommend to use something else with TimeMachine, if you still will use that. You should have a few bootable backups of the system lying around for these kind of occasions. I use Carbon Copy Cloner at the moment to make 3 backups in 1 week, 1 backup weekly, and 1 monthly. So if something goes wrong, I have a good chance to revert settings/things even a while backwards. CCC is easy and has been reliable for me at least. Another thing I hear people are using is SuperDuper. Look into those. And if you have a chance, TEST YOUR BACKUPS before you put your trust in them. I often boot off from my backup drives to see if they are all good, then I can trust them, when I know they are working.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.