1 22 23 24 25 26 Previous Next 386 Replies Latest reply: Mar 25, 2014 7:24 PM by Saraiva81 Go to original post
  • 360. Re: 27" Cinema Display Sound Issues
    urandom Level 1 Level 1 (0 points)
    Actually the fix is just a dirty fix for me.

    I am on a 2010 MacPro and have Audio Output via DisplayLink enabled.
    Now, I still can reproduce the problem as before but I can fix it without powercycle the display.

    Can somebody with a similar setup (DisplayLink audio) try to reproduce the following?

    Mute the volume
    Put the display to sleep (ctrl-shift-eject)
    Wake the display with space bar
    Volume Up / Down does not bring back sound
    Mute and Un-mute brings back sound

    Thanks
  • 361. Re: 27" Cinema Display Sound Issues
    Smudge Level 1 Level 1 (115 points)
    Yes that reproduces the audio muting problem. I'm using a MacBook Pro 15 and not a MacPro as you are but the problem is still the same.
  • 362. Re: 27" Cinema Display Sound Issues
    urandom Level 1 Level 1 (0 points)
    Smudge, thanks for trying. Now it would be interesting if somebody with displaylink audio cannot reproduce it. This would hint at a hardware defect in the first lot of displays...
  • 363. Re: 27" Cinema Display Sound Issues
    MacFreak1981 Level 1 Level 1 (0 points)
    Mac Mini 2010 with the 27" display, same problem here.
  • 364. Re: 27" Cinema Display Sound Issues
    Jonas Calhoun Level 1 Level 1 (0 points)
    I've tried several times to convince AppleCare that this is still an issue...they keep telling me to trade it in at the local Apple store. I'm on my 3rd on already.

    So where do we go from here? Obviously this issue hasn't been fixed for everyone (in fact, I'd like to know exactly who it is working for!).

    I've got a C2D 15" MBP...is it just never going to work with this circa '09 machine?
  • 365. Re: 27" Cinema Display Sound Issues
    Mr. Luigi Level 1 Level 1 (5 points)

    Hi All,  I apologize.  I have not read all the posts to this forum.  It's HUGE!   But, what I have read leads me to believe that Apple has not provided a permanent fix for losing sound on the Cinema Display.  I too have lost sound.  I went through the Resetting of the SMC procedure and that did NOT work.  I did notice that one fellow poster said that he disconnected the power cord of the Cinema Display and that worked for him.  Since this same trick (soft reboot?) works for my cell phone, cable modem, etc. I gave it a try.

     

    • Disconnected the power cord supplying the Cinema Display while the Cinema Display was on.

     

    • Waited a minute (for good measure).

     

    • Reconnected the Power Cord.

     

    • Sound preferences had defaulted back to "Internal Speakers" so I changed it back to "Display Audio" USB.

     

    • The sound on my Cinema Display now works again!

     

    The initial post to this forum was many, many, many months ago.  What is Apple waiting for?  This is not a cheap piece of equipment and a permanent fix from Apple is due.

     

    Am I missing something?

  • 366. Re: 27" Cinema Display Sound Issues
    Mr. Luigi Level 1 Level 1 (5 points)

    I read in a post that we should do a firmware update to address the loss of sound issue.  The person who posted this said to go to the utilities folder and look for "LED Cinema Display Firmware Update."  No go for me.  That file was not there.  I have a 15 inch MacBook Pro running v 10.6.7  with 2.53 GHz Intel Core 2 Duo.  Is it normal to not have this Firmware Update File listed in Utilities?  Anyway, so I downloaded the Firmware update 1.1 as that is all I could find on the Apple download site.  As soon as I did that a window popped up and said there was ANOTHER FIRMWARE UPDATE!  So, I updated again.  Now it appears I have Firmware version v1.417 for the 27 inch Cinema Display.  Is that the REAL latest firmware version for this unit?  The Apple download site mentions NOTHING about v1.417, just v1.1. Oh, and BTW, now when I go to my Utilities Folder the Firmware Update File DOES appear!  What!?  Can anyone let me know if this v1.417 is the latest firmware version and explain why the Firmware Update File was not present initially but is now?  Thank You.

  • 367. Re: 27" Cinema Display Sound Issues
    Eric Arnoldy Level 1 Level 1 (5 points)

    I'm still having this issue.  I have the latest firmware on my MacPro.  I think there is something wrong with the USB bus on this stuff.  I have very crackley speakers, that just get progressivly worse over time.

     

    Just today a Skype conversation was totally garbled.  Afterward I tried some music, and nothing.  My quack for vol up/down wouldn't even make a noise.

     

    This has got to be a Software thing apple, get it together, this is a real problem, and wasn't fixed with your update.

     

    Eric

  • 368. Re: 27" Cinema Display Sound Issues
    GaiusH Level 1 Level 1 (0 points)

    I am also having this issue, if there is a patch I need it backported to 10.5.8 please Apple...

  • 369. Re: 27" Cinema Display Sound Issues
    Andrew Stack Level 1 Level 1 (0 points)

    I just got his with this also.  If I switch audio to the internal speakers, it's fine.  If I switch to sound over USB to the display audio, I don't get proper sound but a strange repetitive coughing sound like the audio is not being sampled properly.  Unplugging the monitor, or sending it to sleep and waking it up and trying to play again seems to fix it, at least temporarily.  I have all the necessary firmware updates, etc. and I've had the monitors for almost a year and this is the first time I've had this problem.  Here's hoping 10.6.8 fixes this.

  • 370. Re: 27" Cinema Display Sound Issues
    ratchetcat Level 1 Level 1 (0 points)

    I'm also encountering this issue under OS X 10.6.8. The fly in the otherwise brilliant soup. Unplugging from power doesn't seem to help. Going to sift through this thread and try some things out, I guess.

  • 371. Re: 27" Cinema Display Sound Issues
    Andrew Stack Level 1 Level 1 (0 points)

    I'm the commenter two comments up -- I rebooted my machine and this seemed to have fixed the issue for me (for now).  Unplugging it, or sending the monitor to sleep would fix the problem for a minute or two but the sound would always fail again so that didn't up being a solution for me.  Not looking forward to 10.6.8 if this problem presents itself again.

  • 372. Re: 27" Cinema Display Sound Issues
    dwkenner Level 1 Level 1 (0 points)

    I can confirm I am having the same problem.

     

    I have a Mac Pro and a  Mac Mini on my desk. They both have their own Cinema Display. Intermittent audio to the Cinema display that is hooked up to the mini,  but audio is fine to the internal mini speakers.  Tried powering down the cinema display for awhile and this did not fix anything.

     

    Let me know if there was a fix that anyone is aware of.

     

    D. Kenner

  • 373. Re: 27" Cinema Display Sound Issues
    Mark Newton2 Level 1 Level 1 (5 points)

    See Apple Support knowledge base article TS3602 for a resolution....

    http://support.apple.com/kb/TS3602

  • 374. Re: 27" Cinema Display Sound Issues
    Mark Newton2 Level 1 Level 1 (5 points)

    My problem was lack of microphone sound. It's important to ensure you have System Preferences configured to accept input from the display's microphone:

     

    1. Open System Preferences, Sound.

    2. Select the Input tab.

    3. Set the option "Select a device for sound input:" to "Display Audio (Type = USB)".

    4. Speak to test volume settings.

     

    You should now have microphone sound.