Skip navigation

XServe and 3rd Party Seagate drives

1755 Views 9 Replies Latest reply: Jul 15, 2013 8:28 PM by Michael Campbell4 RSS
gazo Level 1 Level 1 (25 points)
Currently Being Moderated
May 11, 2011 1:32 AM

I have an XServe Intel 2 x 2.66Ghz Dual-Core Xeon server. It has 10.6.3 Server OS. I have used Seagate HD's in the unit for the last 4 years with no problems.


One of the HD's in the Mirrored Data RAID failed. When I purchased a new Seagate drive on inserted it in the XServe, the XServe did not recognise the drive in Dusk Utility, and the light on the drive bay was amber. I tried restarting the XServe, the lights would all go green on the drive bays, but then would not boot into the OS. Even when I boot up into the Server OS disc, and then go into Disk Utility it cannot see the drive.


I have tested all the drive bay modules and they are all working fine. It as if the new Seagate drive is not recognised by the XServe. What could have possibly changed. Is it a ADM firmware issue? Is there anyway to change this?


I know the right answer is probably to buy an Apple Server drive, but they are just so pricey here in South Africa. The Seagate drives I am buying here are equivalent to $100, where as the Apple drives from the Apple supplier are about $600.

G5 DP 2.0GHz, 1.5GB RAM/ Macbook Pro 13-inch 2.23Ghz, 2GB RAM, Mac OS X (10.5.7), Logic Studio, PT LE 7.4
  • ClassicII Level 3 Level 3 (830 points)
    Currently Being Moderated
    May 11, 2011 6:32 AM (in response to gazo)

    Are the seagates that are in the machine now apple units?  Did you get this current seagate new or used?

  • Tod Kuykendall Level 4 Level 4 (2,270 points)
    Currently Being Moderated
    May 11, 2011 7:22 AM (in response to gazo)

    If you search you will find several threads with people discussing the incompatibility of Intel Xserves with 3rd party drives. The G5s seem okay with certain models but the Intel based ones are not. Some people report that drives will eventually mount after a delay if left in the machines but this makes them unreliable and unbootable.


    My guess is that Apple flashes the firmware to extend the drive functionality and while earlier Xserves would operate without this the newer machines demand the extended functionality to mount and operate.


    You can search the threads here and the web but the consensus seems to be you need Apple drives for reliable operation.



  • Tod Kuykendall Level 4 Level 4 (2,270 points)
    Currently Being Moderated
    May 11, 2011 2:24 PM (in response to gazo)

    There is nothing I'm aware of in Disk Utility that will change a drive to make an Xserve recognize it. Assuming I'm right about Apple flashing the firmware of the drives they do that to the disks before they ship them to extend their functionality.


    The reports I saw for the non-Apple disks always seemed to correlate to Intel boxes only but I'm sure the majority of those people were running 10.5/6 so it probably is a combination of those two things. (I know that 10.5 on the G5 Xserves are way less picky about drives than the Intels.) Short of moving to Apple supplied disks I don't know of anything that will help you. Hopefully someone else has a better suggestion but I haven't heard of one.


    Good luck,


  • ClassicII Level 3 Level 3 (830 points)
    Currently Being Moderated
    May 11, 2011 6:28 PM (in response to Tod Kuykendall)

    I agree with Tod, sadly its apple drives that are a sure thing.


    The only other thing you could try is setting the jumper on that new seagate to 1.5mbps or sata1


    This downgrades the speed but some peope have reported that this works for them.




    Also what sled are you using? Is it the one with the black sata cables or is it the one where both cables are together and has an orange ribbon connector?

  • dkmi Level 1 Level 1 (15 points)
    Currently Being Moderated
    May 27, 2011 12:44 AM (in response to gazo)

    The problem is not in the HDD I think... it is with the RAID card.

    Try to run any AHT on this Server.

  • Kjell Magnus Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 6, 2013 6:33 AM (in response to gazo)

    I know that this is pretty old, but since I spent some time figuring this out myself I share. It is the speed that is the problem, and the drive has to be limited to Sata 150. Here is the page I found:



    This was good for drives I just recently bought.


    The hardest thing you might run into is getting the jumpers. I was just about to get out the soldering iron, before I remembered my pile of old stuff that I haven't gotten rid of. The old jumpers might be a little big, but they do work.

  • Michael Campbell4 Level 1 Level 1 (115 points)
    Currently Being Moderated
    Jul 15, 2013 8:28 PM (in response to gazo)

    You may want to try and fromat the drive exactly the same size as the old apple ones.

    Check this site as he states :

    The new non-Apple drive MUST have at LEAST as much storage capacity as the Apple drive you are replacing. I know - this sounds obvious at first, but it is NOT. For example, if you are replacing an Apple 500GB drive with a Western Digital 500GB, the ACTUAL formatted capacity of the WD drive MUST BE EQUAL TO OR MORE than the Apple drive. I have had instances where the new non-Apple drive formatted at a capacity that was only a few k less than the Apple drive and it would NOT work. Not all 500GB drives format at the exact same capacity. For example, my Apple 500GB had a formatted capacity of 465.76GB but the WD only had something like 465.72GB - this small difference was enough to cause the XServe RAID to reject the WD drive as a replacement in the existing RAID Array.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.