4 Replies Latest reply: Jul 1, 2011 11:02 AM by audiofeen
johnniefromedmonton Level 1 Level 1 (0 points)

when i connect my iphone 3GS and or ipad i get the message there is an update available to 4.3.3 When I try to update my iphone or ipad I get the error message "this device is not eligible for the requested built" what is this about and why can't i update ?


iPhone 3GS
  • 1. Re: unable to update to ios 4.3.3
    deggie Level 8 Level 8 (46,535 points)

    If you are using a Mac computer, try this solution from user wingv that I found in another thread:

     

    Type sudo su

    Press enter

    Then enter your password and hit enter

    Type vi /etc/hosts

    Move your cursor with the down arrow to the line that has gs.apple.com without a # at the beginning of the line.

    Move cursor to the beginning of that line.

    Type i# then press the esc key.

    Type :wq

    Press enter

    Type exit

    Press enter

    Now you can quit out of the terminal application. This likely is a problem caused by Tiny Umbrella denying itunes communicating with the apple servers.

  • 2. Re: unable to update to ios 4.3.3
    johnniefromedmonton Level 1 Level 1 (0 points)

    Thanks for your help, did as you suggested and now working great, I was able to update both my iPhone and iPad without any issue

  • 3. Re: unable to update to ios 4.3.3
    audiofeen Level 1 Level 1 (20 points)

    i had a problem with terminal so instead i just ran tiny umbrella while i updated my iphone

  • 4. Re: unable to update to ios 4.3.3
    audiofeen Level 1 Level 1 (20 points)

    i have a problem running this after this point..

     

    Type i# then press the esc key.

     

    got that done

     

    #127.0.0.1 gs.apple.com

    #74.208.10.249 gs.apple.com

     

    but where do i type: wq ?

     

    it just keps giving me the error sound so i canot complete the process.