Skip navigation

can't find my posts (buglet)

1023 Views 27 Replies Latest reply: May 16, 2011 8:58 PM by hotwheels 22 RSS
1 2 Previous Next
hotwheels 22 Level 1 Level 1 (0 points)
Currently Being Moderated
May 15, 2011 3:03 PM

i get a "not found: the item does not exist. it may have been deleted" when I click on discussions in order to view all my posts so i can follow up on them.

 

can anyone help?

 

thanks

 

Screen shot 2011-05-15 at 5.00.40 PM.png

  • Ronda Wilson Level 8 Level 8 (40,555 points)
    Currently Being Moderated
    May 15, 2011 3:44 PM (in response to hotwheels 22)

    Are you using an old bookmark to try to get to your posts?

     

    Try clicking on "Your Stuff" above the search box on this page. Choose "Discussions" from the drop-down menu, and it should take you there.

  • Tuttle Level 7 Level 7 (28,960 points)
    Currently Being Moderated
    May 15, 2011 7:17 PM (in response to hotwheels 22)

    Still curious what happens when you click this link.

     

    This is what I see:

     

     

    Screen shot 2011-05-15 at Sunday May 15, 10.10.20 PM.png

     

     

    If you don't see that page, then you should log out of ASC, delete all of your Apple cookies, log back in and try the Discussions link again.

     

     

    - ..- - - .-.. .
  • Ronda Wilson Level 8 Level 8 (40,555 points)
    Currently Being Moderated
    May 15, 2011 8:19 PM (in response to Tuttle)

    For what it's worth, when I click on your link, I get the same result as hotwheels #22.

     

    However, I can get to the OP's Discussions by clicking on his profile, his Your Stuff tab, and then Discussions in the right sidebar.

     

    This is the link that I get when doing that:

     

    https://discussions.apple.com/people/hotwheels%20%2322?view=discussions

     

    This is the link I get when clicking on your link, Tuttle:

     

    https://discussions.apple.com/people/hotwheels%20#22?view=discussions

  • Don Archibald Level 10 Level 10 (101,125 points)
    Currently Being Moderated
    May 15, 2011 9:44 PM (in response to Ronda Wilson)

    I think the "#" in the alias hotwheels #22 may be causing the problem. It's sometimes an element-part of the site's URL structures, and so may not get translated to the "%23" form needed for that 'special' character (I assume that's the case, since "%20" is used for a space).

  • Tuttle Level 7 Level 7 (28,960 points)
    Currently Being Moderated
    May 15, 2011 9:48 PM (in response to Ronda Wilson)

    No idea how that happened. I was obviously on the page (see screenshot), and I tested the copied link several times in my post.

  • b noir Level 9 Level 9 (71,990 points)
    Currently Being Moderated
    May 15, 2011 10:51 PM (in response to Don Archibald)
    and so may not get translated to the "%23" form needed for that 'special' character (I assume that's the case, since "%20" is used for a space).

     

    Yeah, that looks spot-on, Don. "%23" is the percent encoding for "#":

     

    http://en.wikipedia.org/wiki/Percent-encoding#Percent-encoding_in_a_URI

  • b noir Level 9 Level 9 (71,990 points)
    Currently Being Moderated
    May 15, 2011 11:09 PM (in response to Tuttle)
    I was obviously on the page (see screenshot), and I tested the copied link several times in my post.

     

    Yeah, it looks to be a nasty wee trap. I just tried some testing of the https://discussions.apple.com/people/hotwheels%20%2322?view=discussions url.

     

    If you insert that url into text in a post, prior to posting (while still composing), the link is fine and would take you to the correct page. The second that you actually click "Add reply" the url for the link-inserted in text is converted to https://discussions.apple.com/people/hotwheels%20#22?view=discussions and everything turns to custard.

     

    It doesn't happen to a "naked" copy of the url in a post. It only happens to copies inserted into text, and it only happens after you press "Add reply". So it's not something you could have seen coming, no matter how much testing you did while still composing the reply.

  • Ronda Wilson Level 8 Level 8 (40,555 points)
    Currently Being Moderated
    May 16, 2011 1:35 AM (in response to b noir)

    I thought it might be something like that, which is why I posted the raw links so I could see that they came out as intended.

     

    It's hard to count on anything with this software. I'll never trust another image directly uploaded from my hard drive after one went missing after a couple of days.

  • Tuttle Level 7 Level 7 (28,960 points)
    Currently Being Moderated
    May 16, 2011 6:29 AM (in response to b noir)

    Thanks for doing that legwork, b!

     

    To the point of, hotwheels #22's OP though, he says that he is unable to reach the Discussions page through direct links, as well, as described in an earlier topic in another community (to incorporate the rubric!), where a "naked" copy of the link was used.

     

    Not sure that has anything to do with the ascii in the link because we've all been able to reach that page, so I'm back to suggesting a complete Apple cookie toss to Jon...

    - ..- - - .-.. .
  • Tuttle Level 7 Level 7 (28,960 points)
    Currently Being Moderated
    May 16, 2011 6:35 AM (in response to hotwheels 22)

    Hi, Jon - Have you tried trashing all of your Apple cookies yet?

     

    Sign out, quit your browser, trash the cookies, log back in.

     

    (Also, no one seems to have asked you whether you're having the same experience in multiple browsers...)

  • Ronda Wilson Level 8 Level 8 (40,555 points)
    Currently Being Moderated
    May 16, 2011 6:56 AM (in response to hotwheels 22)

    They're getting even with you now, Jon.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.