4 Replies Latest reply: May 24, 2011 2:34 AM by VincensoXFIN
VincensoXFIN Level 1 (40 points)



I have made a new and fresh installation of the OSX server 10.6 to a Mac Pro, due the extreme problems what our broken Raid Card caused us. I managed to install it okay, everything is working like before, except group folders.


I have proper AFP shares made for group folder and the mount shows fine. In the old stystem, I could go to group preferences on WGM, and on the Login / Items, select manage always just add the checkbox to "Add group share point", and the folder would display on the desktop for members of that group. Now it is not working. I actually booted from one backup of the last system and made sure that I have same settings than before.


What could be a problem here?

Mac Pro, Mac OS X (10.6.7), Server
  • gracoat Level 3 (660 points)

    A work around.

    On a client work station:

    In finder, manually mount the share you would like to have show up.  You may need to authenticate.  This is fine.  Do so with any users name on your system that has access to said share.


    Open WGM.  (still on the client work station) You'll likely need to install Server Tools temporarily.

    Select the group or user you would like the MCX to apply to.


    Click Preferences.

    Click the items tab.

    Click Always.

    Click the plus button on the right side.

    Select the mounted share.

    Click Okay

    Select the newly added line item.  It'll probably look like this: afp://server.example.com_.  With a kind: URL

    Put a check box in the "Authenticate selected share point with Users login name and password."

    Click save!

    That should do it.

  • VincensoXFIN Level 1 (40 points)

    Thank you for your reply. I tried that and it did not work.


    When I pressed command + K and connected to afp://myserver it showed the shares alright, but the shared folder that I wanted to mount was grayed out. Rest of the folders displayed normally. And when I went to finder and browsed into server that I logged in to, I was able to get in to the shared folder without problems. But it is pretty important that I could get it to show in desktop as well, or else our institutes teachers wont find it ..


    This is really strange because I am pretty confident that the installation of the server and configuring it again went better than I expected. And the users can log in and out without problems, and actually can access the shares, but it just wont mount to desktop...

  • gracoat Level 3 (660 points)

    If the share is greyed out, then you're already connected to it.  ...so it worked....

    If you don't see it on your desktop, then the client settings are to hide it as a desktop item.

    Unhide it like so...

    First of all, make sure that there are no Finder MCX prefs set for the user you're logged in as.

    Go to the Finder menu at the top left hand corner of your screen and click "Finder"

    Click Preferences.

    Click a checkbox beside the "Connected servers" item.

    Close the window.


    That'll probably do it.


    Alternatively you could just add the group folder into the dock....

  • VincensoXFIN Level 1 (40 points)

    I love you man. I love you.


    That was it, had to go to finder prefs and checkbox the connected servers. I have no idea why that was off, since last time I did a clean install (december) I didn't have to edit any Finder prefs. But i'm glad that this is now cleared. Thank you very much for your assistance! That was the only problem I'm having with the new system, so now its aaaaallll good again!


    Thank you!