Skip navigation

POSIX reports: The operation couldn’t be completed. Cannot allocate memory

47533 Views 31 Replies Latest reply: Apr 12, 2014 7:42 PM by sheilafrombelmont RSS
1 2 3 Previous Next
HJATKINS Calculating status...
Currently Being Moderated
Mar 8, 2011 3:46 AM
Hi, I've got a HP SimpleSave 2Tb external hard drive that I'm trying to fix for a friend, they said it stopped working so I plugged it in to my iMac and Finder told me I needed to initialize the disk because there were no volumes on it, so I tried everything in Disk Utility, Partitioning, erasing, restoring, all the tricks and nothing worked. Every time I got the same error : "Disk Erase failed with the error: POSIX reports: The operation couldn’t be completed. Cannot allocate memory"
I tried some diskutil and fdisk commands in Terminal and still nothing works.
I was wondering if there's ANYTHING I can do to try and get it back? I don't even need to get the files back just the hard drive itself. Please help if you know anything.

Thanks in advance
iMac 20", Mac OS X (10.6.6)
  • KJK555 Calculating status...
    Probably the partition table is corrupt. When it does this, it becomes difficult to
    unmount (actually it gets stuck in a loop trying to mount the file system, to no avail
    because the file system is corrupt).

    This procedure forces a dismount, but does not eject the drive.
    This breaks the loop and allows erasing the partition table:


    note: I wrote these instructions were for a boot volume
    with that condition (booting from the install DVD), so the
    disk numbers are not going to be accurate.

    at the prompt:
    diskutil list
    (press enter)
    that will give you the device name of your drive.
    It most likely will be "disk0".

    next command:
    diskutil unmount force /dev/<disk_name>
    diskutil unmount force /dev/disk0

    next command:
    diskutil zeroDisk /dev/<disk_name>
    diskutil zeroDisk /dev/disk0
    (press return)

    After disk is zeroed, you may resume normal partitioning.

    Bear in mind, since this is an external disk, the USB/ translation layer
    may interfere with accessing the disk directly and foul up the procedure.

    Looking at the drive specs, it says it only supports use under windows,
    whatever that means. Perhaps it requires a proprietary USB driver or something.
    Some folks claim it works on a Mac though.

    The USB interface (inside the unit) might be hosed.
    Sales poop says it has a two year warranty. If still in warranty, send it back.

    Mac Pro, Mac OS X (10.6.6), nuke the app store,  "What!?, you didn't back it up?" 
  • KJK555 Calculating status...
    If not under warranty, remove the drive from their box and install it into a generic box.

    Cheap generic boxes are fine, but choose a metal one instead of plastic to dissipate the heat.

    Mac Pro, Mac OS X (10.6.6), nuke the app store,  "What!?, you didn't back it up?" 
  • KJK555 Calculating status...
    Here is what one enterprising individual recommends:
    HP Simplesave 500gb Disable "Virtual CD" SOLVED ! [ Edited ]
    09-18-2010 04:39 PM - last edited on 09-18-2010 04:41 PM

    The Virtual CD is a pain when you are using it on a lot of different Machines.
    I had the same problem with the WD 500gig Passport Drive,
    and found that allows "YOU" to choose
    whether "YOU" want the Virtual CD or not, unlike HP.
    The WD500 Passport Drive uses a USB only internal Hard Drive with no SATA or IDE connection.
    The HP SimpleSave uses a SATA internal Hard Drive.
    So here is how to solve the PROBLEM
    1. save all the data on the SimpleSave, MAKE SURE YOU DO THIS !
    2. pull it apart gently with your fingernails and remove the SATA drive.
    3. buy a cheap Generic SATA to USB enclosure.
    4. right click on "My Computer" select "Manage" > "Disk Management" and make new partition(s)
    and format.
    or on Mac "Disk Utility"
    5. copy all the data back on it.
    6. take the leftover remains of the SimpleSave outside on the concrete (Wearing Eye Protection)
    then proceed to smash it with a rather large hammer into very small pieces.
    (you will feel a lot better after the **** it has put you through)

    Now that is "SIMPLE"
    # 2-0/m-p/305812
    Mac Pro, Mac OS X (10.6.6), nuke the app store,  "What!?, you didn't back it up?" 
  • sdstrobe Calculating status...
    I have a similar problem, only my issue pertains to my internal drive.
    I have been searching for a solution for about 5 hours and have tried just about everything, but have not found a concrete solution. I have attempted both the prescribed solutions in this topic as well as at least a dozen others, and I have seen a lot of promise but not like I previously reported, not very many results.

    Not to spawn a new thread inside of this one, but let me describe my situation.

    I opened my MBP to wake it from sleep mode when I woke up this morning, and it pinwheeled at my password authentication screen. After waiting 10 minutes for this to subside, I closed my laptop, waited 5 minutes, and tried to wake it up again. This time, after 5 minutes my computer allowed me to authenticate my password, and I was capable of opening disk utility and immediately repaired disk permissions on my hard disk (I have been having to do that when I turn my computer on in order to prevent it from locking up almost since i received the product).

    Anyway, my computer locked up again after the permissions repair completed, and I needed to do a hard shut down. After the hard shut down I was unable to boot into neither OS X nor Windows.

    This being suspicious, I grabbed my Snow Leopard install disk and booted with that. I opened Disk utility and was unable to repair my Macintosh HD.

    After that, I followed the instructions that Disk Utility gave me and attempted to erase and reformat my Macintosh HD drive, but received the error,

    "Posix reports: the operation couldn't be completed. Cannot allocate memory."

    So, in response to that, My attitude was, "I have everything backed up, ill just erase the whole drive and restore, or reinstall everything" So, I attempted to repartition the disk so it would have only one partition. I was given the error,

    "Posix reports: the operation couldn't be completed. Cannot allocate memory."

    After this happened, I decided to attempt to erase the whole volume, and was shown the error

    "Posix reports: the operation couldn't be completed. Cannot allocate memory."

    After THAT happened, I used terminal to zero the drive, but have been unable to repartition or create a partition map for the drive because I keep getting the error,

    "Posix reports: the operation couldn't be completed. Cannot allocate memory."

    In terminal the error is not Posix, but still reports that it "Cannot allocate memory" after 60% of the way through formatting.

    I cannot figure out my problem. I am half way considering buying a new drive..

    Does anyone have any solutions??
    acBook Pro (15-inch, Mid 2009) and (15-inch, 2.53 GHz, Mid 2009), Mac OS X (10.6.6), Dual boot, Windows 7 and OX with bootcamp
  • CitizenX Level 1 Level 1 (15 points)

    I receive the same error and a 500GB WD drive in and external enclosure.


    "Disk Erase failed with the error: POSIX reports: The operation couldn’t be completed. Cannot allocate memory"


    The only way I can get around it is to format it in Windows, then reformat it on my MacMini with 10.6.7.


    I have no problem formatting other drives.

  • Silly rabbit Level 4 Level 4 (2,980 points)

    Yep! This is a glitch in the disc utility of Snow Leopard, which has so far been ignored by Apple. I too had the same issues trying to format a 200GB WD drive from a Firewire enclosure, which I pulled out of a broken HDD/DVD TV recorder. A Google search confirmed my opinion by showing hundreds of other 10.6 users with the same issues. Luckily, I have a few firewire drives and was able to get around the issue. What I did was, installed Tiger onto one of my empty drives, booted from it and used the disc utility in Tiger to format the disc, worked like a charm.



    One of the reasons I gave up on Leopard was cos of issues with the disc utility, now it seems Snow Leopard also has the disc utility disease. C'mon Apple! Get your crap together! This is terrible!

  • abhishekmickey Calculating status...



    I recently faced the same issue with WD 500 gb, searched all but not able to resolve this & i recently bought 1Tb WD again and it has stopped showing in windows i am scared to format it on mac now , will keep researching for a solutionn though  till apple comes up  with the bug fix in disk utilty


  • essbeep Calculating status...

    I just had THREE external disks disappear and go bad on me this week! just backed up to one last night, then it wouldn't mount this mornkng. Earlier in the week a LaCie D2 Quadra disappeared and won't mount, tried disk util, pc, and another mac as well as the terminal route of formatting - get the POSIX error, or cannot allocate memory and it won't initialize.


    I am screwed. THREE externals gone - 15 years of work vanished in one week.


    I bought a new 1 TB drive WD tonight to install tomorrow to get some back up in place, but looks like i cannot count of this for an length of time!


    Running SL 10.6.7 which I updated with the lasted combo package.


    As of tonight, NONE of the 3 existing hard drives that worked on Monday are able to mount on mac or PC.

  • devingabriel Calculating status...

    "MacBook-Pro:~ devingabriel$ diskutil eraseDisk JHFS+ macintoshhd disk2

    Started erase on disk2

    Unmounting disk

    Error: 12: POSIX reports: Cannot allocate memory"


    I tried your advice and ended up with the same result. This is happening while trying to format a replacement 500GB drive that is OSX compatible, that I just purchased today. It's a replacement because the OS had locked up and I powered down. Upon reboot it would simply 'spin the wheel.' I was unable to format the drive - I can't remember the specific error, but it was different and occurred well into the format process.


    Pulled the original drive, popped in an external case, and was able to erase/format it on PC. Tried formatting it back in my MacBook Pro and ... same problem, same error. Figured I'd try a new drive.


    That brings me back to where I am now - with a new hard drive that I still cannot use. Any suggestions?

  • devingabriel Level 1 Level 1 (0 points)

    Do you know of any other hard drive formatting software I can use other than Disk Utility / diskutil in Terminal? I'm going nuts - it's my internal hard drive on my MacBook Pro.

  • hinchesk Calculating status...

    Here's a very straightforward solution from a trusted source. It's basically a one command solution, i.e. "diskutil eraseVolume HFS+ BACKUP disk2" (where BACKUP is the new volume label of your choice, and disk2 is the disk identifier of the drive you want to erase so make sure you get it right).


  • devingabriel Level 1 Level 1 (0 points)



    Turns out the error was due to a faulty cable that connects the hard drive to the motherboard. $50-60 later, I was good to go. After wiping my hard drive. Bummer. I guess they go bad relatively frequently considering how quickly the guy diagnosed it @ the Genius Bar.

  • Grafikco Calculating status...

    Hi all, I have found a workaround for this problem and it works, you do not need to bin your drive. Although the data on the disk has been totally erased (have a mirrored drive set up, so all ok)  I have a old mac G3 bronze keyboard laptop ( lombard I think) has OS 9.3 I reformatted my 1TB Maxtor using this "it mounted pronto" Then I moved to my Macbook Pro and the drive mounted no problems, I did re-format the drive again in disk utility just to be safe (no POSIX errors), and she is fine. I appreciate not all of you have OS9.3 on old laptops but it does work, hope it helps.

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.