Skip navigation

Issues with SUS

2808 Views 11 Replies Latest reply: May 29, 2011 12:20 AM by michael_k RSS
yasmin.k Calculating status...
Currently Being Moderated
Jan 17, 2011 4:33 AM

we have in the company about 25 Macs which are integrated in the ADS via the Centrify plugin.
So far so good.
Beside this we have an MacMini Server which should be used for SUS, Packages, NetInstall (later).

My issue is for now with the SUS.
It's configured correctly, the packages are being downloaded and synced with Apple, the Group Policy in Centrify is set up correctly so the clients are able to see the server via port 8088 and indeed they are looking for the software on the server.
But here's the issue: each client is saying "Your software is up to date", but in the background I can see that there is something (the window with the software list appears in the background).

I suppose this is related to the SUS and not to the Centrify software.

Can someone help, please?

iMac 2.4; PowerMac G4 Quicksilver 2001, Mac OS X (10.6.6)
  • VincensoXFIN Calculating status...
    Currently Being Moderated
    Jan 17, 2011 4:52 AM (in response to yasmin.k)
    Im not sure how did you configure clients to use your mac mini to download updates, but thats not the way I did it.

    When I first built up my Software Update service, I had to configure each mac to use my own update server via terminal on the client, using this command


    sudo defaults write /Library/Preferences/ CatalogURL ed-1.sucatalog

    You should try that with one client machine, if you are running Snow Leopard. I think the command with leopard was very similar, but can't recall what part was different.

    Hope this helps.
    iMac 27"
  • MrHoffman Level 6 Level 6 (11,720 points)
    Currently Being Moderated
    Jan 17, 2011 8:01 AM (in response to yasmin.k)
    That reported ghosted software update display is, um, quite abnormal.

    Remove the Centrify plug-in from one client, and see SUS starts working.
  • Terry Fundak Level 2 Level 2 (150 points)
    Currently Being Moderated
    Jan 26, 2011 8:31 AM (in response to yasmin.k)
    I had a client where I had something like this....

    It turned out that my SUS URL had a single / after the http:/

    not the correct

    Check your client configuration string carefully.

    On my the software updates download but the Software Update process just stopped when it was time to do the install..... i.e it appeared to hang.... ghost with no complaint at all..... I ended up thinking my client OS was corrupt but a reinstall and restore of User data resulted in the same issue...... All because of a "/" being missing....

    Maybe this will help someone.....
    Mac Pro 2.88GHz/14GB, 2 X G5-2GHz, and others, Mac OS X (10.6.6), Servers and Clients
  • HackerJL Calculating status...
    Currently Being Moderated
    Mar 10, 2011 10:17 AM (in response to yasmin.k)
    Confirmed this happening with me as well! PAIN!
    Mac Pro, Mac OS X (10.6.3)
  • michael_k Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 28, 2011 3:12 AM (in response to HackerJL)

    Add me to the list! Having same Issue...and no solution... :-(

  • HackerJL Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 27, 2011 12:24 PM (in response to michael_k)

    Michael, no movement on this?

  • Leif Carlsson Level 5 Level 5 (4,950 points)
    Currently Being Moderated
    May 29, 2011 12:11 AM (in response to HackerJL)

    Try looking at the URLs that the SUS provide for the update files.


    If you go to the server: http://<yourserver>:8088/catalogs.sucatalog


    Look at / use one of the "links" on the page to try to find the SUS from a SUS client


    The names should match or at least the URLs for each update file must point to the SUS server.


    The SUS might have been setup / configured using a different server name or maybe DNS is lacking the correct information.

  • michael_k Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2011 12:20 AM (in response to michael_k)

    Actually I got it working but only with all Updates and autocopy enabled. It tooks 6 hours till everything was green(everything was! downloaded before). Now the updates runs much faster and save bandwith, but I’m still not able to provide only selected Updates, which, I guess, would make sense not only in my environment.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.