Skip navigation

Can't save PDF "may not have permissions or file is in use"

6047 Views 30 Replies Latest reply: Jan 7, 2014 4:06 PM by julievs RSS
1 2 3 Previous Next
squidz Level 1 Level 1 (5 points)
Currently Being Moderated
Jun 2, 2011 5:08 PM

On my MBP, when I export a PDF from InDesign to save over the previous version, which I may have saved just moments before, I constantly get the error: Can't save to the file "filename." You may not have permission or the file is in use.


HOWEVER, I am the only user on the MBP. I just saved the freaking original file the first time. The file is NOT in use. The only way I can save the file with the same name again is to delete the original.


If I check Permissions via Get Info, it clearly shows that I have Read & Write perms. Everyone else show read only, which is still a bit restrictive.


How can I convince OSX to apply the proper perms when I save a file? Why is it preventing me from saving over my own file?

MacBookPro5,3 2.8 C2Duo, Mac OS X (10.6.2)
  • Linc Davis Level 10 Level 10 (107,825 points)

    Please launch the TextEdit application, type some text in the window, and then save the document to the same folder as the PDF (but not with the same name.) Does that work?

  • Linc Davis Level 10 Level 10 (107,825 points)

    That is simply saving the same source file over itself, which will work all day long.


    I'm not sure I understand this response. Does that mean you tried the test I suggested and it worked, or that you didn't try it?

  • Linc Davis Level 10 Level 10 (107,825 points)

    If the problem is as you describe it, then it's specific to InDesign. It's not a problem with the permissions of your home folder. Frankly I don't know how InDesign would even know what's selected in the Finder, much less why it would care. Maybe Adobe tech support could enlighten you.

  • marc55 Calculating status...

    Hi Squidz


    Did you ever find out a solution to this problem? I'm having the exact same issue (ID CS4 runnng in Lion). I've found that if I email the PDF to someone, I then can't export over it, I basically have to either delete the original PDF, or export the PDF using a different filename, even though the permissions before and after emailing it have remained the same. Frustrating...

  • BrendonWBrown Level 1 Level 1 (0 points)

    I may have an answer for you, squidz. My workflow is generally Create in InDesign > export PDF > email > receive feedback > tweak > export over last PDF > email. What I think is the culprit is Apple Mail keeping a preview of the file open long after it's been attached and sent.

  • marc55 Level 1 Level 1 (0 points)

    It beggars belief that Apple, with more cash reserves than many first world countries, can not be bothered to fix a seemingly simple bug in it's Mail programme. Just saying...

  • mtvessell Calculating status...

    Have had this exact same issue verbatim for months. It will not save over the original pdf file. It's ridiculous that Acrobat has to be completely closed with absolutely no open pdfs, or exporting my pdf from InDesign will not save over the existing pdf.

  • deejson Calculating status...

    Bump. Same problem here. OS X 10.8 (lion) with CS6.  If I close all open apps and relaunch this usually solves it but this really isn't any better of a solution than saving with a new name.  I used to have this problem on a PC and had hoped I'd be free of this once I moved to the Mac but alas Mac OS appears to think PDFs are in use long after they aren't

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.