Skip navigation

Delegate calendars won't sync with iPhone

100434 Views 63 Replies Latest reply: Nov 23, 2013 10:24 PM by Christian Tian RSS
  • Oki Level 2 Level 2 (210 points)
    Currently Being Moderated
    Aug 20, 2010 5:01 PM (in response to Oki)
    Oki wrote:
    I also used https://www.google.com/calendar/iphoneselect
    Perfect for what I know!


    What! It does not work anymore! Any explanation?
  • Fred Mckinnon Level 1 Level 1 (85 points)
    Currently Being Moderated
    Sep 28, 2010 8:43 AM (in response to mdr925)
    Hey,
    Thanks for this response - I tried this, and under "Shared Calendars", the shared calendar (Delegate) is there (it's a shared calendar from a co-worker), but you cannot select it ... I've tried to check that box until I wanna push my finger through the iPhone .. it won't select, and underneath says "not available for syncing"?
    Dual 1Ghz G4, Powerbook G4/550, Mac OS X (10.2.x)
  • starverte Calculating status...
    Currently Being Moderated
    Sep 28, 2010 4:21 PM (in response to ayo.Kayo)
    Actually, you can just go to https://www.google.com/calendar/iphoneselect and choose which calendars to sync.
    iMac, Mac OS X (10.6.4)
  • starverte Level 1 Level 1 (0 points)
    It must not be available because you don't have any permissions (not even a read-only permission). You are simply subscribing to the calendar.
    iMac, Mac OS X (10.6.4)
  • rmmr Calculating status...
    Currently Being Moderated
    Dec 4, 2010 9:46 AM (in response to Jeffason)
    I think what Jeffason is trying to say is this -- once you have your google account set up as an exchange account on your iPhone, you're only going to see your "main" calendar. To sync the other calendars (delegates) to your iPhone, just sign into m.google.com/sync on your iPhone in Safari.

    From there, you can actually select the device you want to sync with and add all of the missing delegate calendars. Quit iCal on the iPhone and re-open it. You'll find that all of your extra delegates sync'd over just fine.

    If only I could it to sync the proper colors... I've figured out everything else, just give me the right colors!
    iPhone 4, iOS 4
  • Kateweb Calculating status...
    Currently Being Moderated
    Dec 29, 2010 6:57 PM (in response to starverte)
    any ideas for when this dosent work? they are still not syncing for me even tho they are all checked ( they are working in iCal and have been for some time tho)
    3g, iOS 4
  • sparty11 Calculating status...
    Currently Being Moderated
    Feb 19, 2011 7:50 PM (in response to WebDevGuy)
    https://www.google.com/calendar/iphoneselect

    go here an pick the calendars you want to show and save and they will appear after you next sync

    Message was edited by: sparty11
    iPhone 4, iOS 4
  • justincase1 Calculating status...
    Currently Being Moderated
    Apr 4, 2011 2:24 AM (in response to Jeffason)
    Jeffason wrote:
    I think i found the issue.

    Go to m.google.com/sync and select the other calendars!


    Perfect ! works fine
    iPhone 3GS, iOS 4
  • Praveen Sharma Calculating status...
    Currently Being Moderated
    May 24, 2011 4:27 PM (in response to justincase1)

    So I tried this, and then I resynced - saw the google calendars for a second and then they dissapeared when i switched to over the air mobile me synching. Does this not work with over the air synching? I've tried everything and can't get the calendars to reappear!!! So frustrating since they DID work for a hot second :\

  • bobocoo Calculating status...
    Currently Being Moderated
    Jun 3, 2011 11:01 AM (in response to WebDevGuy)

    i used a way that is the simplest to me cause i can't figure out the way provide up here. as the calendar is created first with informant on my iphone, i checked back the source of problem and saw that i have created a lot of calendar outside my SHOULD BE Calender ( the one able to sync), so I just change my events back to my SHOULD BE Calender and created new tag inside that calender instead of creating a NEW Calendar. It immediately sync to all devices. after all i just need one calendar.

  • benseaward Calculating status...
    Currently Being Moderated
    Aug 17, 2011 8:33 AM (in response to bobocoo)

    Kayo's solution worked perfect for me! THANKS BRU!!!!!

     

     

     

     

    SOLUTION: Looks like iTunes won't recognize the delegates, so we are going to have to set up a new "account" for each delegate through iCal, not Google. Here are the steps:

     

    1.) Open iCal, go to Preferences, Accounts tab, click on the "+" sign at the bottom to add an account for a delegate calendar. (Basically, the same instructions when you added your Google calendar)
    2.) Type in your same Google username & password. (For description, this is where you probably want to type in the name of the delegate calender you are adding. Remember, we can only add one calendar at a time).
    3.) Click on the Server Options arrow and this is what you have to type in the box:

     

    https://www.google.com/calendar/dav/<CALENDER ID>/user

     

    4.) Now, you have to replace "<CALENDER ID>" with your delegate calendar's ID. How do we find this? Go to your Google calendar main page. On the left-hand side under "My Calendars", click on the down arrow next to the delegate calendar you wish to add and find "Calendar Settings"
    5.) Now that we are on the Calendar Settings page, scroll down where you will see
    (Calender ID: ___________) on the right and yes, it is in the parentheses. It should look like a bunch of jibberish followed by "@group.calendar.google.com" This is your calender ID.
    6.) You need to copy & paste this in to the URL that I put up above, starting with the first letter of the jibberish and ending at ".com"

     

    Now, you are ready to add this calendar, and it should show up in iCal as a "separate account" and in your iTunes!

     

    To avoid what looks like repeating events, make sure to uncheck your delegate calendars under the Delegation tab under your original default Google calendar.

     

    It's not a perfect solution, but it works for me. And sorry for the longgg post, but if you're anything like me, you need a step-by-step, idiot proof instructions lol.

     

    I hope it works for everyone! If you need any help, send me a message on my Twitter first before following so I won't deny you. Twitter.com/ayo_Kayo

  • scottkundla Calculating status...
    Currently Being Moderated
    Nov 22, 2011 11:06 AM (in response to anomoly)

    This worked for me! 

     

    Note that the <CALENDAR ID> is the full string, including the "@group.calendar.google.com" at the end.  Use this in the "Server" field when creating a new CalDAV account in iCal and you should be all set.

  • scottkundla Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2011 11:13 AM (in response to anomoly)

    The calendar doesn't appear as a "delegate" in iCal anymore, but as the home calendar under the new account.  Still, I can now sync it with my iPhone without creating a whole new Google Calendar, so this is a good fix for me.

  • mprse07 Calculating status...
    Currently Being Moderated
    Feb 15, 2012 11:56 AM (in response to anomoly)

    I completed all the steps and was able to get my calendars on iCal, but they are still not showing up on my ipod touch. Any thoughts on what I'm missing? Thanks

  • mprse07 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2012 11:59 AM (in response to mdr925)

    THANK YOU this is the solution I was looking for!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.