Skip navigation

Apple TV homesharing keeps dropping out ...

173234 Views 445 Replies Latest reply: Apr 5, 2014 10:18 PM by siamless RSS
1 2 3 ... 30 Previous Next
Jeet K Calculating status...
Currently Being Moderated
Apr 6, 2011 11:03 AM
The homesharing on my Apple TV keeps dropping off randomly.
I have a mac with wired ethernet access, and the Apple TV uses my wifi connection.
The setup was OK, and YouTube and NetFlix are fine, but the homesharing will drop off at random times (I see the message "activate homesharing on itunes" under the Computers menu option). My mac is set to never sleep, and itunes is running continuously, so I know that isn't the problem. Wifi signal strength is 80% in the Apple TV menu.
Can anyone help ?
Mac, Mac OS X (10.6.7)
  • Michaelworks Level 3 Level 3 (695 points)
    Currently Being Moderated
    Apr 6, 2011 12:34 PM (in response to Jeet K)
    Jeet K wrote:
    The homesharing on my Apple TV keeps dropping off randomly.
    I have a mac with wired ethernet access, and the Apple TV uses my wifi connection.
    The setup was OK, and YouTube and NetFlix are fine, but the homesharing will drop off at random times (I see the message "activate homesharing on itunes" under the Computers menu option). My mac is set to never sleep, and itunes is running continuously, so I know that isn't the problem. Wifi signal strength is 80% in the Apple TV menu.
    Can anyone help ?


    You can test and isolate the wireless connection by connecting wired and see if the ATV2 still does it. You might also look at your router logs for wireless and see if the ATV2 is dropping all the time or is experiencing errors. If your DHCP timings are short, that could be an issue also.
    MP 2.66 16GB ATI 5770 MBP i7 17" iMac iPhone 4 32 iPad 3G 64, Mac OS X (10.6.7), MBA 11.6" Ultimate Canon 5D & 5D MKII
  • charks Calculating status...
    Currently Being Moderated
    Apr 6, 2011 3:30 PM (in response to Jeet K)
    I'm having the exact same issue. APTV says I need to turn on Home Sharing in iTunes despite it already being on. I've hard rebooted the APTV by unplugging it...and that seems to temporarily fix it...but it will always return.

    Called Apple today...walked through all settings both APTV and PC...and they came to the conclusion that it was my router (which is brand new). They suggested to make sure that the following ports are open...

    TCP: 443
    TCP/UDP: 554
    TCP: 3689
    UDP: 5353
    TCP: 80

    I haven't had a chance to try this yet...hopefully it will clear things up. This is really frustrating. Home Sharing is one of the main reasons I purchased the APTV.
  • beep1 Calculating status...
    Currently Being Moderated
    Apr 6, 2011 3:41 PM (in response to Jeet K)
    i get this also, I updated to the latest software on my apple tv just a few days ago and it has been happening ever since. Hopefully Apple fixes this soon, I have to keep force quitting itunes then restart it.
  • Michaelworks Level 3 Level 3 (695 points)
    Currently Being Moderated
    Apr 6, 2011 11:00 PM (in response to Jeet K)
    Jeet K wrote:
    I'll try it with a wired connection.

    Do you think iTunes could be the cause of this ? I have a large library (300GB) and I'm copying files around a lot.


    It doesn't help, but the ATV2 only has 8 GB NAND memory so it can't/won't remember all of it, just what you access (music, movies, etc.). You might research what and if there are any library size limits. The ATV2 is really an iPod Touch, iPhone 4, iPad V1 parts iOS device. It has 256 MB of RAM, an A4 processor, and I/O ports added. It has the same Airport card as the three above. It will take a bit more time than a computer to process your library and talk to it over WI-FI 65 mbps and below.

    It may work perfectly after a Restore. If you aren't comfortable doing it, I've seen posters saying the Genius Bar will if you make an appointment. They can verify the hardware is good also. Good luck!
    MP 2.66 16GB ATI 5770 MBP i7 17" iMac iPhone 4 32 iPad 3G 64, Mac OS X (10.6.7), MBA 11.6" Ultimate Canon 5D & 5D MKII
  • charks Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 7, 2011 7:42 AM (in response to charks)
    Opened all said ports through my router. Home Sharing worked for about 15 minutes before it got booted off.

    Absolutely an APTV issue.
  • kailsabin99 Calculating status...
    Currently Being Moderated
    May 10, 2011 7:48 AM (in response to Jeet K)

    Home Sharing cuts out when I don't use it for a while. This means iPhones, iPad, Apple TV, even the Remote app can't connect to iTunes running on my wired computer. The only way to fix it is cycling my router (TrendNet TEW-652BRP). I've had ip assign issues with the router in the past so this could be related.

  • Enver Masud Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 5, 2011 1:28 PM (in response to Jeet K)

    Apple TV 2 keeps dropping the wireless connection. Will play iTunes and iPhoto content one moment, and drop connection next moment. I have to fiddle with it, restart everything to get it going again — EVERYDAY. Have latest Mac OS, iTunes, Apple TV software running on a MacBook Pro. Problem may have started with latest Mac OS update. Before this, it seems the only problem I had was with Netflix streaming.

  • stuartfromcroyde Calculating status...
    Currently Being Moderated
    Jun 16, 2011 12:19 AM (in response to Enver Masud)

    me too.

    very dissapointed with aptv2.  its is suposed to be streaming my itunes in the kitchen, thats why we buy this stuff, it drops its connection to home share even though it is all on and all the time. fix please apple.  p.s. i posted a question which suggested people may not wish to buy this until the fix is suplied, but apple took it down.  we need a fix quick apple. this product is a lot of money and at this time does not do what it says it should do.

  • Andy_Rob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2011 9:13 PM (in response to Jeet K)

    Same issue after update.  Easiest workaround is just to turn airport off and on again.  Reconnects fine for another 30 min or so.  Only times out when using homesharing itunes to atv2.  Waiting for a fix with with next update.  Ahh, pioneering.  I'll try to be patient but a bug fix for this type of thing should be days, not weeks or months.

    QA/QC apple. It's not like you lack resources or feedback.

  • joeb1knobi Calculating status...
    Currently Being Moderated
    Oct 3, 2011 9:40 AM (in response to Jeet K)

    I'm in the same boat. I've had absolutely no problems up until recently. I have 2 Mac computers and both computers can detect eachother's shared library but they keep disappearing from off my 2 ATV 2s. I don't think it's a router thing because I can still access internet content (ATV 2 detects the networks and can still use it) but the shared libraries just disappear. I don't know if the issue is with itunes of ATV 2 but I'm thinking its software related because both ATVs are crapping out. I've had the ATVs for months with absolutely no problems and now I can't hardly use them.

     

    I'm quickly falling out of love with ATV because its like our entire movie collection is randomly unavailable to us and we have to keep resetting the unit to get back functionality...but only for a short time.

     

    Is anyone still experiencing this issue? Anyone found a permanent work around?

1 2 3 ... 30 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (15)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.