Skip navigation

Using external drive to test program beta version, how safe?

250 Views 2 Replies Latest reply: Jun 6, 2011 2:12 AM by cricketernot RSS
cricketernot Calculating status...
Currently Being Moderated
Jun 5, 2011 10:33 PM

I have put CCleaner, Mac version, which is beta, on a spare TEST partition on an external Firewire 400 drive. I put a SuperDuper clone on that partition and then installed CCleaner there. The idea was to completely isolate a potentially risky beta program. Am I right that doing this means the normal internal startup drive cannot be corrupted? I had been warned that putting on a separate partition might still cause dangerous corruption but in this case it's not a partition on the internal drive, it's on external.

Yes, I know no cleaners are necessary for Mac. Just wanted to try it out.

Thanks for any comments.

iMac, Mac OS X (10.6.7), Windows 7 on BootCamp
  • jsd2 Level 5 Level 5 (6,200 points)

    I've been using an expendable "test clone" on an external partition for years with no significant problems. I use the clone for all my tinkering, and then I just re-mirror it from my HD every once in a while using SuperDuper's "Smart Update" feature. This clone is of course completely separate from my "backup clones" which I never mess with.   I would say that using a clone for testing is generally quite safe, but not 100% so - see this thread from earlier this year describing a rare but catastrophic issue experienced by some users  that simultaneously destroyed the data on all their mounted volumes:

    All mounted volumes erased when system crashed during XCode install

     

    For extra safety you could routinely unmount your internal HD before doing any testing from the external volume, though I generally don't do this. What I do routinely do is turn off Time Machine and automatic Mobile Me syncing before creating the test clone so that these functions are inactive on the clone, and I also never try to sync an iOS device when booted from the clone.

     

    Operationally the clone functions nearly normally, though what I do notice is that when an application that had been on the HD is run from the clone for the first time it is often again "quarantined" by the system as if it had just been downloaded, and I have to "approve" its use, even though I had cleared it from quarantine back on the HD before making the clone.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.