Skip navigation

Server is not correctly configured error.... Plz plz help

36659 Views 24 Replies Latest reply: May 18, 2012 8:26 AM by angelduzt RSS
  • copesetic Calculating status...
    Hi Guys,

    I have been having this problem for months on my iphone and now on my Ipad but I just figured it out and it was my sonicwall blocking it. I had to Enable HTTP Byte-Range requests with Gateway AV and it immediately started working. I don't know if any of you are running sonicwall products but if you are this setting can be found on the diag.html screen. Hope this helps some of you because I know this is a big issue, if you are not using a sonicwall my assumption would be that other firewalls are doing similar things.
    iOS 4
  • SDBatl Calculating status...
    Copesetic, thanks for the tip.

    Encountered the same problems on a DMZ behind a Watchguard corporate firewall. YouTube worked fine on Mac or any PC through a browser. The iPad and iPhone Youtube apps displayed the video selections, but as soon as a video was selected, the message "Server not correctly configured" displayed. Looking at the traffic log inside the firewall showed that no packets were being blocked, so policy setting were suspect. Sure enough, Http range requests were not being allowed by in the HTTP policy. Several web sources state that the iPhone and Touch use range requests for video download, so suspected that iPad does too. Changed the policy setting to pass range requests and problem solved. I agree that some of the complaints here are being caused by similar settings in other firewalls as range requests are blocked by default in Watchguards HTTP policy.
    Many
  • NathanKWA Calculating status...
    RE: "Server is not correctly configured"

    I was having the exact same problem with Iphones we used to have and with a new Ipad.

    I finally figured it out! In our case the issue turned out to be a setting in the 'Anti-Spyware Policies' on our Sonicwall TZ 170 firewall. Turning off HTTP Protocol Inbound Inspection under the Anti-Spyware Settings did the trick.

    This also resolved an issue we were having with Netflix streaming.

    This was a bit hard to discover as the dropped traffic was not showing up in the Sonicwall log

    Hope this helps!
    MS, Windows XP
  • Deejayk Calculating status...
    Ive been having this problem for three weeks now server not configured!
    iphone 4, iOS 4
  • Computer Bob Calculating status...
    God bless SonicWall. Turned off HTPP inspection under both anti-virus and anti-spyware and You Tube videos now get through. Lots of information on the web about the problem but very few solutions. Many thanks!

    Running Sonicwall TZ 150 with the basic firmware
    PC, Windows 7
  • CentralCoastFlyer Calculating status...
    The Http Range Request (checked ON) - in the Policy Editor, on our Watchguard 550e firewall, DEFINATELY WORKS, and fixed this error ---- nice job, SDBati. Thanks for the heads up.

    Poicy Editor => HTTP Proxy ==> HTTP Proxy Action Configuration ==> Click "Allow Range Request through unmodified" on the first page. Save it. Load it. Rock and roll!
    iPhone4, iOS 4, Evil Network Administrator (lol)
  • Shareef Yousef Level 1 Level 1 (5 points)
    Connected to the same wifi network, my iPad (4.3) gets the error while my iPhone (4.2.1) plays it fine. So it def isn't a network issue for me. What else can I try?
    MacBook Pro - iPhone 4 - iPad 2, Mac OS X (10.6.7), 15" 2.66GHz MBP (2010), Hi-Res AG, 8GB, 256GB SSD
  • Packet Sniffer Calculating status...

    I do not recommend you disable inbound inspection on anything!  You are defeating the purpose of having a deep packet inspection firewall by doing this!  Might as well buy a $50 router at Best Buy!

     

    I am running SonicOS Enhanced 5.8 and here is the correct place to click.

     

    Security Services --> Gateway Anti-Virus --> Configure Gateway AV Settings --> Enable HTTP Byte-Range requests with Gateway AV

    Click OK

     

    If you have disabled inbound inspection, please re-enable it!

  • s. hadi Calculating status...

    I haven't installed anything how do I find out if I,m running sonic or something else. Completely new to apple and getting this utube error. Not sure what to do

  • angelduzt Calculating status...

    Thank you, PS. That looks like it resolved our issue with YouTube on an iPad, using a SonicWall NSA E5500. Much appreciated. We had opened up YouTube to our staff but it was still not cooperating until now. Previously we could only get YouTube to work through a flash-browser-app called Rover (not suggested as a fix, just an observation).

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.