Skip navigation

Plug-ins not showing up in Aperture 3.1

1259 Views 8 Replies Latest reply: Apr 25, 2013 2:28 PM by abhallowell RSS
hibhaven Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 6, 2011 10:31 PM

I have been using Aperture for a past few days, and when i tried to instal two plug-in programs (photoshelter - it is a photo hosting site and the plug in allows you to upload photos directly to the site, and HSC edit - this is an edit tool I downloaded from the Apple site). Neither of them show up in the menu of Aperture. I tried re-installing, but doesn't work. what could i be doing wrong?

MacBook, Mac OS X (10.6.7), MB intel Core2Duo,320GB HDD,4GB RAM
  • CorkyO2 Level 4 Level 4 (1,290 points)
    Currently Being Moderated
    Jun 7, 2011 6:56 AM (in response to hibhaven)

    Did you download the Photoshelter Aperture plug-in version 1.3.2?

     

    According to the third FAQ toward bottom of page at link below, this version fixes that situation:

     

    http://www.photoshelter.com/help/tut/archive/upload/aperture

     

    Note - I have not used that plug-in, but the linked page seems to outline the use pretty well.

     

    Hope this helps.

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Jun 8, 2011 8:42 AM (in response to hibhaven)

    Plugins normally are installed in /Library/Application Support/Aperture/Plug-Ins if you chose to make the plug-ins available to all users. If not they would be in Home/Library/Application Support/Aperture/Plug-Ins

    (Home being replaced by the name of your home folder).

     

    If you look in those places do you see anything? 

     

    BTW you have restarted Aperture since you did the installs?

  • CorkyO2 Level 4 Level 4 (1,290 points)
    Currently Being Moderated
    Jun 10, 2011 6:19 AM (in response to hibhaven)

    That symbol usually means that you are not logged in as the authorized user or that it is a system file / folder. AFAIK, that should not be considered a restricted 'System' level folder.

     

    Are you trying to run the program from the same account you installed Aperture from?

     

    Note - that folder is not a restricted folder on my machine where I install and run from the same administrator account.

  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Jun 10, 2011 7:28 AM (in response to hibhaven)

    If you are unable to view that folder with the finder Aperture will be unable to access it when you run the program.

     

    As a first step I would run repair permissions under Disk Utility (not from Aperture first aid). That ay resolve your problem. If it doesn't post back describing how you install Aperture

  • abhallowell Calculating status...
    Currently Being Moderated
    Apr 25, 2013 2:28 PM (in response to Frank Caggiano)

    Frank,

     

    I have a similar situation that you seem like you might understand.

     

    I bought a new computer, started a new user (A), and downloaded Aperture. Then I realized it was easier to move the pictures from my old computer by transferring everything from that computer, creating another user (B) on my new computer. Since then I havent used user A at all, but now I can't access plug-ins for Aperture. Based on your posts above I checked user B and sure enough there are the plug-ins. I tried to repair permissions in the disk utility, and that didn't help. I restarted the program after each try.

     

    Any idea of what I might try next?

     

    On a separate note, I've been unhappy with this new macbook pro from the start, as compared to my old macbook, in terms of speed. Plus the battery life *****, which is a main reason i ditched the last one, no where near as advertised. Could an extraneous unnecessarily running/ partitioned in the background be creating any problems for speed or battery life? Or was dumping in everything from my old computer a bad idea?

     

    Thanks in advance to anyone who can help.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.