3 Replies Latest reply: Jun 15, 2011 6:33 AM by barreltone
roxannefrombrisbane Level 1 Level 1 (0 points)

I have recorded a voice audio and can export to mp3 fine. I added an effect to change the voice, and it exports fine, but it has no sound???


Soundtrack Pro, Mac OS X (10.5.8)
  • 1. Re: Export to mp3 problem
    barreltone Level 2 Level 2 (495 points)

    Must not be too fine, if it has no sound. So you added an effect and processed it, and when you listened back before exporting the sound was there, and the effect was working?

  • 2. Re: Export to mp3 problem
    roxannefrombrisbane Level 1 Level 1 (0 points)

    I applied the Vocal Transformer via the Effects panel, and it played fine while in the program. I even created a pre-set in this panel, but noticed it did does not appear in the Process > Effect menu. It does not allow me to render to an action either.

  • 3. Re: Export to mp3 problem
    barreltone Level 2 Level 2 (495 points)

    I just tried this as an an experiment, and I'm getting the same result. That is, I put the Vocal Transformer effect on a single track in a multi-track project, export the Master Mix as an mp3, and I'm getting silence, too.

     

    It's an extra step, but a workaround is to export as an aif or wave file first, then do the conversion to mp3.

     

    If you do that, make sure to set your submix to the same number of channels as your track (i.e., stereo or mono), so that the resulting file you export is the same channel count, instead of surround.

     

    Hope that helps!

     

    EDIT: BTW, I submitted this as a bug to Apple.