Skip navigation

Update to 10.6.8 broke my optical audio -  any help?

84290 Views 341 Replies Latest reply: Oct 13, 2011 6:35 AM by ArnoutF RSS
1 2 3 ... 23 Previous Next
Jan Nechyba Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 24, 2011 2:42 PM

Hi everyone,

 

i have just upgrade my system to 10.6.8 and everything work fine except my audio thru optical output. I have pluged Logitech Z-5500 Digital to my MacBook Pro's optical sound output and my problem now is that, when i play some HD movie vith DolbyDigital AC3 ore DTS, it plays fine but when i stop watching movie and close VLC, no other sounds play.. no itunes, no standard stereo movies ect.. it plays only AC3 od DTS sound track.. so when i want to listen some music, i must restart MBP and it plays again everything until i open again movie with 5.1 track....

 

any solution to fix it?

 

thanks in advance

 

Jan

MacBook Pro 15, Mac OS X (10.6.7), 4 GB RAM
  • aritza Calculating status...

    Same problem here imac 24, cant get optical output work after update.

  • PAPPL Calculating status...

    Same problem here Mac Mini 2009. No stereo out after surround sources over optical out to external receiver.

    Problem occurs right after update to OSX 10.6.8

    Tried to change settings in sound & midi menu but only rebbot enables stereo again.

    This problem is present in safari browser since i got my mac mini in 2009, after watching surround sources in itunes or vlc i have to restart safari to get stereo sound (e.g. youtube) again, but now stereo doesn't work anymore on whole OSX until reboot.

  • mweisser Calculating status...

    Same problem, too. i use a mac mini core solo. reinstalling 10.6 + combo update to 10.6.8 didn't work either. currently workin' a rollback to 10.6.7. let's hope for a quick fix.

  • Faro_1980 Level 1 Level 1 (0 points)

    Same problem here... Using a Mac Pro, and also the Logitech Z-5500.

    I guess there is a bug in 10.6.8

    I hope they will fix it soon!!!

  • Joeyjojo25 Level 1 Level 1 (60 points)

    Seeing as there is no way for me to contact suport as my hardware is out of warranty (MacMini-Late 2009), I thought I'd post in here that this is also happening to me. I use it to play music from iTunes and watch videos. Now that the stereo optical out is broken and I can't roll back the update, it's useless. As others have said, DTS and AC3 is fine, but not stereo. This is BS! How was this not found in testing??? I'll now have to plug in an analouge stereo lead and give up DTS & AC3 until this is sorted. Hopefully it's not long.

     

    I just got my MacBook bottom replaced last month and my iPhone 4 the month before. Apple used to be reliable. At least they're making billions in profit every year

  • Seanld Calculating status...

    I'm using a Macbook Pro 17" (2008) and when I did this latest update (the one with the MacDefender fix) it broke my sound.

     

    Digital sound works in VLC, but nothing else works. No sound in my browsers, no sound in Quicktime, no system sounds, nothing except VLC when I choose Audio Output-Built-In Output-(Encoded Output). *****.

     

    Apple, fix this now, please.

  • MakX Calculating status...

    I'm having audio issues but of a slightly different nature. Any audio output via HDMI to my Sony TV, ever since the 10.6.8 update, has been skipping every now and again. I have tried lowering sample rates and bit depth in Audio MIDI Setup app but it's really made no noticeable difference.

     

    It's definitely software related as it was working 100% fine before the update. Yep, Apple need to get this fixed ASAP - and the issues better not be replecated in Lion.

  • babouin72 Calculating status...
    Currently Being Moderated
    Jun 25, 2011 1:08 AM (in response to PAPPL)

    Same problem :

    Mac Mini 2009. No stereo out after surround sources over optical out to external receiver.

    Problem occurs right after COMBO update to OSX 10.6.8

    tried to re-apply combo, not solving...

  • enjayjay Level 1 Level 1 (0 points)

    Perian installed?

     

    10.6.8 installed - all OK - Eyetv sound. I watched an MKV - multi channel output. After this my eyetv which is stereo (encoded as dolby surround II) by perian stopped working - silence - though something was hitting my amp - it was getting some stream but silence. Audio midi setup would crash every time I would try and open it when eyetv TV window open. Removed perian - now I have sound back in eyetv.

     

    Perians fault? Apples fault?

     

    Not sure - but it got it back for me.

  • babouin72 Level 1 Level 1 (0 points)

    enjayjay,

     

    Perian is not installed on my system...

  • nickmooney Calculating status...

    Audio problem here for 10.6.8 - I get NO SOUND whatsoever now (through internal speakers or through earphones).

     

    https://discussions.apple.com/thread/3140147

  • PAPPL Level 1 Level 1 (0 points)

    Even original iTunes-movies don't switch back to stereo output when selected in menu.

     

    Perian is not the problem! Removed perian and after new login same problem.

     

    It's enough to log off and relog into MacOSX to enable stereo out again, this is quicker than a reboot.

     

    :(

1 2 3 ... 23 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (20)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.