Skip navigation

Updated to 10.6.8, now I can't print

186190 Views 376 Replies Latest reply: Feb 21, 2014 2:25 PM by ETeague RSS
  • sp0radic Level 1 Level 1 (120 points)
    Currently Being Moderated
    Jun 25, 2011 8:13 PM (in response to cm-nzl)

    Problem fixed for me.

     

    After looking at the print error logs and seeing that the failure was with the lpd file, I replaced the lpd file in /usr/libexec/cups/backend/ with a backed up copy from Thursday and now I can print.

     

    The new lpd file that doesn't work is dated 30/04/2011 whereas the previous one, that does work, is dated 11/02/2011.

     

    I'd like to know what's different with this new lpd file that is causing the failure and if I'm missing out on anything by not having the latest version of that file.

  • rafavalles Calculating status...
    Currently Being Moderated
    Jun 25, 2011 9:30 PM (in response to sp0radic)

    Are you a Xerox DC user?

    If you are obe can you please descrobe te fixing step by step

    I cant find those paths you mention neither on my imac or my time machine

     

    Thanks in advance

  • sp0radic Level 1 Level 1 (120 points)
    Currently Being Moderated
    Jun 25, 2011 9:57 PM (in response to rafavalles)

    Yes I'm using a Fuji Xerox DC236.

     

    Go to the Finder, choose the Go menu, choose Go to Folder, enter or copy /usr/libexec/cups/backend/ the click Go and the "backend" folder will open in the Finder. With that folder open, Enter Time Machine, and go back in time until prior to the update, click on the LPD file and Restore it. I chose to keep both the original and the backup when Time Machine prompted, that way I end up with both files just in case.

  • samko Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 26, 2011 6:16 AM (in response to cm-nzl)

    Printer model: HP CM2017

     

    Problem: Failed to print after upgraded to 10.6.8

     

    Solution: Removed printer. Add printer from System Preference.  DO NOT USE BONJOUR to look for printer. In stead enter printer IP address and print using HP Jetdirect.

  • wahed Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 26, 2011 7:36 AM (in response to cm-nzl)

    here is what worked for me, I have two xerox 4112

     

    After backing up my /usr/libexec/cups/backend folder

    I copied the entire content of backend folder from last weeks Time Machine

    copy renamed my existing copies to original, kept both files

    Right away my printer started to print.

     

    Installed both printer with existing drivers and I am able to print to both Xerox 4112. I have trying everything this weekend nothing worked. This may not work for everyone but try to work with the content of backend folder

     

    Good luck

  • wrf3 Calculating status...
    Currently Being Moderated
    Jun 26, 2011 10:08 AM (in response to cm-nzl)

    Just to add my 2 cents: upgraded to 10.6.8 on Friday; could print to one printer (a Konica Di3010f), but could not print to a Konica BizHub C300 due to the "dnssd failed" message.  ipp is crashing with a divide by zero error.

     

    Fortunately, I made a backup before upgrading, so I'll restore the 10.6.7 files.

  • jstottmarketing Calculating status...
    Currently Being Moderated
    Jun 26, 2011 2:44 PM (in response to PAHU)

    Hi Pahu,

    I just installed the 10.6.8 combo, and repaired permissions, but no joy unfortunately. I also tried the option of uninstalling and reinstalling printer not using bonjour - still no joy. Permissions appear as they should be from post above.

    Unfortunately I don't have a time machine backup I can fall back on. I only just bought an external drive and ran my first backup yesterday.

    Do you have any further suggestions?

     

    James

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Jun 26, 2011 3:21 PM (in response to jstottmarketing)

    Hi James,

     

    If you go back to page 6, velocius has posted a link to the 10.6.7 version of the socket backend. So you can download this and replace your current 10.6.8 socket backend with this downloaded one. He also describes how to do this. With the file replaced you can then delete your current print queue and add a new queue, this time selecting IP > HP Jetdirect-Socket for the protocol. You then enter the IP address of the printer, leave the queue field blank and select the printer model in the Print Using menu. Now see if you can print without error.

     

    Pahu

  • CirrusFlyer Calculating status...
    Currently Being Moderated
    Jun 26, 2011 8:04 PM (in response to cm-nzl)

    Just to add some color to the solutions being proposed ...

     

    I have a MacBook Pro and an iMac, both of which stopped printing to the same networked printer (a Lexmark X502n). The MacBook Pro problem got fixed using Velocious' suggested solution of restoring the 10.6.7 version of the "socket" executable file in the backend folder. However, when I tried the same fix on the iMac it did not work. I then restored the entire backend folder on the iMac back to the 10.6.7 version from my time machine backup.

     

    Bottom line .. the solution may not lie with the "socket" executable in every case. Clearly, the issue is with one or more elements of the OSX 10.6.8 backend. Please refer to earlier messages that show where and how to find the backend folder on your machine.

     

    Someone else more technically astute can probably explain the nuances of why the "socket" fix worked on one machine and not the other. I am just grateful for the others before me that helped zero in on the possible solutions.

  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Jun 26, 2011 8:28 PM (in response to cm-nzl)

    here is an idea... curious if this works. If you cant print, take a crossover cable (not an eithernet cable) connect it to the printer. Reset the printer on the mac by adding it to the printer list if it is not already there or if it is there add a new printer. After adding the printer  test your printing, then test with the crossover cable disconected. I use to own a HP business injet 1200 and that is what was needed sometimes.

  • whizz5000 Calculating status...
    Currently Being Moderated
    Jun 26, 2011 9:20 PM (in response to cm-nzl)

    Fixed !

     

    I have a network of Fuji Xerox DocuCentre IV 5580's using an older non-postscript driver.  Worked perfectly under OS X 10.6.7 but the 10.6.8 update give me the 'printer paused' problem.

     

    Per some of the previous suggestions, the problem is with some broken files in /usr/libexec/cups/backend

     

    Simply restore the following files in the backend folder from either the 10.6.6 or 10.6.7 versions:


    socket

    dnssd

    lpd

    ipp

     

     

    Once you've done this, you have to re-set the Printing System, and also run 'fix permissions' using the Disk Utility.

     

    All back to normal, although I'll look out for the fix from Apple.

  • PositiveY Calculating status...
    Currently Being Moderated
    Jun 26, 2011 10:29 PM (in response to whizz5000)

    Easy fix and now we are back printing.  Told the users to restart instead of restarting the printing system. Thanks!

  • johannes28 Calculating status...
    Currently Being Moderated
    Jun 27, 2011 12:58 AM (in response to PositiveY)

    Hi,

     

    thanks to all of you for the patch! Restarting the macs did the job for me instead of resetting CUPS.

     

    We have updated all Macs here at work over the weekend and the network printers did not work anymore (HP Color Laserjet CM 1312nfi)

     

    But I am really wondering what Apple is doing there? Is 10.6.8 a beta? We switched from windows to macs years ago,  but I am in doubt if that was the correct thing to do...

     

    Best regards,

    Johannes

  • edjonesy Calculating status...
    Currently Being Moderated
    Jun 27, 2011 4:41 AM (in response to velocius)

    I have just encountered this problem printing from a Mac Mini and a Mac Pro to a Xerox DC240 hooked up to a Creo RIP,

    I tried Velocius tip of moving the socket file from a time machine backup and sadly it didn't work, it did make me think though, I print to the DC240 via LPD, so i copied the lpd file over instead of the socket file. Printing now works. WooHoo. I did make backup a backup copy of the lpd file prior to replacing it.

    Thank Velocius, although you didn't fix my problem, you certainly pointed me in the right direction and gave me a good kick.

  • whizz5000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 27, 2011 4:50 AM (in response to johannes28)

    You did the right thing to move to Mac.  I've just helped a friend fix his audio drivers on  Windows 7. What a dog Windows is in comparison.  Despite this small hiccup, the Macs are so stable - a pleasure to use.

1 ... 7 8 9 10 11 ... 26 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (14)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.