7 Replies Latest reply: Nov 5, 2011 1:38 PM by BRLeep
dhjdhj Level 2 Level 2 (160 points)

Today, I decided to try creating an "emergency" MainStage concert using only plugins in the event that my main live rig stops working for some reason.

 

My approach was to create a basic set of instruments and put them in an "Instruments" set.

 

I then created a new set with patches for each song and inserted aliases from the "Instruments" set so that I could keep memory requirements down.

 

Here are the issues (and also some suggestions for consideration) I ran into while doing this:

 

1) After setting up a keyboard (an Akai MPK 88) in Layout mode, the "learn lowest key" would not in fact learn the lowest key. I had to do it manually.

 

2) I pasted a channel as an alias. I then deleted the alias and pasted an actual channel strip. From that point on, it was impossible to get sound out of any plugin that I inserted into that channel strip. I could open the plugin (tried various different ones) and those that had audio output meters did indeed show that they were responding to the keyboard and generating audio, but the audio didn't make it into the channel strip. I had to delete the actual patch and recreate it. I was able to reproduce this twice.

 

3) It doesn't seem to be possible to paste an alias to a channel strip more than once in a patch. This is a real pity --- there are several places where I would like to have the same sound be produced twice, with one transposed up or down an octave.

 

4) When you leave the Layer Editor to go to another tab, the "Learn lowest or highest note" buttons should be turned off if they are on. I got bitten quite a few times as I flipped from the Layer Editor to the MIDI input tab as I was configuring multiple layers only to discover that keys were still being learned.

 

5) There needs to be a way to resend all the initial program changes (including bank select and initial CC values) for a patch without having to leave the patch and come back to it.  This is a real pain

 

6) I'm not sure if I'm missing something but if the patch list view is longer than what will fit on the screen, I could not find a way to scroll to the patch I want. I had to click on a patch near the bottom of the screen which then scolled the patch list up so that I could find the patch I needed.

 

7) There should be a way to show ONLY the patches for a selected set. That way, it is far less likely that the patch list will exceed the vertical available space.

 

 

Some of the above are nuisance issues but clearly bugs (like #2) but #5 and #6 impact performance mode.


Macbook Pro, Desk Pro, Mac OS X (10.6.6), www.deskew.com (digitize your sheet music for the iPad)
  • 1. Re: Probems and issues with 2.1.3
    aerol Level 3 Level 3 (515 points)

    The title of this thread could be quite misleading.  Aside from possibly your second point none of this is new in 2.1.3.

  • 2. Re: Probems and issues with 2.1.3
    dhjdhj Level 2 Level 2 (160 points)

    Why it is misleading? These are all relevant as of  2.1.3 ---- it's even more distressing for older issues that are still not addressed, particularly if they have already been suggested.

  • 3. Re: Probems and issues with 2.1.3
    aerol Level 3 Level 3 (515 points)

    I said 'could' be misleading as it could sound as if these are new to 2.1.3 and therefore might stop folks from updating.

  • 4. Re: Probems and issues with 2.1.3
    Blueberry Level 4 Level 4 (2,860 points)

    While (1) and (2) seems to be potential bugs, the rest seem more like ERs for the next version. Why are they 2.1.3 specific?

     

    BTW: There is no way an alias can be in the same patch twice, because an alias points to only ONE channel strip. It would make NO sense to have a reference to one channelstrip twice in the same patch, because it can only have one setting anyway at any given time.

  • 5. Re: Probems and issues with 2.1.3
    dhjdhj Level 2 Level 2 (160 points)

    Are you seriously suggesting that someone using a particular version of a product is supposed to go back and try all the earlier versions to see if the problem was there before? I never said that the issues were specific to 2.1.3. I simply said I encountered them while using 2.1.3

     

    As for aliases, perhaps I don't understand them very well. Never tried them until 2.1.3   I thought the point of aliases was to save memory by reusing the plugins and effects. If that's the goal, then there's no good reason why attributes such as keyboard split information (note range), velocity mappings, transpose and so forth should be tied so tightly to them.

     

    Incidentally, do you happen to know if there is a way to make the plugin tied into the original channel strip to change its preset? It would be VERY nice to be able to reuse a single plugin for different sounds on different patches. I tried doing this with the Plug-in Library with one of my soft-synths but as you can see from the attached picture, while the top level categories showed up in MainStage, selecting one of them (Bass, in this example) does not show the contents of the category (the contents can be seen within the plugin)

     

     

    Those ERs have been requested for the "next" version after every previous "next" version that ever was.

  • 6. Re: Probems and issues with 2.1.3
    stevensocal Level 1 Level 1 (0 points)

    I have windows xp , when I try and download 2.1.3 update I get this message, in a dialog box .. "The feature you are trying to use is on a network this is unavailable."

    Below in the box says "Click ok to try again , or enter an alternative path to a folder containing the installation package "applesoftwareupate.msi in the box below ...  

     

    Use source and a browse button is in the box below.

     

    Can anyone help me on this one .. Please email if you have a fix for this ? I can't install 2.1.3 which I need to install 10.5 itunes in order to get software update 5.0 for iphone.

    Thanks,

    Steve

  • 7. Re: Probems and issues with 2.1.3
    BRLeep Level 1 Level 1 (0 points)

    Steve,

     

    Did you find a fix for your update issue? I have the same problem and cannot update to 10.5 because of the inability to update 2.1.3 (?)

     

    Bill