1 2 3 4 Previous Next 57 Replies Latest reply: Apr 18, 2014 6:26 AM by HUNIM
Schwa72 Level 1 Level 1 (15 points)
I just installed a new Crucial C300 256GB SSD in my mid-'09 MacBook Pro (2.66GHz Core 2 Duo w/ 4GB RAM). I didn't have any issues with the install but I did notice that the negotiated link speed shown in System Profiler for the drive (under Hardware - Serial ATA) is only 1.5Gbps when 3Gbps is possible and the SSD supports 6Gbps transfers.

Here's what's really weird -- if I reset the computer's SMC, the correct negotiated link speed of 3Gbps shows up after booting...until I reboot the computer at which point it drops back down to 1.5Gbps. What the heck is going on here? How do I get the SMC to "stick" so the drive doesn't slow down after a reboot?

FWIW I'm running EFI version 1.7 so SATA-II speeds should be possible. I have read about the issues that some are having with mid-'09 MBPs and non-stock hard drives so I suppose this might be related...

Thanks in advance for any pointers!

15" mid-2009 2.66GHz C2D MacBook Pro, Mac OS X (10.6.4)
  • 1. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    Revolutionary Rob Level 1 Level 1 (0 points)
    For whatever it's worth, I just received a new MacBook Pro yesterday in the mail and it has a negotiated speed of only 1.5Gbps
  • 2. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    Seitch Level 1 Level 1 (5 points)
    Hey Schwa72 --Did you ever get this sorted? Would love an update if anyone has any further information as I'm thinking of replacing the internal drive with a SSD on my new machine: mid2010 2.8Ghz Macbook Pro. I'm shooting for startup and application launch speed boosts.

    What I'm trying to figure is if the Negotiated Link Speed is capped at 1.5Gbps is there any advantage in waiting for the new generation 3 Sand Force SF-2000 drives? Is it better to have 6Gbps transfer if only 1.5Gbps transfers are supported on S-ATA? Are there advantages over current generation 2 SSDs?

    Thanks in advance for any guidance!!
  • 3. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    SoySauceWDF Level 1 Level 1 (0 points)
    The same thing is happening to me, except it won't change to 3.0 even if I reset the SMC. I'd really like a solution so I can use more than half of my ssd speed.
  • 4. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    Toocool4 Level 2 Level 2 (365 points)
    I did read somewhere, can’t remember where about this issue with the Crucial C300 SSD.

    I have exactly the same spec as yours, but I use OWC Mercury Extreme Pro 240GB SSD and do not have any link / negotiation speed issues. It always links up at 3 Gigabit.
  • 5. Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 17" early 2009  MBP...
    Konstantinos Kafritsas Level 1 Level 1 (5 points)
    Same thing happens to me.
    I have a Macbook Pro 2.93 GhZ Core2Duo early 2009 with a Optidrive-replacement Crucial C300 SSD.
    Link speed available is 3 Gigabit, but it only gives me negotiated link speed of 1.5 Gigabit.
    Crucial tells me it's Apple fault, since it works on WIndows machines... Please Apple, do a Firmware-Upgrade to enable 3 Gigabit on every macbook pro!
  • 6. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    mpanebianco Level 1 Level 1 (0 points)

    Same problem with my Mac Pro. I have four 500gig SATA II HDDs in a RAID 0. All rated for 3Gbs. Negotiated Link Speed is 1.5 when it should be 3.0. Only once have I seen them connect at 3.0 speeds. Sometimes 2 of the drives will connect at 3.0 speeds but not the other two. I need to see if this is HDD related or SATA port related.

     

    Be nice if there were a EFI update or something to fix the issue. Considering how many users are affected. When all HDD do connect at 3.0 speeds I love the speed bost I get. With Apples Software RAID I was Geting close 200MBs in speeds based on ATTO.  This is my main working RAID. I am using the two other ports located behind the fan for additional drives. So I have 6 drives in my tower. And I hve tried various configuartions to get things to work.

     

    It is possible that my HDDs firmware may need to be upated. I have read that some of the Samsung drives have issues in RAID.

  • 7. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    AussieDJ Level 4 Level 4 (1,435 points)

    I am having the same issue with a 17" Mid 2009 MBP 5,2. With original 500GB 7200 HDD in it. Both the HDD & DVD both say negotiated link speed of 1.5GB/s. Need a solution.

  • 8. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    AussieDJ Level 4 Level 4 (1,435 points)

    Ok, so after a bit more research...

     

    The EFI 1.8 Firmware update added a new field showing "negotiated link speed", which it did not display before. However it was always running at SATA 1. The reason being, is that Nvidia SATA chipset was running terrible with SATA II, with people reporting beachballs galore, so apple decided to reduce the firmware to SATA I, since that runs at 150MB/s, and the HDD's wouldn't run at that speed anyway, even the Apple supplied SSD's.

     

    So the general consensus is that all HDD's supplied by Apple are firmwared at SATA I.

     

    So it seems that this problem which repeats itself with Apple when the SATA interface upgrades. Since these problems have been going on since 2008 with SATA II.

     

    However, what is also surprising, is that the latest Early 2011 17" is reporting SATA issues. This occurs & is noticable when a SATA III SSD is installed, but it happens on random machines. Some work, others don't. They seem to now have SATA II down pat, but SATA III now having the issues. And the DVD SATA cable is locked on SATA II.

     

    And what's further, is that Apple have now released the new iMac, with a CUSTOM SATA cable, so there is no user replacing on those going on as far as I know. I'm sure there will be updates on this in the coming weeks.

  • 9. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    ajbliss Level 1 Level 1 (0 points)

    Hi Everybody. I've got a Late 2008 MBP 5,1. I want to install an SSD, but I'm afraid that I won't be able to get the SATA II speeds I am supposed to have. Is there any way to make the computer use the 3.0 Gb/s link speed it's supposed to? Buying an SSD would be a waste if I can't get it above 1.5 Gb/s. Thanks!

     

    ajb

  • 10. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    ch.silent Level 1 Level 1 (20 points)

    is it because the hard drive interface?my mbp is ATCI,but you know,the interface of hard drive mostly is SATA3 or 2.i mean maybe the negotiated link speed is limited because of the difference of interface between the mbp and the hard drive you bought.

  • 11. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    timothy37 Level 1 Level 1 (0 points)

    I also have the same issue after installing a Crucial M4 256GB SSD in my MacBookPro 5,3 (mid-2009 15" 3.06ghz core 2 duo). Negotiated link speed is 1.5 and I have all updates (OS 10.6.8). The SSD is still pretty quick but if this computer is capable of 3.0gbps I'm wondering if it can be quicker!

  • 12. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 17" early 2009  MBP...
    No Problem Level 1 Level 1 (10 points)

    So what you are using basically is:

     

    Forget SATAII on your late 2008 Macbook with MCP97 Nvidia Chipsets, right?

     

    When I boot the system with the Install DVD my Vertex 3 on my late 2008 Macbook shows 3 Gigabit and no "negotiated speed" entry.

     

    So I guess it could work, we would have to figure out which EFI Firmware Update introduced the throttle?

     

    Any idea how to revert an EFI Firmware Update?

  • 13. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 15" mid-2009  MBP?
    AussieDJ Level 4 Level 4 (1,435 points)

    It seems this thread was referring specifically with Mid 2009 Macbook Pro's.

  • 14. Re: Negotiated Link Speed only 1.5Gbps for 256GB SSD  on 17" early 2009  MBP...
    timothy37 Level 1 Level 1 (0 points)

    Yes, this may be specific to mid 2009 macbook pros (mine has MCP79). If I recall, EFI 1.7 was supposed to enable 3.0 gbps but this does not seem to be the case. It could also just be specific to certain SSDs like mine although the crucial m4 supports SATA 3. Oh well, to be honest, the difference between 1.5 vs 3.0 gbps probably isn't noticeable in real-world day-to-day performance unless you're constantly transferring very large files and I'm happy that the drive is completely stable so far.

1 2 3 4 Previous Next