4 Replies Latest reply: Jul 10, 2011 11:10 AM by LexSchellings
Al-V Level 1 Level 1 (0 points)

When I try to install Safari 5.0.5, I get a message stating that it works only with OS X 10.6.7. Is there a way to install a compatible version of Safari?


Mac Book Pro, Mac OS X (10.6.5)