Skip navigation

MacBook Pro constantly losing wireless connectivity

913586 Views 1,983 Replies Latest reply: Apr 17, 2014 11:39 AM by nobhilll RSS Branched to a new discussion.
  • blackICE888 Level 1 Level 1 (0 points)

    Thanks ffredburger! Couldnt agree more. Question I have is why in the last 24 hours has this started happening to me. I recently changed from Internode to Optus. Was running so well without a single network drop on home wifi until yesterday. Even went to the trouble & expense of buying the Optus preferred/supplied Netgear wireless cable modem/router. The service rocks! All devices in the house are running perfectly well. Except the MacBook Pro 15. Tried everything suggested on the web searches I have done. Only thing that works is killing off Airport then restarting it. Get 5 to 10 mins then it drops off the wif net again!. This is getting pretty ridiculous & way beyond a joke! I really hope someone can some up with something soon. I love my Macbook but to go from a great performance to this rubbish is not good when my Wintel & Android devices all work fine!

  • William Kucharski Level 6 Level 6 (14,405 points)

    Jamie Jamison wrote:

     

    No Bill, this is pretty definitively a MacOS X issue because none of the other equipment that connects to my WAPs suffers from this problem. Additionally when I enable debugging on the Airport I can see error messages about coming out of power save mode that lead me to believe that this is either a problem with the 802.11 framework in MacOS X or with the Broadcom chipsets used in Apple products or with some interaction between them.  This is a really stupid comment on your part, it's incredibly dumb. Seriously, would you argue that because millions of people drove a Ford Pinto without being burned alive that there wasn't a problem with the gasoline tanks? Or perhaps you'd argue that since millions of people took Vioxx without having fatal heart attacks within the first two weeks of taking the drug that there wasn't a problem with Vioxx. Or perhaps you'd argue that since millions of people ate at Jack in the Box back in the early 1990s without contracting fatal E. Coli infections that there weren't any problems with the food handing procedures at Jack in the Box or with the quality of the beef they were buying.

     

    I think that this problem has to do with the Broadcom chipsets in the Macbooks and how they handle power save mode. I think that the chipset goes into power save mode when the OS goes to sleep and then doesn't wake up when the system wakes up.

     

    In fact this is more like saying "My friend Joe was the only person I know who ate beets, and he died of cancer, so obviously beets cause cancer."

     

    There is no proof at this point, debugging messages or not, that Mac OS X is at fault here and given the evidence to the contrary, it's much more likely to be the firmware in your router or WAP.

     

    However, you'll also note that I said:

    It's not that it's definitively not a Mac OS X issue so much as it's likely to be a router or configuration issue given the literally millions of Mac users using their machines with multiple router vendors' products daily with no issues at all.

     

    Note: I never said it wasn't a Mac OS X bug, I simply stated that given the evidence at hand, it was more likely that the problem lay elsewhere.

     

    This, by the way, is what makes things like the Vioxx case you quote so problematic; while it did increase the incidence of heart attack among some members of the public that took it, there is also a number of people who took it who will now suffer stomach ulcers from taking aspirin or side effects from some other medication they must now take that Vioxx is no longer available; much of medicine is based on a link between medication and effect rather than a firm, scientifically proven causality.

     

    The Jack in the Box E. Coli outbreak was caused by neither food handling procedures nor the "quality" of beef they were purchasing but rather due to poor food handling procedures at the vendor from which Jack in the Box purchased beef for certain restaurants (Von Companies of California) and the fact that they did not cook the patties to 155ºF - a temperature that did not become an FDA recommendation until after the outbreak occurred (Jack in the Box instead cooked their patties to the FDA recommended temperature in force at the time of the outbreak - 140ºF) - a change that was in fact made due to the outbreak.

     

    As far as your hypothesis about Broadcom chipsets in MacBooks, I'd have to ask if you have evidence showing whether it's only Broadcom-based chipsets that are having this issue with your WAPs? I say "your WAPs" again because I know many people with Broadcom-equipped MacBooks who are seeing no such issues with any of the routers and WAPs with which they use their machines.

     

    If you have a definitive "this AirPort driver with this chip with this WAP running this firmware" reproducible scenario, I'm quite serious in saying that I'm sure Apple would love to know so they can duplicate it in their AirPort testing labs.

     

    It doesn't matter whether every other device on the planet has no problem connecting to a certain WAP, it's a matter of being able to prove that the issue is with the Mac OS X driver; for example it could be a Broadcom firmware issue.

     

    I've given this example several times already across multiple threads, but once again:

     

    If say the firmware of a router has a bug where adding 2 + 3 yields 5 but adding 3 + 2 yields 6, even if every other device on the planet adds 2 + 3, it's not Apple's responsibility to rewrite their driver because they add 3 + 2; it's the device manufacturer's responsibility to fix their bug.

     

    But once again, I'm not saying it's not Mac OS X, but rather that if you have a reproducible test case, AppleCare would love to know about it.

  • StephTizio Level 1 Level 1 (5 points)

    I've moved to another location.

    Now my MBP has developed a new connection headache; it cannot see the wireless network that every other device in the house (PC and Apple) finds instantly with ease.

    Some MBP's develop wireless networking problems of varying nature. It happens to folks who have had their notebooks for a couple of years and it happens to folks right out of the box. If you research this issue, it's pretty obvious no one knows what is going on – or how to fix it.

    Anyone contemplating the purchase of an MBP should know that it's a crapshoot. If you get stuck, you're out of luck. Caveat Emptor.

    Maybe a Mac ace would like to trade with me and see if he/she can figure out what's up with the MBP 15" before investors hear about Apple's Achille's Heel?

  • William Kucharski Level 6 Level 6 (14,405 points)

    StephTizio wrote:

     

    Now my MBP has developed a new connection headache; it cannot see the wireless network that every other device in the house (PC and Apple) finds instantly with ease.

     

     

    Anyone contemplating the purchase of an MBP should know that it's a crapshoot. If you get stuck, you're out of luck. Caveat Emptor.

    Maybe a Mac ace would like to trade with me and see if he/she can figure out what's up with the MBP 15" before investors hear about Apple's Achille's Heel?

     

    As for your connection issue, have you tried simply moving your Mac around to see if there is a location where it can see the network?

     

    As far as being out of luck, it depends on whether you're willing to follow debugging steps.  Have you checked to see if there's a firmware update for your router/WAP?

     

    People have been complaining in one way or another about AirPort since it was first introduced, across a variety of versions of Mac OS and hardware revisions.  What you don't hear regularly is the multiude of Windows issues.

     

    For example, I have a MBP, iPhone 4, iPad 2, a LinkSys running Tomato firmware, a TiVO with a wireless adapter and a Wii all connected to my home Wi-Fi network, one that a Dell laptop running XP sitting two feet away from the WAP refuses to connect to.

  • bucky716 Level 1 Level 1 (0 points)

    Having the same issues others are reporting shortly after I installed the most recent updates. 

  • StephTizio Level 1 Level 1 (5 points)

    Dear William K.,

     

    You really don't seem to get it do you?

     

    Thanks anyway.

  • William Kucharski Level 6 Level 6 (14,405 points)

    StephTizio wrote:

     

    Dear William K.,

     

    You really don't seem to get it do you?

     

    Thanks anyway.

     

    I've been helping users debug their issues here at AD for more than a decade now, and I've been in the industry for over twenty years, and am simply basing what I say on my experience.

     

    In this case, given the vast majority of users have no Wi-Fi issues, it's much more likely that connection problems lie with signal conditions or with the other device, something that's held to be true about 90% of the time.

     

    The other 10% of issues are often due to a combination of hardware issues, firmware issues, and Mac OS X bugs.

     

    I know how frustrating these problems can be, as I once went through months of debugging an issue and trying to narrow it down the best I could and it indeed turned out to be a Mac OS X bug that was fixed and remains fixed to this day - none of which detracted from the fact that I wanted to run the MBP I had just purchased at that time through an industrial shredder every time the Wi-Fi connection dropped.

  • Benson-uk Calculating status...

    Hi, I too have been having problems for years with my penryn macbook pro 15.

     

    The problem seemed to dissappear however now it has come back but with a vengence. The wireless is un usable it actually doesnt work. Even though the signal says full bars it just wont load any pages. If i turn it off and back on it will reload one page but then break again.

     

    This really does take the p*** !!!!

     

    It was only a month ago the whole motherboard had to be replace.

     

    No matter how much i love apple i am seriously considering selling up and getting something that actually works!

  • StephTizio Level 1 Level 1 (5 points)

    Let's recapitulate so that anyone new to the discussion gets a feel for what's going on.

     

    I have had 8 months of problems connecting to the Internet with my MBP.

     

    I have experienced at least 4 different types of problems. I have an Airport Extreme at home and my MBP doesn't get along with it either.

     

    I am by far not the only user with one or more forms of connectivity issues.

     

    It appears that a percentage of MacBook Pros (unquantified as of yet) develop wireless issues (the typology is varied) Problems arise either after a certain period, or sometimes right out of the box. Numerous discussions can be found on this topic.

     

    There is no definitive solution to these problems at the moment. Apple itself has not expressed any interest in the wireless difficulties that are constantly arising among MBP users. Unless you are an expert Mac user like William K. and have months to spend on debugging, you are in real trouble.

     

    No one seems to know what is causing this issue (software? firmware? hardware? some combination of these?). They can occur with 3rd party routers and with Apple routers.

     

    Anyone contemplating the purchase of a costly MacBook Pro should be aware that problems with wireless connectivity is a very real issue and will compromise the functioning of your notebook.

     

    I consider this problem Apple's Achilles Heel. I predict that in a relatively short term wireless connectivity issues will re-dimension downward the sales of MBPs.

  • a0b9180 Level 1 Level 1 (0 points)

    I am having wireless issue in all my apple products- two macbooks and two iphone dropping the wireless frequently. I have to shut off the airport (macbook) or wifi settings (in iphone) to get a minute of connectivity. It started recently, and have been approx. two weeks. Wondering, if it's time to switch back to PC from these white elephants.

  • gooober Level 1 Level 1 (25 points)
    Currently Being Moderated
    Jul 15, 2011 2:21 PM (in response to a0b9180)

    Sorry to hear you all are having such great trouble with staying connected wirelessly.

     

    I've never had any troubles myself - except when i had too many bluetooth devices connected to my MBP in the mix.

     

    And to think...windows doesn't have that problem is kind of bizarre. I've had some issues with wireless connectivity with Windows too. It could be a hardware defect. I've had two MBPs so far and no issues except when I add one more bluetooth device other than the Apple bluetooth keyboard and my Magic Tracpad.

     

    iPhone are definitely on the 2.5 ghz band - which is probably what your MBPs are connected on as well. Wireless N seems to have far less issues and much more channels to connect to, but that leaves your iPhones with no way to connect if you set your router to "N only". I got the dual-band Airport Extreme and seems to work ok.

     

    If you live in an apartment complex, for example and are surrounded by 2.5 ghz networks, then you may have to adjust your channel. Wireless N has over 100 to choose from.

  • olefromregstrup Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2011 1:12 PM (in response to gooober)

    Hi All,

     

    I am not sure if this is one or a multitude of problems. I strongly disagree with the people not believing this to be a MBP (newer generation) problem.

     

    The problem for me has been close to constant on my current MBP(Newest generation), while older generations of MBP's have been working just fine. My MBP have had next to no signal whatsoever, but other clients including iphones, older MBP's and pc's has had full signal strength. My router is a time capsule running latest firmware.

     

    My suggestion to people not capable of using the wireless adapter, switch to N only and set it to only operate on the 5 Ghz band (on the router of course). This made all the difference, and I now have full signal strength all the time.

    I am pretty sure it is the firmware which is buggy and not capable of handling the 2,4 Ghz band.

     

    This means however, that I cant have any clients only operating ont he 2,4 Ghz band such as iPhones and older computers, which *****!

     

    Apple, fix it!

     

    Hope this helps others, and that I have not repeated somehting someone else has already written...

  • BasZ Level 1 Level 1 (0 points)

    I am sad to say I am one of those people with MBP connection issues.  faulty router firmware....? No clue. All I know is that I've paid 5 times as much for a laptop, which can't do what my old basic 400 euro laptop could do with ease: stay connected to internet, without having to go through the 'switch airport off, switch airport on' routine...

     

    What I REALLY dont get is that since I've been searching the web for a solution, I've never encountered an official Apple statement recognising this as a flaw...come on guys...this thread alone has over 200.000 views and almost 1000 posts. And thisnthread is only one of the many. It's surely not because is such interesting reading material... I am not a great lover of Microsoft, but at least they ADMIT when they screw up and do not try to cover it up or ignore it... (anyone recall antenna gate). I must say, I'm mightily disappointed in Apple...

  • olefromregstrup Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 12:17 AM (in response to BasZ)

    @BasZ Did you try what I suggested? Switch from 2,4 to 5 Ghz..

  • BasZ Level 1 Level 1 (0 points)

    Hi Ole,

     

    My router unfortunately only operates on 2.4GHz. I did switch to the 20MHz band only and set it to N only. Hope it'll work.

     

    I just found out my brand new iPad2 is losing connection all the time as well...waiting for half a minute and renewing the DNS lease gets connection back, but this is also as annoying as !#@$.

     

    If the problem IS my router (Sitecom WL341), which router would you recommend me to use? Please note that I've never experienced any connection problems with my router before I switched to Apple.

     

    Thanks!

     

    Bas.

1 ... 64 65 66 67 68 ... 133 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (38)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.