Skip navigation

Internal audio has gone missing

653 Views 5 Replies Latest reply: Apr 27, 2012 8:18 PM by danitaz RSS
Tom Wolsky Level 10 Level 10 (104,615 points)
Currently Being Moderated
Jul 12, 2011 8:33 AM

Has anyone seen this problem? It's a new MBP and I can't get any internal audio output.

 

004.png

15" 2.2G i7 MacBook Pro, Mac OS X (10.6.7)
  • Allan Jones Level 7 Level 7 (29,570 points)
    Currently Being Moderated
    Jul 12, 2011 8:46 AM (in response to Tom Wolsky)

    Hi Tom,

     

    Peek in the digital audio port. Can you see a red light glowing?

     

    If so, a slightly out-of-spec analog audio plug has likely jammed the digital port (tighter specs) in the MUTE position. Apple's official fix is to replace the logic board, but most people area able to fix it by putting a plug in the port and GENTLY wiggling it in the horizontal plane.

     

    I've found with both my MBP and a circa 2003 PowerBook G4 that most analog plugs will deliver proper output and stereo separation long before the stop shoulder on the plug touches the case. The plug is held firmly enough to stay put for normal usage. It's inserting the plug "to the hilt," so to speak, that jams the MUTE contact.

     

    I've taken to putting on headphones or turning on external speakers BEFORE plugging them into my notebooks. I insert the plug slowly until I hear proper sound, then stop pushing. No jams since adopting that procedure.

     

    If there is no red light, I'd head for the Apple Store or AASP. Although some say an SMC reset will fix the muting in the absence of the red light clue, I'd let Apple work on a new computer.

     

    I'll try so get a picture later today of what mine looks like with the plug in a functional position. I recall the stop shoulder being between 1/16- and 1/8-inch from touching the case on either notebook model I have.

  • Allan Jones Level 7 Level 7 (29,570 points)
    Currently Being Moderated
    Jul 12, 2011 9:33 AM (in response to Tom Wolsky)

    Sorry about that. It's the headphone port.

     

    Instructions on the SMC reset are here:

     

    http://support.apple.com/kb/HT3964

     

    Scroll down to find the link for specific product groups. If your MBP does not have a user-serviceable battery, you'd use this one:

     

    Resetting the SMC on portables with a battery you should not remove on your own

  • danitaz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 27, 2012 8:18 PM (in response to Allan Jones)

    By the way, I was searching for the same problem, and this answer seems to have fixed my issue as well!  I shall be more careful about putting the headphone plug in!

     

    Thanks.

     

    Danita

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.