Skip navigation

Aperture corrupting images during editing

6045 Views 49 Replies Latest reply: Apr 4, 2014 4:44 AM by DG1234567 RSS
  • shuttersp33d Calculating status...
    Currently Being Moderated
    Jul 15, 2011 11:49 AM (in response to Sielk)

    Have you tried importing with any other app to see if you get the same results?

     

    Have you tried importing into iPhoto or Image Capture?

     

    Just some more steps on narrowing down whether it's an Aperture issue or System.

  • Thomas Boyd Calculating status...
    Currently Being Moderated
    Jul 16, 2011 9:12 AM (in response to shuttersp33d)

    This could be a card reader/cord problem. I've seen this happen before. Try running tests to eliminate the card reader as a problem. If you opened the masters in Preview and they are corrupted it's probably not Aperture.

     

    Try opening the master files in Preview from the Finder, not exported from Aperture.

     

    Send one of the masters to a friend and see what happens when they open it on a different computer in something like Photoshop.

     

    Try opening the corrupted master in Preview and doing a Save As to JPEG.

     

    Try copying images from your card reader to the finder and seeing if they are corrupt.

  • léonie Level 8 Level 8 (46,355 points)
    Currently Being Moderated
    Jul 18, 2011 3:29 AM (in response to Sielk)
    I am fairly confident this is not an import issue.  Photos are getting coorupted during the editing process or the export process.  ...........   Also I opened an old library from several months ago where I know there was no corruption and now I am seeing several photos with the issue.

    Those are exactly the symptoms I observe with my Aperture Library.

    I own two MacBook Pros, on both do occur the same random corruptions during editing on images that have been o.k. a year ago.

     

    And it also occured after I created a brand new test account to prevent bad preferences and worked with a copy of the Library from the new account - on both machines. On both machines I made several test with the Aperture Library  residing on different partitions of the internal disk or on an external disk. The problem persisted.

    So I'm pretty sure it isn't a hardware problem.

     

    Leonie

  • Ernie Stamper Level 8 Level 8 (37,430 points)
    Currently Being Moderated
    Jul 18, 2011 6:18 AM (in response to Sielk)

    Did I understand you to say earlier that you have Photoshop?  If so, have you tried importing simply to a folder, and from that folder only open the RAW and then edit only in Photoshop?

     

    Ernie

  • Jim Warthman Level 1 Level 1 (125 points)
    Currently Being Moderated
    Jul 18, 2011 7:02 AM (in response to Sielk)

    Sielk, when you import your RAW files, are you importing as "managed" or "referenced"?

     

    What happens if you switch to the other method?

     

    Thanks,

     

    Jim

  • Ernie Stamper Level 8 Level 8 (37,430 points)
    Currently Being Moderated
    Jul 18, 2011 7:05 AM (in response to Sielk)

    That certainly frames up the issue, but I have never had this happen with RAWs from my Nikon cameras, nor with the few that I have from the CR2 files shot with a friend's Canon EOS DIGITAL REBEL XTi.  Very odd!

     

    Ernie

  • Ernie Stamper Level 8 Level 8 (37,430 points)
    Currently Being Moderated
    Jul 18, 2011 9:55 AM (in response to Sielk)

    I think since you earlier reported finding the masters in the Package of the Library in the Masters folder, that you are using Managed.  A Referenced Library would allow importing to leave them in their current location, or to import them to be located on another drive, and outside of the Library.

     

    Wish I had a sample of some images from your camera to test this out on my setup.

     

    Ernie

  • Ernie Stamper Level 8 Level 8 (37,430 points)
    Currently Being Moderated
    Jul 18, 2011 10:04 AM (in response to Sielk)

    Do you have a web site to which you can upload the RAW files, and from which they could be downloaded?  Or if you use YouSendIt, an email address for me can be found by clicking on my name to the left, and looking in the bio line of the resulting Profile.

     

    They would be too large to directly email, I would expect.

     

    I am curious about what Graphic Converter would report about the file if it were asked to open one of them.

     

    Ernie

  • MacCanon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 31, 2011 1:12 PM (in response to Sielk)

    Sielk: did you solve this problem? I'd like to know as I'm struggling with the same... Any help is welkom.

  • dustobub Calculating status...
    Currently Being Moderated
    May 3, 2012 12:57 PM (in response to Sielk)

    I really hope there is a solution to this issue out there somewhere. I just encountered it this week and have been thoroughly scared by it to the point of downloading Lightroom. I've seen two versions of this bug, one where the raw (NEF from D800/D7000 in my case) is truly corrupted and has to be restored from backup, and another where I see corruption on the image when viewing 100%, but if I export the Master to my desktop and re-import, the corruption is not visible on the new file.

     

    I am running a 2011 MacBook Air i7 and OSX Lion and Aperture up-to date as of 5/3/2012.

     

    Has anyone found a solution to this issue? I am particularly worried as the corruption doesn't show up on the thumbnails, and seems to happen at random to pictures that have been perfectly fine for months. And since Time Machine is a rolling backup, I have no way to gurantee good backups. I guess I'll take a static backups every week or so until I find a solution to this.

     

    Thanks,

    Dustin

  • William Lloyd Level 6 Level 6 (19,205 points)
    Currently Being Moderated
    May 3, 2012 3:13 PM (in response to dustobub)

    Aperture isn't corrupting the images.  Every time I've seen or heard of this issue, it's either a faulty card reader, or a problem with the CF card itself.  Aperture _never_ modifies the original files.

     

    Try copying files straight to the local drive first, then viewing them in Preview and seeing what's going on.  If they're OK, then import them into Aperture from there.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.