Skip navigation

I get "error code 0x80020022" when I try to write to disc.

105083 Views 181 Replies Latest reply: Mar 18, 2014 2:31 PM by krbusby RSS Branched to a new discussion.
  • diveactive Level 1 Level 1 (0 points)

    yes why would one want to put less then 4 GB files size onto a duel layer 8GB dvd?

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Just did a fresh install of 10.6.3 to new hard drive in an older MacBook (1.83, white). Updated all to 10.6.7. Booting from a 10.5.8 Firewire drive, the optical drive burns CDs, no problem. From 10.6.7 = error.

  • Motorcycle Michael Level 1 Level 1 (115 points)

    BTW: I see this topic has "branched to a new discussion," but I'm not allowed to view the new discussion. Nothing like being locked out of a discussion group while trying to solve a problem.

     

    Going to erase HDD, install 10.6.3 from OS DVD again (current, fresh from Apple) and try the CD burner w/o applying any updates. If that doesn't work, guess I'll havta erase/install again and go backwards to 10.5.8.

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Optical drive works full-speed (burns CD at 24x) under 10.6.3. In this case it would appear something between 10.6.3 and 10.6.7 breaks disc burning. your results may vary.....

    Drive is a Matshita CD-RW CW-8221 (Combo drive).

  • diveactive Level 1 Level 1 (0 points)

    I have to say this to you all, This is an ever forgoing brick wall that I have just found out that apple fitted bad sub grade super drives.

     

    It has to be replaced with a higher brand like :

    Apple continually ships its computers with Matshita drives, which a sub-par drives.  If you check out reviews online, they are not rated well.  There is a high failure rate with them.

     

    I have replaced mine with a Hitachi drive.  Both Hitachi and LG make the best (highest rated) drives.  It ***** to spend the money, but it's the ony way to fix this problem.

     

    You will not find a response from Apple computer ANYWHERE about this issue.

    As I said before some lower grade disks work better but , thats not the point having an expensive 9000 rm apple mac to do the JOB

    I have been told to take it up with trading standards.  Why should we have to endure these problems. Apple are only interested if they are making money out of it. However i must say when you have a warrantee when I did. Apple are the best for putting things right. Hats of to mac Australia for that.

    But as for this drive thing. Ummmm

  • diveactive Level 1 Level 1 (0 points)

    How do you install or replace the up date for the drive. Mine is burning discs  but not dual layer 8 gig. only some.

     

    unlike window is there not a fix driver for the super drive.  If i can fix the problem . then it would save allot of hassle writing letters. And phone calls.

  • Apu9mm Level 1 Level 1 (0 points)

    I read through the whole discussion and I think I didn't see anywhere an answer. I also had the problem and was skimming through the forums. However, there is apparently a pretty simple workaround, which lets me burn DVDs now.

     

    I just don't work with the .fpbf burning folder anymore. I highlight the files I want to burn in Finder, right-click on Burn "xyz" to Disc and when promted, put in the DVD. That's it.

     

    Before that, I had tried a bunch of DVD brands and various speeds but had laid the DVD already in and clicked on Open with Finder when the empty DVD was recognized. Nothing worked. Now I have no problems anymore.

     

    Please see if this works for you too and post your results. Thanks in advance.

  • diveactive Level 1 Level 1 (0 points)

    Not quite following

  • diveactive Level 1 Level 1 (0 points)

    I can burn 4 gig DVD no problem. Its the duel layer 8 gig i cannot burn. Allot of my work takes for gig DVDs using hd dvd and 18 mp files 28 mb and more.

     

    And if they do burn some times the optical drive will not open them. but the PC will. I need a solid step by step fix it.

  • Apu9mm Level 1 Level 1 (0 points)

    There are (at least) 2 ways to burn a DVD with Finder:

     

    1) You put in a blank DVD, you get prompted to select Finder, and a folder is created on your desktop where you drag'n'drop the files you want to burn.

     

    2) You select in a Finder window all files you want to burn by just selecting them, right-click and select Burn "selected files" to Disc. You then get prompted to insert a blank disc. And when you do, burning commences.

     

    The first one will get you a bunch of toasted useless discs, the second will do what you expected to happen.

  • diveactive Level 1 Level 1 (0 points)

    Thats right thats what i do the second one l i high light the fils to be burnt and then go to file and go to burn to disk.

  • .:SiLo:. Level 1 Level 1 (0 points)

    Has anyone tried to use an external burner?


    I have tried a Freecom LightScribe drive on FireWire and get the same error message.

    I also cannot burn (external or Super Drive) when booting from Windows on the same MacBook Pro.

     

    My conclusion is that there is a problem with the EFI upgrade which is included in most of the Combo Updates associated with Leopard and SL. I would like to downgrade to EFI 1.5 from EFI 1.8, but Apple has disabled this ability since owners were installing aftermarket solid-state drives and taking advantage of the faster bit rate. I would urge all of you to Wikipeadia EFI and read about what it does (grossly simplified: it controls hardware at a pre-OS level). I don't think that the Super Drives are to blame at all. To prove it, try an external burner.

  • diveactive Level 1 Level 1 (0 points)

    Ok thank you i will look into that now. Cheers

  • Brian S. Campbell Level 1 Level 1 (75 points)

    U can't burn to single OR dual layer using either of the two methods mentioned by @Apu9mm. I still get the error...

     

    The disc can’t be burned because because communication between the computer and the disc drive failed (error code 0x80020022).

  • Motorcycle Michael Level 1 Level 1 (115 points)

    Suggest checking OS version - some models seemed to have an issue with 10.6.7 (IMHO). Going back to 10.6.6 cured disk burning problems here on a pair of (white) MacBooks - updating to 10.6.8 might work, too.

1 2 3 4 5 6 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.