Skip navigation

iphoto gets spinning beach ball upon opening

1364 Views 9 Replies Latest reply: Mar 25, 2012 11:05 PM by chadvice RSS
eyedoc00 Calculating status...
Currently Being Moderated
Jul 9, 2011 11:15 PM

I have tried re-starting iphoto and re-starting my computer but I still get the spinning beach ball.  What does this mean and how can I fix it?  I do have a time capsule with the most recent back up being July 6th. 

27" iMace i5
  • Terence Devlin Level 10 Level 10 (121,630 points)
    Currently Being Moderated
    Jul 10, 2011 1:37 PM (in response to eyedoc00)

    What version of iPhoto? If it's 09 or later:

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Rebuild iPhoto Library Database from automatic backup.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. .

     

    Regards

     

    TD

  • hendrik7 Calculating status...
    Currently Being Moderated
    Jul 18, 2011 1:12 PM (in response to Terence Devlin)

    I've seen your reply in other threads as well. I can tell you option 1 does not work for me. I'll try option 2.

     

    In my case it looks like it is related to importing movies from my Sony camera. After I connect the camera it goes into beachball mode...

     

    When I Google for iPhoto and beachball too many results turn up. Looks like a very common problem. Rebuilding your library does not solve it, and when it does it takes too much time. I think I'm going to give Picassa at try.

  • eyot08 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2011 1:23 PM (in response to eyedoc00)

    Today I updated iPhoto to 9.1.5 and have exactly the same problem... Before the update it still worked perfectly. Now iPhoto opens, displays photos but immediately after I get an endless spinning beachball.

     

    I've tried the following:

     

    • Created a fresh database (holding ALT) but the problem persists even with an empty library

    • repaired disk permissons

    • uninstalled iPhoto completely incl. preference, cache and any other iphoto files hanging in libraries. Reinstalled iPhoto, updated... Same problem.

     

    Any more suggestions please?!

     

    Thanks very much.

  • eyot08 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2011 1:49 PM (in response to eyot08)

    I just copied over 9.1.3 from another mac over my 9.1.5, but annoyed to find I still have the same problem. Now I am wondering that any of the other iLife updates might have broken my iPhoto. What could it be though??

  • Terence Devlin Level 10 Level 10 (121,630 points)
    Currently Being Moderated
    Jul 18, 2011 1:56 PM (in response to eyot08)

    Create a new account (systempreferences -> accounts) and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

     

     

    Regards

     

     

    TD

  • hendrik7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2011 2:08 PM (in response to eyot08)

    Looks like I've got the same problem you have. I tried iPhoto Library Manager as suggested by Terrence, but it chokes on it as well. After creating a new library iPhote hangs. So what could be the case here is that iPhoto beachballs on ANY library... That is a yes. I just opened iPhote with a library on another volume and it beachballs right away.

     

    I would think that this should be easy to fix for Apple as the number of crash reports must be massive by now.

     

    P.S. I need to have this fixed by thursday, so I can complete the photo quest we had planned for our son's 7th birthday. Anyone know how to transfer photo's to an iPod without iPhoto????

     

    BTW. I've got a 1st generation Intel iMac (32 bits Core Duo). Maybe Apple's focus is a little too much on Lion and they've forgotten about older Macs.

     

    (

    The error iPhoto Library Manager gives me is:

    Apple event timed out ('core'/'getd' (returnID 1) { ---- = object specifier: {objectClass = 'ikwd'; keyForm = 'indx'; keyData = 'abso'($206C6C61$); container = (null)}; rtyp = 'obj '})

     

    Look like some AppleScript timeout.

    )

  • hendrik7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2011 2:28 PM (in response to Terence Devlin)

    I created a new account. In there iPhoto worked OK. Then I connected my camera, and boom there was our colorful beach ball again! So I ended up with one more useless iPhoto instance. After that I gave it another try with a clean user account. This time I downloaded some Flicker images and imported them just fine...

     

    In my case I looks like iPhoto is stuck in some failed import state from which it cannot recover. I have tried rebuilding my library, cleared ~/Library/Cache, trashed my iPhoto prefs, all in vain. There must be some other place iPhoto is storing data that it is accessing. Or some other process is throwing beach balls at it.

  • hendrik7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2011 2:45 PM (in response to hendrik7)

    For my case I may have solved the problem. It looks like iPhoto is trying to communicate with another process. (My own 'joke' from my last reply gave me the hint ;-)) So after some looking around I killed the process MassStorageCamera. After that iPhoto stared fine again.

     

    It leaves me with the problem of importing photo's from my camera (Sony DSC-HX5). Copying them from the SD card to the HD and then importing them will probably work.

     

    Hope this helps others as well, and I hope Apple will fix this.

  • chadvice Calculating status...
    Currently Being Moderated
    Mar 25, 2012 11:05 PM (in response to hendrik7)

    Thanks hendrik7 -- this solved my problem. I used Terminal to look up currently running processes (ps -ef) and then killed the MassStorageCamera process. I'm unsure how I got into this mess, but I was thankful for your insight.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.