Skip navigation

Problem processing RAW images with Lion and 3.1.3

631 Views 8 Replies Latest reply: May 13, 2012 4:58 PM by dbmoore RSS
joefromdc Calculating status...
Currently Being Moderated
Jul 20, 2011 3:13 PM

Images that have "This photo was adjusted using an earlier version of Apple's RAW processing.  Attempting to send to a plug-in or Photoshop results in a dialog "Editing Error This image cannot be rendered for editing because Aperture does not support the image format."  Images that were previously processed with the current version of RAW processing work correctly.

Aperture 3, Mac OS X (10.7)
  • shuttersp33d Level 4 Level 4 (1,540 points)
    Currently Being Moderated
    Jul 20, 2011 4:19 PM (in response to joefromdc)

    Did you attempt to reprocess the RAW files that are displaying that message? Photos > Reprocess Master...

  • kulminho Calculating status...
    Currently Being Moderated
    Oct 24, 2011 4:42 AM (in response to joefromdc)

    I do have exactly the same issue.

    I upgraded to Aperture 3 a few months ago and imported new RAW files (.cr2) from my Canon EOS 50D quite frequently (at least twice a week) and everything has been fine. I am running Lion 10.7.2 and again, everything has worked just fine up until today.

    I uploaded pics directly from my CF card using a card reader and the import worked fine. When going through the pics however every now and again I click on a pic and it turns very dark greenish and gives me the "This photo was adjusted using an earlier version of Apple's RAW processing". These pics are fresh off the camera and have not been previously imported or viewed other then on the camera. When clicking the "reprocess" button, nothing happens.

    I am out of ideas, please help

  • chaz9 Calculating status...
    Currently Being Moderated
    May 12, 2012 6:10 PM (in response to kulminho)

    I just started getting this problem today when shooting in RAW and JPG pairs.  When I go to import just the RAW files, Aperture doesn't see them in my import panel.  When I import both files, the RAW has the green tint you mentioned, and the same message.

     

    Clicking the reprocessing AND then the back arrow seems to somewhat fix the image, but I'm perplexed as to why this just started to happend.  I don't often save pairs, but I have in the past without issue.

     

    Anybody discover the problem? 

  • Valmente Calculating status...
    Currently Being Moderated
    May 13, 2012 1:47 AM (in response to chaz9)

    There is another discussion for problem with raw and the new 10.7.3.1 : my Raw from Panasonic GH2 are green and Aperture says : treatment with old version

     

    I find the solution to correct my RAW : they are green because of the bad WB applied by Aperture.

     

    I put here the solution but I have to correct manually and ask to treatment in the RAW windows for each picture. If it doesn't work, I correct manually the WB.

    https://discussions.apple.com/thread/3942768?start=0&tstart=0

     

    We have to report this bug to Apple.

  • chaz9 Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 13, 2012 2:42 AM (in response to Valmente)

    Valmente,

     

    Thank you for pointing me to that thread.  My problem seemed to be caused by the 10.7.4 upgrade.  I tried the suggestion by Snoop Dogg and this worked for me.

  • dbmoore Level 1 Level 1 (95 points)
    Currently Being Moderated
    May 13, 2012 4:58 PM (in response to joefromdc)

    Joe   I was curious as to why you are still on 3.1.3

    cheers

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.