Skip navigation

Wifi Constantly Dropping in Lion

524138 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • andrewfromwycombe Calculating status...
    Currently Being Moderated
    Jul 21, 2011 12:38 AM (in response to lhale)

    My 2010 MacBook Pro is also having this issue, was fine with osx 10.6, since the upgrade last night there have been numerous WiFi drop outs for no apparent reason,

     

    Reading lots of other web posts makes me think there is a bug somewhere with this new OS, I hope Apple sort soon as its very annoying,

  • fvancamp Calculating status...
    Currently Being Moderated
    Jul 21, 2011 2:09 AM (in response to lhale)

    I have the same problem with my iMac from late 2009. Very frustrating, to say the least and very surprised that this bug hasn't been caught in beta testing! Hopefully Cupertino is aware of these problems by now and the first Lion update is coming our way in just a few days. Until that time I'll bring out my first-generation MacBook Pro with rock solid Snow Leopard...

  • jrwhite82 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 2:57 AM (in response to lhale)

    I'm in the same boat.  Quite annoying.  Turning airport on and off or rebooting gets it to connect again.

     

    Macbook Pro 2010.

  • hteejus Calculating status...
    Currently Being Moderated
    Jul 21, 2011 4:42 AM (in response to lhale)

    My iMac(early 2010) is constantly dropping wifi after upgrading to Lion. All my other devices iPhone and MacBook started dropping internet connection. I see it connected but no access to internet.....

  • Darryl Mylrea Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jul 21, 2011 4:56 AM (in response to lhale)

    Add another to the wifi dropping list!  MBP 2011 i7 and noticed today, while downloading from the App Store, that the connection was down.  Disabling and re-enabling the wifi connection works...for a while, then drops again.

     

    I, too, noticed that pinging something (I used Google's DNS 8.8.8.8) seemed to keep the wifi connection up.

     

    Also, I spend a lot of time yesterday and today just browsing and emailing.  No drops.  Maybe only with constant, high bandwidth usage??

  • JamesWinans Calculating status...
    Currently Being Moderated
    Jul 21, 2011 5:37 AM (in response to andrewfromwycombe)

    Yeah, this has to be a bug. I installed Lion on my Mac Mini yesterday. Prior to the upgrade, I had zero connection issues. Since I upgraded to Lion, my WiFi connection has been up and down constantly. I hope Apple addresses this soon. I know the Wifi is fine, because my iPhone, iPad, and other computers can still get to the internet without issue. Just the Lion computer. No bueno!

  • 393801916 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 6:00 AM (in response to lhale)

    same here.  wifi _and_ ethernet connection is dropping periodically.  turning wifi on/off or un/repluging ethernet cable solves the problem.  (mba / timecapsule).  very annoying.  due to this bug lion is not an option for a production environment yet

  • silicon1138 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 6:02 AM (in response to JamesWinans)

    That's +1 for me also with an iMac from 2010. My macbook and iphone and PS3 are all fine over wifi but the imac is dropping it's download speed every 5 minutes or so. I use MenuMeters to monitor my connection/thruput speeds and i can see the download speed gradually dropping then hitting zero and i can't access anything on the web any more, or emails etc. I have to turn off wifi from the imac's menu, then back on.

    Very annoying when everything else is happily using my airport.

  • jmilleruk Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jul 21, 2011 6:37 AM (in response to lhale)

    I am having the same problem with my Mid 2010 iMac. Before the upgrade to 10.7 I had never had any issues with wifi, and both my iPhone and iPad are staying connected just fine.

  • cueburst Calculating status...
    Currently Being Moderated
    Jul 21, 2011 6:43 AM (in response to lhale)

    Same problem here, I'm on a Mid-2010 iMac.

    My connection was fine on Snow Leopard, but since the upgrade to Lion it drops quite regulary.

     

    I have to turn Air-Port off and on for the connection to come back.

    It does this about 1-2 times an hour.

     

    Hoping this can be resolved soon.

  • Christomopher Calculating status...
    Currently Being Moderated
    Jul 21, 2011 7:30 AM (in response to lhale)

    I am having the same problem.  Installed Lion on three devices, 2010 27" iMac, 2009 13" MacBook and 2010 15" MacBook.  All three devices are behaving the same.  I have an Aiport Utility as my wifi source.  When Lion was installed the wifi worked fine then just dropped.  Played with the wifi for about an hour and had to delete my original network and recreate it, doing this seemed to help the problem for a bit.  This is a total bug and needs to be fixed ASAP. 

  • 393801916 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2011 7:44 AM (in response to Darryl Mylrea)

    using an extra dns on the mac (ie. not the one from the router), seems to be a workaround.

  • andrewfromwycombe Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 21, 2011 7:44 AM (in response to lhale)

    I've been playing with the WiFi settings all morning to try and get it working consistantly and seem to have stopped the disconnection issues...

     

    Not sure which part of this worked but I effectively started with a blank Network Preferences window:

    • Removed WiFi connection and Bluetooth DUN from Network Preferences
    • Created new location in Network Preferences & removed the "Automatic" entry
    • Added new WiFi connection
    • Set DNS address settings to 8.8.8.8 (Google public DNS), and 8.8.1.1
    • Set Service Order to WiFi at the top of the list
    • Reboted router & Macbook

     

    As I said I'm not sure which part of this worked for me but haven't jad a drop out for last 5 hours and that includes large bandwidth downloads as well as general web browsing.

     

    Hope this helps.

  • ndelc Level 1 Level 1 (120 points)
    Currently Being Moderated
    Jul 21, 2011 8:24 AM (in response to lhale)

    I'm having a similar issue, but not exactly the same. I installed Lion on both my MacBookPro 2.4GHZ Core 2 Duo, and my 27" iMac 2.93GHZ Core i7. The MacBook Pro hasn't had any connectivity issues whatsoever, but with the iMac, I have to manually select my wifi network every time it restarts or wakes from sleep. The network shows up and connects right away every time, but I have to do it manually. I haven't lost connection at any other time, however. I've never had connectivity issues with it prior to installing Lion. What's more, I checked the signal strength on both computers and the MacBook Pro listed the RSSI at -46 while the iMac listed it at -34. Both of them are sitting within two feet of the Airport Extreme.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 21, 2011 9:39 AM (in response to jepzman)

    jepzman,

    All I see is the client trying to scan twice frome the logs. I see you are using WEP as your security. Can you try using WPA2-Personal and see if that helps any ?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.