Skip navigation

Wifi won't turn on since upgrade to Lion

74700 Views 278 Replies Latest reply: Dec 2, 2012 11:44 PM by 2yb RSS Branched to a new discussion.
1 2 3 ... 19 Previous Next
kevinrobers Calculating status...
Currently Being Moderated
Jul 21, 2011 3:07 PM

First of all, my apologies if i make alot of gramar/spell errors, english is not my native language.

 

Yesterday i've upgraded my Snow Leopard installation to Lion on my late 2008 macbook pro and from the beginning i am unable to start my Wifi/Airport card. The menu bar shows the wifi icon but with no signal bars. When i click the wifi icon and press 'Turn wifi on' nothing happens. System profiler shows the airport card and when i look in Console i can see that the system recognizes the wifi card and acknowledge it's mac address.

 

What i've tried so far:

- I've created another user account

- I performed a clean install on a second harddrive, same problem

- i rolled back to Snow Leopard and the airport card functions as it should be, this rules out a hardware failure

- I've deleted all files in /library/preferences/SystemConfiguration and rebooted

- I've created a new location with only the Airport card under System preferences - Network

- I've made the airport card inactive and active again

 

I did found some strange messages in Console but they are not very clear: http://imageshack.us/photo/my-images/718/screenshot20110721at102.png/

MacBook Pro, Mac OS X (10.7)
  • crye55 Calculating status...
    Currently Being Moderated
    Jul 21, 2011 11:36 PM (in response to kevinrobers)

    Wifi on Lion is DEAD. Won't turn on.

     

    Had always had a weird issue with Airport/Wifi on this laptop, 2.93 duo. If I would turn off Airport, then turn it back on the machine would freeze. Often when starting up it would freeze (verbose logging startup seemed to point to an Airport issue). Then other times it would start up no problem and Airport would be on.

     

    Today installed Lion. Airport was working fine, was doing emails, browsing. Updated Little Snitch and did a re-start. Since then I cannot get Wifi to turn on. Have disabled LS, thinking that might be the prob. I choose "Turn on Wifi" and nothing happens. In system prefs it won't turn on there either. Click the button and nothing happens.

     

    Have deleted the Wifi out of the interface box and re-added it, thinking that might fix it. Nope.

     

    Under 10.6.8 that interface was called Airport, now under 10.7 it's called Wifi...weird. Is that something Apple changed?

     

    Someone please help. Airport/Wifi is dead on my MBP with Lion.

  • Bert S. O. Calculating status...
    Currently Being Moderated
    Jul 22, 2011 6:00 AM (in response to kevinrobers)

    I have the same problem with my 2008 unibody MacBook. Have now reverted to 10.6.8 again, can't work without wifi.

     

    Aiport card: AirPort Extreme  (0x14E4, 0x8D)

    Firmware: Broadcom BCM43xx 1.0 (5.10.131.42.4)

     

    Looks like the same type as yours Kevin.

  • miliet Calculating status...
    Currently Being Moderated
    Jul 22, 2011 6:22 AM (in response to kevinrobers)

    Hi, the same problem here. I upgraded yesterday to Lion an Wi-fi is death. Only during several minutes i could turn on "Wi-fi" and have signal. I've tried the following but nothing happens:

     

    - Restore permissions.

    - Reset SMC, PRAM and NVRAM.

    - I've created a new location with only the Airport card under System preferences - Network.

    - I've made the airport card inactive and active again.

     

    My card:

     

    AirPort Extreme  (0x14E4, 0x8D)

    firmware:          Broadcom BCM43xx 1.0 (5.100.98.75.6)

     

    Macbook Unibody bought in summer 2009, LION upgraded from SL 10.6.8

     

    I supose is a firmware problem... We'll have to wait!!

  • Bert S. O. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 6:34 AM (in response to kevinrobers)

    It's the firmware version under Snow Leopard indeed. For now I'm postponing the upgrade, I'm working on my thesis and this already cost me a valuable day of work...

  • miliet Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 6:56 AM (in response to Bert S. O.)

    I hope it would be solved soon!! For the moment, it's the only problem with Lion...

  • crye55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 7:16 AM (in response to kevinrobers)

    Mine is still dead, have tried everything in this thread. Here's my report on Network, Wi-Fi:

     

    Software Versions:

           CoreWLAN:    2.0 (200.46)

           CoreWLANKit:    1.0 (100.43)

           Menu Extra:    7.0 (700.42)

           configd plug-in:    7.0 (700.57)

           System Profiler:    7.0 (700.3)

           IO80211 Family:    4.0 (400.40)

           WiFi Diagnostics:    1.0 (100.26)

           AirPort Utility:    5.5.3 (553.20)

     

    Interfaces:

         en1:

           Card Type:    AirPort Extreme  (0x14E4, 0x8D)

           Firmware Version:    Broadcom BCM43xx 1.0 (5.100.98.75.6)

           MAC Address:    xx:xx:xx:xx:xx:xx

           Locale:    FCC

           Country Code:    X0

           Supported PHY Modes:    802.11 a/b/g/n

           Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

           Wake On Wireless:    Supported

           AirDrop:    Supported

           Status:    Off

  • galileo1 Calculating status...
    Currently Being Moderated
    Jul 22, 2011 7:35 AM (in response to kevinrobers)

    I also have the same airport card in my late 2008 macbook and can confirm the WiFi won't turn on. Hopefully we can get a fix soon.

  • davidnowhere Calculating status...
    Currently Being Moderated
    Jul 22, 2011 7:40 AM (in response to kevinrobers)

    Guy's my knowledge about these things are very limited. I think i have exactly the same problems with you guys.

    Can't turn on my wifi at all. What can i do? I only have a wifi connection at home...now i have no access to the internet at all...

  • davidnowhere Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 7:42 AM (in response to davidnowhere)

    by the way my Card type is AirPort Extreme  (0x14E4, 0x8D)

1 2 3 ... 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.