Skip navigation

Wifi Constantly Dropping in Lion

522286 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • ghossegor Calculating status...
    Currently Being Moderated
    Jul 22, 2011 2:41 AM (in response to lhale)

    i have the same issue !!

     

    MBP 2,53 I5 8GB Ram. After a few dropouts WIFI stopped working completely. I tried all the mentioned solutions but it did not help. This issue is with various routers.

  • lorandreas Calculating status...
    Currently Being Moderated
    Jul 22, 2011 2:59 AM (in response to ghossegor)

    More or less the same issues here. WIFI drops after my MAC wakes from sleep. Tried all the suggested solutions, but they did not help. Thought it was my Time Capsule, but it´s the same with other routers as well.

  • francisfromwoolloongabba Calculating status...
    Currently Being Moderated
    Jul 22, 2011 3:11 AM (in response to lhale)

    Me too 27" imac under SL no problems under Lion, the wi fi is droping out. This ***** needs to be fixed apple. Give us a patch.

  • RichardJFK Calculating status...
    Currently Being Moderated
    Jul 22, 2011 3:47 AM (in response to lhale)

    i got the same problem, i can solve this by turning wifi off & back on, but it's annoying and my console shows that something is wrong !!...

    Apple is supposed FIX THIS !!....it's freaking me out, cuz WiFi is constantly dropping every 10-20 minutes or so... Arh!

    At this time, Lion ***... awaiting 10.7.1 or further updates that would make OS X stable and fixed.

     

    Never got a problem with WiFi on SL ....but turned on Lion and here it is.....

  • rjulao Calculating status...
    Currently Being Moderated
    Jul 22, 2011 5:32 AM (in response to lhale)

    3.02 Core2Duo 21.5

     

    Ditto to everything here. Wifi is horrible and definately killing my movie watching.

     

    Plan on wiping and loading Snow Leopard back today.

  • mptskies Calculating status...
    Currently Being Moderated
    Jul 22, 2011 6:42 AM (in response to jasmelthomas)

    This also seems to be working for me. Followed your instructions and haven't had a problem yet. Thanks!

  • Adrianc333 Calculating status...
    Currently Being Moderated
    Jul 22, 2011 8:00 AM (in response to lhale)

    Mine had the same problems as everyone else.

     

    Although i did the following, and i havn't dropped my connection in about 4 hours...

    • Deleted com.apple.aif.plist, found in /HD > Library > Preferences. Then restart computer.
    • Change DNS to Google Public DNS (8.8.8.8 & 8.8.4.4) I'm not sure if this helped, but it was in my process.
    • Rebooted my Router via the Control Panel (eg. 192.168.x.x)

     

    I'm not saying it's how to fix it, but it's helped me a lot!

    Not one problem since doing this, i'll let you know if i drop my connection again.

  • TheAmdMAN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 8:33 AM (in response to TheAmdMAN)

    Wanted to get back to everyone, found a resolution for my issue.  This is for when the network is dropping out completely, not DNS related, not DHCP related, you are getting the disassociated due to inactivity..

     

    Turns out it's the beacon interval on the AP.  I had this issue when SL first came out but they eventually resolved it in an update, now it turns out it's back in Lion...

     

    I had to take my AP beacon interval from 100 to 50.  Careful with this as it will slow down network speed.  I'm going to creep it back up until I find the maximum I can use with the MacBook Pro and Lion but right now 50 is giving me no drops.

     

    FYI, 2 - MacBook Pros exhibit the same problem in the same house, however the iMac had NO issues (older unit, Core 2 Duo).

     

    Good luck.....

  • ndelc Level 1 Level 1 (120 points)
    Currently Being Moderated
    Jul 22, 2011 8:40 AM (in response to Link48010)

    This fixed my issue where my iMac would not automatically reconnect after waking or restarting. The interesting thing is, it had about a dozen networks listed as preferred on my iMac, which has only ever been connected to the network at my house. Some of them were airport hot spots etc., that I have logged onto with my iPhone so somehow that info had been trnsferred to the iMac.

     

    Thanks for the info Link48010!

  • jdfkelly Calculating status...
    Currently Being Moderated
    Jul 22, 2011 8:51 AM (in response to lhale)

    Count me in, too. I've had Lion up and running for twenty-four hours. Hardwired connection works fine, but WiFi won't stay connected for more than a minute. Running an iMac 27" and a Belkin N1. Never had a problem with either one on Snow Leopard.

     

    jk

  • djiti Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 9:27 AM (in response to TheAmdMAN)

    You are a good man, @TheAmdMAN.

    I increased the beacon interval on my AP to 1000 ms a while back because I did not need it more aggressive.

    My WiFi broke with the upgrade to Lion (only pinging my default gateway would keep the link alive for more than 10 seconds).

    I put my beacon interval down to 50 ms as you suggested, and voilà, no drop so far.

  • gcabrera Calculating status...
    Currently Being Moderated
    Jul 22, 2011 9:30 AM (in response to jdfkelly)

    Having same issue, I can't connect to the internet after waking puter from sleep. I have to turn off wi-fi then turn it back on for me to be able to surf.

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 22, 2011 9:53 AM (in response to djiti)

    djiti,

    you should try 100 first as thats the optimum number. Since you had 1000 before, 100 should work for you.

  • Justin Green Level 1 Level 1 (20 points)
    Currently Being Moderated
    Jul 22, 2011 10:06 AM (in response to wifiguru)

    Installed Lion, having wifi drop outs as well. I get this problem when I switch on my Mac and if it goes on standby (when I come back from making the coffee).

     

    Snow Leopard worked 100%, I am thinking of going back to SL. Its only a minor thing, but its now getting annoying.

     

    Hurry up with the patch Apple.

     

  • wifiguru Level 2 Level 2 (230 points)
    Currently Being Moderated
    Jul 22, 2011 10:10 AM (in response to jdfkelly)

    jdfkelly,

    On your Belkin N1, do you have the wireless settings to use HT20/40 in the 2.4 Ghz ? Try using HT20 only and see if it works.

    All the other folk's thats another setting to check for on your wireless router's. In 2.4 Ghz mode, use HT20 only and give it a shot.

1 ... 3 4 5 6 7 ... 152 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.