Skip navigation

Wifi Constantly Dropping in Lion

522776 Views 2,266 Replies Latest reply: Mar 28, 2014 2:35 AM by WSR RSS Branched to a new discussion.
  • ndelc Level 1 Level 1 (120 points)
    Currently Being Moderated
    Jul 22, 2011 10:14 AM (in response to Justin Green)

    Justin,

     

    Have you tried this solution that Link48010 posted above:

     

    "I may have fixed this by going into Network in System Preferences, under Wi-Fi, click Advanced, and remove all prefered networks and then reconnect to your desired Wi-Fi. I have not had it drop yet, I will keep you posted."

     

    It worked for me. There were a bunch of networks listed as preferred that my iMac had definitely never been connected to. When I deleted all but my home network it started working as normally again, logging on automatically after sleep or restart. It was as if it had downloaded the network info from my iPhone and was trying to connect to some of those first. Some were hotspots in airports, hotels, etc., and my iMac has never been connected to any but my home network.

  • Justin Green Calculating status...
    Currently Being Moderated
    Jul 22, 2011 10:37 AM (in response to ndelc)

    thanks for that, I'll give it a go.

  • djiti Calculating status...
    Currently Being Moderated
    Jul 22, 2011 10:59 AM (in response to wifiguru)

    wifiguru,

    http://www.dslreports.com/forum/remark,14241618 is presenting a less black and white picture of the beacon interval. I am giving 100 a try - so far, so good.

  • TheAmdMAN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 12:53 PM (in response to djiti)

    The bad part about the beacon interval is most people here don't know what that is.  To top it off it's also not in any of the troubleshooting guides people keep posting.  It could possibly be a fix that no one is trying.

     

    I've never had a problem with Windows machines in my house or Mac OS X 10.4 with the interval set to the optimum (100).  When I rolled out 10.5 it started causing an issue so I set it to 50, when I got to about 10.6 I tried again back at 100 and it was fixed.  Now all of the sudden it's back again needing to be at 50.  And it's like clockwork too, both MacBook Pros that I have, two generations (2009 & 2010) consistently have the problem with it set at 100.  My 2008 iMac had no issues on either setting with any version of OS, and no Windows PC in my house has the issue.

  • Sheila2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 1:01 PM (in response to TheAmdMAN)

    Um...for those of us who fit into the category of not knowing what the beacon interval is...what is it and how does one re-set it? I'm on a 27" IMac, late 2009.

     

    Oddly, my wi-fi has been stable for nearly 12 hours now, including waking from sleep. But I don't trust it....

  • TheAmdMAN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 2:09 PM (in response to Sheila2)

    If you're having issues on some sort of corporate wirelss then you won't be able to modify the setting.  If you have control of the wifi access point (or wifi router), login and flip through the settings until you see something like advanced wireless settings (sorry every wireless router/ap is different you'll have to check with your vendor for where this setting is located).  Under these settings there will be a value called "Beacon Interval".  This should usually be set to 100.  As djiti pointed out this is in milliseconds (ms).  If you have constant drops and I mean the icon in the upper right corner goes from bold lines to gray lines and you lose all connectivity you may decrement this number until you notice the drops go away.  This does not apply to just not being able to get to the Internet.  This is for a specific drop and a "disassociated due to inactivity" message in your console logs.

     

    I would not go below 50ms on this number as it may cause network slowness issues.  I believe Mac OS X Lion is pretty sensitive and needs to see the beacons consistently or it drops you from the network.  Most other PCs/OSs allow a little flexibility if you lose a few of these.

     

    From what I've read, if there are a lot of wireless networks in your vacinity you may have to adjust this number down from the default of 100 to get consistent network connectivity.

  • Washy21 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 2:11 PM (in response to rjulao)

    Same here.

     

    I have noticed that my entourage mail is not affected when I lift up the screen but all browsers are. So much for improved productivity. At this point in time I wish I hadn't bothered.

     

    I have tried all suggestions and have lost an awful lot of time trying to troubleshoot this.

     

    Come on Apple - sort this out please.

  • poojith Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 22, 2011 3:04 PM (in response to lhale)

    hi,

     

    Go to Network in System Preferences, under Wi-Fi, click Advanced, and remove all prefered networks and then reconnect to your desired Wi-Fi. and also go to proxies tab uncheck use passive FTP mode. its works fine for me.

  • francisfromwoolloongabba Calculating status...
    Currently Being Moderated
    Jul 22, 2011 4:05 PM (in response to lhale)

    Go to Network in System Preferences, under Bluetooht Pan, click the cog and turn to inactive. Since doing this drop out as not occurred again.

  • tvrs3 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 23, 2011 1:47 AM (in response to lhale)

    Late 2006 iMac with Lion I have this issue too. Using Airport Extreme 3rd Gen with 7.5.2 firmware. Connecting over 5Ghz n.

     

    After wake from sleep WiFi connects fine, but DNS doesn't work. I can browse via IP fine. Restarting WiFi fixes things.

     

    Tried everything mentioned here, including:

     

    Resetting SMC.

    Removing Bluetooth PAN.

    Removing and re-adding network settings.

    Fixing IP.

    Adding extra DNS servers.

    Deleting plists and re-setting up network.

    Moving order of services to promote WiFi.

    Switching off TimeMachine.

    Fixing Location / Adding new location.

    Removing all preferred networks.

    Turning round three times while saying the name of the Scottish Play.

     

    Cannot change beacon interval as Airport Extreme doesn't allow that.

     

    Never had any problems with Tiger/Leopard/Snow Leopard. Early MacBook Air runnung Lion connecting fine after sleep.

     

    I think what we have here is a bug. I wonder if Apple will spot/fix it?

  • JalenJade Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 10:42 AM (in response to lhale)

    Well I'll add myself in here as someone with wifi dropping problems since installing Lion. I'm also on an Airport Extereme and cannot modify the beacon interval. I had a 24hr workaround (require admin password to turn wifi off) but as I mentioned to a friend that I thought it was fixed, the wifi dropped shortly after.

  • juanfrombristol Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 12:13 PM (in response to lhale)

    Just connected My Imac to my modem using an ethernet cable,previously i was using Wi-Fi,but kept loosing my connection since i installed Lion,now i've got a good signal.Hopefully it will keep this way until apple decide to release an update.

  • dansoton Calculating status...
    Currently Being Moderated
    Jul 23, 2011 4:42 PM (in response to Link48010)

    I have the same problem with my MBP from mid 2010 in that after it awakens from sleep it doesn't reconnect to the wifi. I click on the wifi icon, it doesn't show any wifi networks, and only then searches for them and finds them then I click on the network I was on just before sleeping and it reconnects.

     

    Very frustrating, and as all the other posters have said, I have never had this problem in SL.

  • AltoCumulus Calculating status...
    Currently Being Moderated
    Jul 23, 2011 8:29 PM (in response to lhale)

    Upgraded to Lion and now iTunes playback drops in and out. We have a Mac mini with a wired connection, iTunes audio output is to 2 Airport Expresses. Songs begin to drop in and out out after a few minutes of playback.

1 ... 4 5 6 7 8 ... 152 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (82)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.